cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3489
Views
0
Helpful
6
Replies

AVAYA IP Phone with Cisco Catalyst switches

kaustav.gupta
Beginner
Beginner

Hi,

I am facing this issue : AVAYA IP pHone when connected to a Cisco catalyst switch configured with Voice VLAN stops when the switch port is configured as a switch port access but when the same port is configured as Voice VLAN and the PC connected to the IP Phone is put in another VLAN the pc stops working but the phone works.Has anybody configured AVAYA IP phone with Catalyst switches.

Regards

kas

1 Accepted Solution

Accepted Solutions

kleo
Participant
Participant

Does it work when if you try and explicit 802.1q trunk ?

like this :

interface FastEthernet0/1

description to IP telephone

switchport trunk encapsulation dot1q

switchport trunk native vlan

switchport trunk allowed vlan 1,,

switchport mode trunk

spanning-tree portfast

Second, how are you placing the phone in the voice vlan and what is the model of phone?

View solution in original post

6 Replies 6

amit-singh
Collaborator
Collaborator

Hi Kas,

is the phone with inline power or the external adaptor support. Please paste the config of the switch and also the show version.

regards,

-amit singh

Int fastethernet mod_num/< port number>

Switchport mode access

Switchport voice vlan 192

Switchport access vlan 21

Spanning-tree portfast

Power inline auto

Mls qos trust cos

kleo
Participant
Participant

Does it work when if you try and explicit 802.1q trunk ?

like this :

interface FastEthernet0/1

description to IP telephone

switchport trunk encapsulation dot1q

switchport trunk native vlan

switchport trunk allowed vlan 1,,

switchport mode trunk

spanning-tree portfast

Second, how are you placing the phone in the voice vlan and what is the model of phone?

gopikrish
Beginner
Beginner

hi

configure the ports in trunk mode because in your configuration you configured the port in acess mode so it wont allow more than one vlan through the switch port

This is not how it works with the newer (2950 upwards) switches; only the 2900XL & 3500XL required the port to be specifically set as a trunk. The newer switches can be set to access ports with a voice vlan as described by an earlier poster.

I would have thought the problem lies with how the internal switch-port in the Avaya phone is configured. Generally you can set the IP Phone to set one 802.1q tag for itself and either no tag or a data vlan tag for the attached PC. The actual traffic between the PC and the IP Phone is untagged but the Phone can add on a tag and send it to the Cisco switchport.

How is the Avaya stuff configured? It may be worth hard-coding a port as a trunk and then setting up a span session to see what traffic is coming from the IP Phone, specifically what VLAN tags are you seeing.

HTH

Andy

loizosko
Beginner
Beginner

a couple things.

your port config is fine. 

on your dhcp server make the following settings

on your scope for DATA vlan (21)

option 242 L2Q=1,L2QVLAN=192,VLANTEST=0

on your scope for voice vlan (192)

MCIPADD=192.168.10.10,MCPORT=1719,HTTPSRVR=192.168.10.10,VLANTEST=0

where 192.168.10.10 is your avaya system

you can also have more than one address there

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers