cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
769
Views
0
Helpful
5
Replies

Can't get inter-vlan routing

gabrielcrespo
Beginner
Beginner

Good evening,

I'm trying to get inter-vlan routing without any success. My scenario is as follows:

All switches are Catalyst 2960S

Switch 1: Ports 1 - 22 VLAN 110. Port 16 connected to router 1

Switch 2: Ports 1 - 22 VLAN 120. Port 16 connected to router 1

Switch 3: Ports 1 - 10 VLAN 130. Port 8 connected to router 1

Router is Cisco 2901 + 8 etherswitch ports

Router 1: etherswitch port 1 connected to switch 1

              etherswitch port 2 connected to switch 1

              etherswitch port 3 connected to switch 1

I need to route some traffic among these three vlans, but nothing I have tried works. Any ideas?

Here you have the config for 1 switch and the router:

Building configuration...

Current configuration : 4416 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname switch1

!

boot-start-marker

boot-end-marker

!

!

aaa new-model

!

!

!

!

!

aaa session-id common

!

!

no ip domain-lookup

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

!

vlan internal allocation policy ascending

!

ip ssh version 2

!

!

interface Port-channel1

switchport mode trunk

!

interface FastEthernet0

no ip address

shutdown

!

interface GigabitEthernet1/0/1

switchport access vlan 110

!

interface GigabitEthernet1/0/2

switchport access vlan 110

!

interface GigabitEthernet1/0/3

switchport access vlan 110

!

interface GigabitEthernet1/0/4

switchport access vlan 110

!

interface GigabitEthernet1/0/5

switchport access vlan 110

!

interface GigabitEthernet1/0/6

switchport access vlan 110

!

interface GigabitEthernet1/0/7

switchport access vlan 110

!

interface GigabitEthernet1/0/8

switchport access vlan 110

!

interface GigabitEthernet1/0/9

switchport access vlan 110

!

interface GigabitEthernet1/0/10

switchport access vlan 110

!

interface GigabitEthernet1/0/11

switchport access vlan 110

!

interface GigabitEthernet1/0/12

switchport access vlan 110

!

interface GigabitEthernet1/0/13

switchport access vlan 110

!

interface GigabitEthernet1/0/14

switchport access vlan 110

!

interface GigabitEthernet1/0/15

switchport access vlan 110

!

interface GigabitEthernet1/0/16

switchport access vlan 110

!

interface GigabitEthernet1/0/17

switchport access vlan 110

!

interface GigabitEthernet1/0/18

switchport access vlan 110

!

interface GigabitEthernet1/0/19

switchport access vlan 110

!

interface GigabitEthernet1/0/20

switchport access vlan 110

!

interface GigabitEthernet1/0/21

switchport access vlan 110

!

interface GigabitEthernet1/0/22

switchport access vlan 110

!

interface GigabitEthernet1/0/25

!

interface GigabitEthernet1/0/26

!

interface TenGigabitEthernet1/0/1

!

interface TenGigabitEthernet1/0/2

!

interface Vlan1

no ip address

!

interface Vlan110

ip address 192.168.50.11 255.255.255.192

!

end

=============================================

Building configuration...

Current configuration : 4382 bytes

!

! Last configuration change at 15:50:43 UTC Wed Feb 20 2013 by sshuser

! NVRAM config last updated at 15:50:54 UTC Wed Feb 20 2013 by sshuser

! NVRAM config last updated at 15:50:54 UTC Wed Feb 20 2013 by sshuser

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname router01

!

boot-start-marker

boot-end-marker

!

!

logging buffered 51200 warnings

!

no aaa new-model

!

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

!

no ip domain lookup

ip domain name yourdomain.com

!

multilink bundle-name authenticated

!

!

!

!

!

voice-card 0

!

!

!

!

!

!

!

hw-module pvdm 0/0

!

hw-module pvdm 0/1

!

!

!

!

redundancy

!

!

!

!

!

!

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

ip address 10.10.10.1 255.255.255.248

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface BRI0/2/0

no ip address

encapsulation hdlc

shutdown

!

interface GigabitEthernet0/1/0

no ip address

!

interface GigabitEthernet0/1/1

description Simulation

switchport access vlan 120

no ip address

!

interface GigabitEthernet0/1/2

description Operational

switchport access vlan 110

no ip address

!

interface GigabitEthernet0/1/3

no ip address

!

interface GigabitEthernet0/1/4

no ip address

!

interface GigabitEthernet0/1/5

no ip address

!

interface GigabitEthernet0/1/6

no ip address

!

interface GigabitEthernet0/1/7

no ip address

!

interface Vlan1

no ip address

!

interface Vlan110

description "Operational VLAN"

ip address 192.168.50.4 255.255.255.192

standby 234 ip 192.168.50.6

standby 234 priority 250

!

interface Vlan120

description "Simulation VLAN"

ip address 192.168.50.132 255.255.255.192

standby 235 ip 192.168.50.134

standby 235 priority 250

!

ip forward-protocol nd

!

!

!

!

!

!

!

!

!

control-plane

!

!

!

!

mgcp profile default

!

!

!

!

!

end

1 Accepted Solution

Accepted Solutions

Hello Gabriel.

The best way to accomplish this implementation is:

You have 2960s, they are nice switches, they can do intervlan routing. I hope they are not in production cause we will need to reboot them at some time during the confiugiration change.

1- Go to global configuration mode.

2- Change the SDM template to lanbase-routing. ( requirement: You need to run at least 12.2(55) )

3- We need to reload the switch for changes to take effect.

4- Go to global configuration mode.

5- Enable ip routing, enter the command "ip routing"

6- Create the interface vlans as you need.

7- Finally have a static route pointing all unknown traffic to the router, just in case they need to go out the local lan.

Regards.

Wilson B.

View solution in original post

5 Replies 5

kcnajaf
Rising star
Rising star

Hi Gabriel,

From your description what i can understand is that you have three cables going from your router to the same such as switch as described below..Is in it? Not sure why you have three cables between these device

etherswitch port 1 connected to switch 1

etherswitch port 2 connected to switch 1

etherswitch port 3 connected to switch 1

Currently you have these ports configured as access ports. You could just use one cable between the router and switch and confgure the both ends as trunk port rather than access and try reaching between the vlans. That should help i assume.

Regards

Najaf

Please rate when applicable or helpful !!!

Hello Najaf,

Thank you for answering.

It looks like I have not explained very well :s What I have are three switches connected to the same router. In the router, every cable is connected to the ports in the module "EHWIC-D-8ESG", which looks to have 8 L2 ports.

Hope you can help me.

Regards,

Gabriel

Hello Gabriel.

The best way to accomplish this implementation is:

You have 2960s, they are nice switches, they can do intervlan routing. I hope they are not in production cause we will need to reboot them at some time during the confiugiration change.

1- Go to global configuration mode.

2- Change the SDM template to lanbase-routing. ( requirement: You need to run at least 12.2(55) )

3- We need to reload the switch for changes to take effect.

4- Go to global configuration mode.

5- Enable ip routing, enter the command "ip routing"

6- Create the interface vlans as you need.

7- Finally have a static route pointing all unknown traffic to the router, just in case they need to go out the local lan.

Regards.

Wilson B.

Thank you Wilson. You are absolutely right.

Regards,

Gabriel

Hello Gabriel.

I'm glad it helped.

Regards.,

Wilson B.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers