cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
443
Views
0
Helpful
2
Replies

cisco 3620 & xmodem'ing flash from rommon

volatileacid
Beginner
Beginner

Hello all,

I erased my flash recently and decided to reload through the rommon. I used the command

xmodem -c c3620-ios-etc-etc.bin

to prepare the router to accept a file, and sent it via xmodem on hyperterminal.

After about an hour when it finishes... it automatically starts trying to erase the flash? and I see a list of sectors coming up until it stops with the message:

"flash sector will NOT erase...aborting"

What does that mean!? Is the flash corrupt or damaged ?

It's done this twice in a row?

I've also tried using another option with the xmodem command, the -r option copy's the image to DRAM for launch...

and that worked fine... apart from the fact that when I reboot again, as it was running from DRAM, it's all lost.

help me please.. google throws up nothing with regard to that error message.

2 Replies 2

Georg Pauwen
VIP Master VIP Master
VIP Master

Hello,

can you try and manually erase the flash with the ´erase flash´ command and then try the procedure again ?

Regards,

Georg

thanks for your response.

I have just erased the flash, and it showed a whole series of e's across the screen IIRC as it cleared the flash, but again, i'm getting the same error at the rommon prompt when I xmodem the file down to the router and it tries to clear the flash again before installing....

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: