cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
366
Views
0
Helpful
1
Replies

Cisco 806 and Cable modem setup help

wliporace
Level 1
Level 1

I am new to cisco routing and firewall configuration. I purchased a Cisco 806 to act as router and firewall. My cable modem gives out a DHCP address.

I would like to have the router recieve and address from the cable modem. Then I would like to have the router issue DHCP addresses to my LAN.

Can some one help me with this one? I have not been able to find help files or sample config files.

TNX Will

1 Reply 1

mbruner
Level 1
Level 1

Here is a config similar to one that I used on my 806 / cable modem setup:

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Router1

!

enable secret yourenablesecretpasswordhere

!

ip subnet-zero

!

ip dhcp pool DHCP-POOL

import all

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

lease 5

!

ip inspect name myfw cuseeme timeout 3600

ip inspect name myfw ftp timeout 3600

ip inspect name myfw http timeout 3600

ip inspect name myfw rcmd timeout 3600

ip inspect name myfw realaudio timeout 3600

ip inspect name myfw smtp timeout 3600

ip inspect name myfw tftp timeout 30

ip inspect name myfw udp timeout 15

ip inspect name myfw tcp timeout 3600

ip inspect name myfw h323 timeout 3600

!

!

interface Ethernet0

description Inside interface

ip address 192.168.1.1 255.255.255.0

ip nat inside

no ip mroute-cache

no cdp enable

!

interface Ethernet1

description Outside interface.

ip address dhcp client-id Ethernet1

ip access-group 111 in

ip nat outside

ip inspect myfw out

no ip mroute-cache

no cdp enable

!

ip nat inside source route-map traffic interface Ethernet1 overload

ip classless

ip http server

!

!

access-list 50 permit 192.168.1.0 0.0.0.255

access-list 111 deny ip 192.168.1.0 0.0.0.255 any

access-list 111 deny ip 127.0.0.0 0.0.0.255 any

access-list 111 permit icmp any any echo

access-list 111 permit icmp any any echo-reply

access-list 111 permit icmp any any traceroute

access-list 111 permit udp any eq domain any

access-list 111 permit udp any eq bootps any eq bootpc

access-list 111 permit udp any eq bootps any eq bootps

access-list 111 deny ip any any log

no cdp run

!

banner motd ^CNo unauthorized access allowed. All access is monitored!^C

!

line con 0

password somepassword

logging synchronous

login

line vty 0 4

access-class 50 in

password someotherpassword

logging synchronous

login

!

scheduler max-task-time 5000

end

Hope it helps!

Review Cisco Networking for a $25 gift card