cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
979
Views
8
Helpful
8
Replies

ip helper adress & ip dhcp server

middee
Beginner
Beginner

I have to test a network today that is working with DHCP. There is a DHCP server on another location that works fine. I configured a router on another locations (cisco 828) with the following commands:

ip helper address 192.168.1.3 (dhcp server)

ip dhcp-server 192.168.1.3

I've looked things up on the Internet and according to a lot of people this should work. So that the other location (behind the 828 router) can work with DHCP adresses given by the server on yet the other location.

I can ping the server from any location so the connection is just fine. But i need to be sure that i'm not forgetting anything. Is this going to work?

Or do i need to configure another router between the server and the router on the other location?

Well i hope you can help me....fast...thnx!

8 Replies 8

Georg Pauwen
VIP Master VIP Master
VIP Master

Hello,

the command:

ip helper address 192.168.1.3

is only needed on the router when your DHCP clients are not on the same segment. If you have another intermediate router in between your two locations, configure the ip helper command on that router as well.

The command:

ip dhcp-server 192.168.1.3

is used for DHCP clients on your local segment.

Let me know if that is not clear...

HTH,

GP

Thnx for a fast reply!

So if i get it right(got some english problems because..well...im not english). But if i get it right the ip helper command is for DHCP clients on the same subnet? Then i need to use that command to make it work because all clients are on the same subnet and the servers are too.

dhcp server command...for a local LAN? Don't really get that.

Here's some more info:

2 routers, some workstations, and 1 DHCP server.

The DHCP server(192.168.1.3) is connected to a router (192.168.1.10). That router goes through epacity to another cisco router (192.168.5.10). That router is connected to a few 3com switches and the workstations are connected to those switches.

On the 192.168.5.10 router i've done these things:

ip helper-address 192.168.1.3

and

ip dhcp-server 192.168.1.3

On the other router i've only putted the following command(192.168.1.10)

ip dhcp-server 192.168.1.3

Can the workstations recieve a DHCP adresses now?

Hello,

on the router with IP address 192.168.1.10 you need:

ip dhcp-server 192.168.1.3

ip helper-address 192.168.1.3 (on the interface connected to your remote location)

and on the router with IP address 192.168.5.10 you need only the command:

ip helper-address 192.168.1.3 (on thhe Ethernet or FastEthernet interface where your clients are connected to).

HTH,

GP

yeah! that's an answer i need!

Well...im gonna test it, hopefully it works! Thank you.

Just to be sure, here's the configuration of the 192.168.5.10 router:

Current configuration : 1458 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log uptime

!

hostname 2316RX-40

!

no logging buffered

!

ip subnet-zero

!

ip cef

!

!

!

interface Ethernet0

ip address 192.168.5.10 255.255.255.0

ip helper-address 192.168.1.3

no cdp enable

hold-queue 32 in

hold-queue 100 out

!

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 2/32

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

dsl equipment-type CPE

dsl operating-mode GSHDSL symmetric annex B

dsl linerate AUTO

!

interface Dialer0

ip unnumbered Ethernet0

no ip proxy-arp

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp pap refuse

ppp ipcp address accept

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

no ip http server

!

!

dialer-list 1 protocol ip permit

no cdp run

!

line con 0

exec-timeout 0 0

password cisco

login

stopbits 1

line vty 0 4

exec-timeout 30 0

login

length 0

!

scheduler max-task-time 5000

end

Half of this i don't understand, im still learning. But is this router configured right?

Hello,

that should work. Let me know after you have tested if there are still problems.

Regards,

GP

It worked! Thank you so much GP!

DHCP server & helper address on one router, and on another a helper address...works super!

Hello,

great that you got it working. Have fun !

GP

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: