07-22-2003 07:27 AM - edited 03-02-2019 09:01 AM
I have a central Callback server with PRI (3620) which receives callback requests from a 2611 (with up to 5 BRIs) Each BRI has a seperate telephone number (can't change this).
The config is built on rotary dialer and dialer map commands.
The config appears to be functioning correctly and adding channels as load increases BUT the central router (callback server) shows multiple failures in the "show isdn history table".
It appears as if the call comes into the callback server and the callback occurs to the dial string on the first dialer map statement. As the traffic load increases more channels are added. BUT it appears that every time a channel has to be added the router has to fail the previous channels which are already in use (BUSY). By the time the router gets to the 5th BRI it has to fail each of the previous 4 in turn. This is not necessarily causing much delay but it makes monitoring the ISDN calls very awkward. The remot router does not show any failures.
Any ideas how to prevent the failures on ISDN HISTORY?
Call Calling Called Remote Seconds Seconds Seconds Charges
Type Number Number Name Used Left Idle Units/Currency
--------------------------------------------------------------------------------
In 104 ---N/A--- farend 1
Out ---N/A--- 101 farend 311 0
Out ---N/A--- 101 farend 280 0
Out ---N/A--- 101 Failed 0
Out ---N/A--- 102 farend 248 0
Out ---N/A--- 101 Failed 0
Out ---N/A--- 102 farend 216 0
Out ---N/A--- 101 Failed 0
Out ---N/A--- 102 Failed 0
Out ---N/A--- 103 farend 183 0
Out ---N/A--- 101 Failed
Out ---N/A--- 102 Failed
Out ---N/A--- 103 farend 151 0
Out ---N/A--- 101 Failed
Out ---N/A--- 102 Failed
Out ---N/A--- 103 Failed
Out ---N/A--- 104 farend 119 0
Out ---N/A--- 101 Failed
Out ---N/A--- 102 Failed
Out ---N/A--- 103 Failed
Out ---N/A--- 104 farend 87 0
Out ---N/A--- 101 Failed
Out ---N/A--- 102 Failed
Out ---N/A--- 103 Failed
Out ---N/A--- 104 Failed
Out ---N/A--- 101 Failed
Out ---N/A--- 102 Failed
Out ---N/A--- 103 Failed
Out ---N/A--- 104 Failed
-------------------------------------------------------------------------------
07-22-2003 07:50 AM
Can you please post the relevant portions of the callback servers configs that has the dialer maps & the physical interface (if using dialer interface).
Thanks, Mak.
07-22-2003 08:52 AM
Extract of config of Callback server (hq) and Callback Client (farend)
_____________________
CALLBACK SERVER- hq
______________________
!
controller E1 1/0
pri-group timeslots 1-31
description ISDN PRI 1
!
!
interface Serial1/0:15
no ip address
encapsulation ppp
dialer rotary-group 10
dialer-group 1
isdn switch-type primary-net5
no peer default ip address
no cdp enable
ppp authentication chap
ppp multilink
!
interface Dialer10
ip unnumbered FastEthernet0/0
encapsulation ppp
dialer in-band
dialer callback-secure
dialer idle-timeout 10
dialer enable-timeout 1
dialer map ip 172.16.117.251 name mhome class dial1 100008
dialer map ip 172.16.124.251 name farend class dial2 101
dialer map ip 172.16.124.251 name farend class dial2 102
dialer map ip 172.16.124.251 name farend class dial2 1003
dialer map ip 172.16.124.251 name farend class dial2 104
dialer hold-queue 100 timeout 5
dialer load-threshold 1 either
dialer-group 1
no peer default ip address
no cdp enable
ppp callback accept
ppp authentication chap
ppp multilink
ppp timeout multilink link add 2
multilink max-links 7
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.103.253
ip route 172.16.117.0 255.255.255.0 172.16.117.251
ip route 172.16.117.251 255.255.255.255 Dialer10
ip route 172.16.124.0 255.255.255.0 172.16.124.251
ip route 172.16.124.251 255.255.255.255 Dialer10
ip route 172.31.255.201 255.255.255.255 172.16.124.251
ip route 172.31.255.202 255.255.255.255 172.16.117.251
ip http server
!
!
map-class dialer dial1
dialer callback-server username
!
map-class dialer dial2
dialer callback-server username
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101
_____________________
CALLBACK CLIENT- farend
______________________
!
!
interface BRI1/0
no ip address
encapsulation ppp
dialer rotary-group 1
isdn switch-type basic-net3
no cdp enable
ppp authentication chap
ppp multilink
!
interface BRI1/1
no ip address
encapsulation ppp
dialer rotary-group 1
isdn switch-type basic-net3
no cdp enable
ppp authentication chap
ppp multilink
!
interface BRI1/2
no ip address
encapsulation ppp
dialer rotary-group 1
isdn switch-type basic-net3
no cdp enable
ppp authentication chap
ppp multilink
!
interface BRI1/3
no ip address
encapsulation ppp
dialer rotary-group 1
isdn switch-type basic-net3
no cdp enable
ppp authentication chap
ppp multilink
!
interface BRI1/4
no ip address
encapsulation ppp
shutdown
dialer rotary-group 1
isdn switch-type basic-net3
no cdp enable
ppp authentication chap
ppp multilink
!
!
interface Dialer1
ip unnumbered Ethernet0/0
encapsulation ppp
dialer in-band
dialer idle-timeout 16
dialer map ip 172.16.103.251 name hq 200001
dialer hold-queue 100 timeout 5
dialer-group 1
no cdp enable
ppp callback request
ppp authentication chap
ppp multilink
multilink max-links 10
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.103.251
ip route 172.16.103.251 255.255.255.255 Dialer1
ip http server
!
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101
!
07-22-2003 09:01 AM
Apologies the dialer map statements have changed since I recorded the earlier "show isdn history output" The failure behaviour is still the same:
These are the relevant statements for the earlier history output.
dialer map ip 172.16.124.251 name farend class dial2 101
dialer map ip 172.16.124.251 name farend class dial2 102
dialer map ip 172.16.124.251 name farend class dial2 103
dialer map ip 172.16.124.251 name farend class dial2 104
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide