cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
383
Views
0
Helpful
2
Replies

Multiple NAT

c.mac
Beginner
Beginner

Hi all,

Attached are sample configs of 2 routers. What I am trying to do is have 2 separate NATing schemes for 2 different networks.

interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.0

ip nat outside

interface FastEthernet4/0

ip address 192.168.2.1 255.255.255.0

ip nat outside

interface Serial2/5

ip address 172.16.7.1 255.255.255.252

ip nat inside

interface Serial3/1

Discription - T1 To ISP

ip address 206.166.38.226 255.255.255.252

ip route 0.0.0.0 0.0.0.0 serial3/1

ip route 0.0.0.0 0.0.0.0 192.168.1.1

ip route 10.1.7.0 255.255.255.0 172.16.7.2

ip route 10.0.10.0 255.255.255.0 172.16.7.2

How do I nat the 10.1.7/24 block to the 192.168.2/24

and have the 10.0.10/24 block to the 192.168.1/24

Is this possible?

2 Replies 2

c.mac
Beginner
Beginner

OOOps sorry I messed up alittle..here is the correct setup

interface FastEthernet0/0

ip address 192.168.1.2 255.255.255.0

Discription --connects to switch where T1 is at

ip nat outside

interface FastEthernet4/0

ip address 192.168.2.1 255.255.255.0

ip nat outside

interface Serial2/5

ip address 172.16.7.1 255.255.255.252

ip nat inside

interface Serial3/1

Discription - T1 To ISP

ip address 206.166.38.226 255.255.255.252

ip route 0.0.0.0 0.0.0.0 serial3/1

ip route 0.0.0.0 0.0.0.0 192.168.1.1

ip route 10.1.7.0 255.255.255.0 172.16.7.2

ip route 10.0.10.0 255.255.255.0 172.16.7.2

How do I nat the 10.1.7/24 block to the 192.168.2/24

and have the 10.0.10/24 block to the 192.168.1/24

Is this possible?

Use NAT with route maps.

http://www.cisco.com/warp/public/105/nat_routemap.html

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: