cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
265
Views
0
Helpful
1
Replies

NAT on 801 with multi-link

frywool
Level 1
Level 1

I am having trouble setting up an 801 to dial my ISP using multilink and NAT. The router will dial both channels however it doesn't appear to let any traffic to pass through. I suspect that the problem lies with my NAT configuration. Can someone please take a look at the config below and tell me what I am missing.

service password-encryption

!

hostname ##############

!

ip subnet-zero

multilink bundle-name endpoint

isdn switch-type basic-net3

!

interface Ethernet0

ip address 192.168.6.1 255.255.255.0

ip nat inside

no shut

!

interface BRI0

no ip address

no ip directed-broadcast

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap callin

ppp multilink

no shut

!

interface Dialer 0

ip address negotiated

no ip directed-broadcast

encapsulation ppp

ip nat outside

dialer remote-name dialconnect

dialer idle-timeout 7200

dialer string #############

dialer load-threshold 1 either

dialer pool 1

dialer-group 1

ppp authentication chap callin

ppp chap hostname ############

ppp chap password ############

ppp multilink

!

ip nat inside source list 101 interface Dialer0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

!

line con 0

password ############

login

!

line vty 0 4

password ############

login

!

access-list 101 permit ip 192.168.6.0 0.0.0.255 any

access-list 101 permit gre any any

dialer-list 1 protocol ip list 101

1 Reply 1

bash3r
Level 1
Level 1

Here is a config from one of my 804 routers that may be of help to you:

!

service timestamps debug uptime

service timestamps log uptime

service password-encryption

no service tcp-small-servers

no service udp-small-servers

!

hostname sd-804-01

!

enable secret xyz

!

no ip name-server

!

isdn switch-type basic-ni1

pots country US

!

ip subnet-zero

no ip domain-lookup

ip routing

!

interface Dialer 1

description connected to Internet

ip address negotiated

ip nat outside

no ip split-horizon

encapsulation ppp

dialer in-band

dialer idle-timeout 120

dialer string 1112223344

dialer hold-queue 10

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname username

ppp chap password xyz

ppp pap sent-username username password xyz

no ppp multilink

no cdp enable

!

interface Ethernet 0

no shutdown

description connected to EthernetLAN

ip address 10.20.1.1 255.255.255.0

ip nat inside

keepalive 10

!

interface BRI 0

no shutdown

description connected to Internet

no ip address

dialer rotary-group 1

isdn spid1 11122233330101

isdn spid2 11122233340101

!

! Access Control List 1

!

no access-list 1

access-list 1 permit 10.20.1.0 0.0.0.255

!

! Dialer Control List 1

!

no dialer-list 1

dialer-list 1 protocol ip permit

!

! Dynamic NAT

!

ip nat translation timeout 86400

ip nat translation tcp-timeout 86400

ip nat translation udp-timeout 300

ip nat translation dns-timeout 60

ip nat translation finrst-timeout 60

ip nat inside source list 1 interface Dialer 1 overload

!

! DHCP Server

!

service dhcp

ip dhcp excluded-address 10.20.1.1 10.20.1.9

ip dhcp pool 1

network 10.20.1.0 255.255.255.0

default-router 10.20.1.1

dns-server 1.2.3.4 1.2.3.5

!

router rip

version 2

network 10.0.0.0

passive-interface Dialer 1

no auto-summary

!

!

ip classless

!

! IP Static Routes

ip route 0.0.0.0 0.0.0.0 Dialer 1

no ip http server

!

end

Review Cisco Networking for a $25 gift card