cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
441
Views
5
Helpful
8
Replies

Priority Queuing & Qos

raju
Level 1
Level 1

Merry Christmas !

Hello,

We have a 2MB point to point link with the ISP for Internet access for our Company users and BW usage always hits maximum. We are going to introduce the Video conferencing system which we will use same 2 MB line , will have Video conferencing with International customers weekly 3 times and conferencing will last for 1 hour.My request is , during the Video conferencing time, I want to prioritize the H.323 protocol than HTTP protocol on same 2MB line. During normal time, all 2MB should be used for HTTP traffic. In current scenario, I'm stopping the Internet access completely (disable the Proxy service ) during the Video conferencing time. Pls note that this 2MB is configured on Fast ethernet Internet interface on a Router which is connected with Radio link modem (Ericsson device ).

Thanks in advance.

Raju

8 Replies 8

Hello Raju,

is there any other video conferencing going on besides those times when you want to prioritize the H323 traffic ? If so, you could use LLQ n combination with a time-based access list, the configuration would look like this:

ip access-list extended H323

permit tcp any any eq 1720 time-range CONFERENCE

!

time-range CONFERENCE

periodic Tuesday 14:00 to 15:00

periodic Thursday 15:00 to 16:00

periodic Friday 13:00 to 14:00

!

class-map match-all VIDEO

match access-group name H323

!

policy-map VIDEO_CONFERENCE

class VIDEO

priority 2000

!

interface FastEthernet0/0

service-policy output VIDEO_CONFERENCE

If you just have the video conferencing going on 3 times a week, you do not need the time-based access-list. Whenever there is congestion and H323 traffic, the traffic will get the full 2MB bandwidth.

Just be careful that the H323 traffic does not completely saturate the link and causes problems with any routing or other control traffic. You might want to specify only 1.75MB...

HTH,

GP

Thanks GP. It's only between HTTP traffic and H323. I don't want mention specific days like Tues, Thu and Fri with specific timings also .

What I want is, whenever we do initiate the Video conferencing , it should give prioritize to H323 traffic .

Thanks onceagain.

Raju

Hello Raju,

ok. Without the time based access list the config would be:

ip access-list extended H323

permit tcp any any eq 1720

!

class-map match-all VIDEO

match access-group name H323

!

policy-map VIDEO_CONFERENCE

class VIDEO

priority 2000

!

interface FastEthernet0/0

service-policy output VIDEO_CONFERENCE

Regards,

GP

Thanks . Is it possible to allocate BW dynamically ?.Let me put this way. As soon as , Video conferencing session starts using H.323 Protocol, it should give priority to H.323 protocol than HTTP and reserve (allocate) 1 MB for H.323 protocol out of 2 MB . Once the Video conferencing gets over , all 2MB should be used for HTTP traffic and all this should happen in dynamic way instead of doing manual configuration each time.

Have a good weekend.

Regards,

Raju

Hello Raju,

the bandwidth reservation is dynamic with the configuration posted. The way it works is when congestion on the interface occurs, H323 traffic gets priority over all other traffic. When there is no H323 traffic, or no congestion on the interface, all other traffic can use the full bandwidth. That means you can apply the configuration to your device and leave it on there, you do not need to apply it only when the video conferencing occurs.

Does that make sense ?

Regards,

GP

Hello GP,

Got the point. Thanks for that. I'm going to apply the Access list tomorrow, will have Video conferencing with our client and let you know the results.

Thanks.

Raju

hi,

i have a query in this.

it says "when congestion occurs on the interface . so , what does it do with the traffic without congestion , can't i forcefully imply a priority to a certain traffic.

and wat do we mean by congestion here?

Hello,

basically, congestion means that the traffic received on an interface cannot be sent out an interface at the same rate. This results in traffic being dropped, and that's why you need to classify the traffic.

If you want to forcefully prioritize certain traffic, you could use priority queueing, but is is considered legacy and has the disadvantage that traffic in the high priority queue might starve traffic in the lower priority queues.

HTH,

GP