Showing results for 
Search instead for 
Did you mean: 

Switching - Dropped Packets

Level 1
Level 1

We have a network where machines hooked up to the same load balancer on the same subnet with the same gateway/mask information are not able to communicate consistently.

The effect we experiencing occurs when we type "ping ip address". The first packet gets a reply, then we drop 100 packets or so before we start seeing them again for awhile before it breaks again.

I verified that the mac address being resolved matches the target nic.

We set all adapters and ports to ful100 and also tried all on auto.

I verified that the 2k servers we are using don't have tcp or ipsec filters enabled. (Same for GPO.)

We swapped cables. We swapped nics. We swapped out the load balancers with a vanilla switch.

We still see the same thing occuring.

To make it more interesting, I can vpn through the pix above the LB into both boxes and run the ping tests and see the drops between them. So this appears to be a layer 2 issue.

On the LB we aren't seeing drops, discards, or errors. We have tried no VLAN and all in the same VLAN. We verified the ports aren't flapping.


1 Reply 1

Level 6
Level 6

Check if ICMP is blocked or the DF bit is set. You could also check if the drops are related to a certain size of packet by using the extended ping and specifying the packet size in it and checking for what size the packets are dropped. You could also use the tips from this document allthough it might not be directly related to your problem.