cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1573
Views
0
Helpful
5
Replies

Telnet access to a switch from a router.

I am configuring a lab environment. My situation is restricted such that I have to have a router as the entry point for the lab and access the other devices via telnet or ssh from the router itself. 

 

Directly connected to the router (2800) is a catalyst 2900 24 port switch. I want to be able to access this switch via telnet or ssh. Security isn't a huge deal as there isn't anything connected to this network.

 

I have configured vlan1 on the switch with an ip address 10.0.2.2 and on the router vlan1 with ip address 10.0.2.1. I have set the default gateway on the switch  to 10.0.2.1. I have defined a username and password for the switch and set line vty 0 4 to allow telnet connections.

 

Since it wasn't working I recreated the system as best I could in packet tracer and when I run the simulation I am told that the arp request is being blocked because STP is blocking fastethernet 0/24.

 

What am I missing? I assumed that once the switch elected itself root bridge that it would just forward everything? Do I need to disable STP?

1 Accepted Solution

Accepted Solutions

 

I did solve it!

I had tried tagging the port in the switch with vlan 101 like so

 

!
interface FastEthernet0/24
 switchport trunk allowed vlan 1,101
 switchport mode trunk
!

Turns out, perhaps due to the outdated firmware on the switch, that you have to explicitly set it to use dot1q encapsulation.

!
interface FastEthernet0/24
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,101
 switchport mode trunk
!

Thank you for all your help guys!

 

View solution in original post

5 Replies 5

Philip D'Ath
VIP Alumni
VIP Alumni

From what you have described, it wont be anything to do with spanning tree.

 

Are all the interfaces involved (including vlan1 on the switch) in an up state?

 

Anything interesting in the router or switch log?

All interfaces are showing up in the switch and the router. Both logs are empty. Ill attach my configurations, I removed some lines from them. Also my apologies, I am using vlan 101 instead of vlan 1.

It might be important that the switch isn't showing up in arp in the router. I think what is happening is that the router's arp request is being dropped by the switch, not the telnet request.

Think you have two choices, put everything in VLAN 1, or adjust the trunking to make VLAN 101 the native VLAN:

Router:

!
interface GigabitEthernet0/1.101
 encapsulation dot1Q 101 native

!

Switch

!

interface FastEthernet0/##

switchport trunk native vlan 101

!

 

 

 

I did solve it!

I had tried tagging the port in the switch with vlan 101 like so

 

!
interface FastEthernet0/24
 switchport trunk allowed vlan 1,101
 switchport mode trunk
!

Turns out, perhaps due to the outdated firmware on the switch, that you have to explicitly set it to use dot1q encapsulation.

!
interface FastEthernet0/24
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,101
 switchport mode trunk
!

Thank you for all your help guys!

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: