05-23-2003 09:07 AM - edited 03-02-2019 07:36 AM
--begin ciscomoderator note-- The following post has been edited to remove potentially confidential information. Please refrain from posting confidential information on the site to reduce security risks to your network. -- end ciscomoderator note --
i connect from a pc ( modem ) to cisco2511 ( another modem ). when recieved connect and verify username / password , it disconnect.
i use "login local" ( not radius or tacacs ) and use "ppp". the config is :
=======================================================
Current configuration:
!
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cisco2511
!
enable secret 5 --moderator edit--
enable password --moderator edit--
!
username --moderator edit-- password 0 --moderator edit--
!
!
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface Group-Async1
ip unnumbered Ethernet0
encapsulation ppp
ip tcp header-compression passive
async mode interactive
peer default ip address pool setup_pool
ppp authentication chap pap
group-range 1 16
!
router igrp 1
redistribute connected
network 192.168.1.0
network 192.168.10.0
!
ip local pool setup_pool 192.168.1.201 192.168.1.216
ip classless
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
snmp-server community public RO
!
line con 0
line 1 16
autoselect during-login
autoselect ppp
login local
modem Dialin
speed 115200
flowcontrol hardware
line aux 0
line vty 0 4
password --moderator edit--
login
!
end
==========================================================
please help me how to correct this problem.
05-23-2003 10:02 AM
Please post the outputs of the following debugs when the call fails:
deb modem / deb ppp nego / deb ppp authent
http://www.cisco.com/warp/public/471/nm-xam_dialin.html
Thanks, Mak.
05-27-2003 05:25 PM
debug output is :
=========================================================
Cisco2511#
2d13h: TTY6: DSR came up
2d13h: tty6: Modem: IDLE->READY
2d13h: TTY6: EXEC creation
2d13h: AAA: parse name=tty6 idb type=10 tty=6
2d13h: AAA: name=tty6 flags=0x11 type=4 shelf=0 slot=0 adapter=0 port=6 channel=0
2d13h: AAA/AUTHEN: create_user (0x18ECD8) user='' ruser='' port='tty6' rem_addr='async/' authen_type=ASCII service=LOGIN priv=1
2d13h: AAA/AUTHEN/START (159376357): port='tty6' list='' action=LOGIN service=LOGIN
2d13h: AAA/AUTHEN/START (159376357): using "default" list
2d13h: AAA/AUTHEN/START (159376357): Method=RADIUS
2d13h: AAA/AUTHEN (159376357): status = ERROR
2d13h: AAA/AUTHEN/START (159376357): Method=LOCAL
2d13h: AAA/AUTHEN (159376357): status = GETUSER
2d13h: TTY6: Autoselect(2) sample 80
2d13h: AAA/AUTHEN/CONT (159376357): continue_login (user='(undef)')
2d13h: AAA/AUTHEN (159376357): status = GETUSER
2d13h: AAA/AUTHEN/CONT (159376357): Method=LOCAL
2d13h: AAA/AUTHEN/LOCAL (159376357): no username: GETUSER
2d13h: AAA/AUTHEN (159376357): status = GETUSER
2d13h: TTY6: Autoselect(2) sample 8080
2d13h: AAA/AUTHEN/CONT (159376357): continue_login (user='')
2d13h: AAA/AUTHEN (159376357): status = GETUSER
2d13h: AAA/AUTHEN/CONT (159376357): Method=LOCAL
2d13h: AAA/AUTHEN/LOCAL (159376357): no username: GETUSER
2d13h: AAA/AUTHEN (159376357): status = GETUSER
2d13h: TTY6: Autoselect(2) sample 808080
2d13h: AAA/AUTHEN/CONT (159376357): continue_login (user='')
2d13h: AAA/AUTHEN (159376357): status = GETUSER
2d13h: AAA/AUTHEN/CONT (159376357): Method=LOCAL
2d13h: AAA/AUTHEN/LOCAL (159376357): no username: GETUSER
2d13h: AAA/AUTHEN (159376357): status = GETUSER
2d13h: TTY6: Autoselect(2) sample 808080F8
2d13h: TTY6: Autoselect(2) sample 8080F880
2d13h: AAA/AUTHEN/CONT (159376357): continue_login (user='')
2d13h: AAA/AUTHEN (159376357): status = GETUSER
2d13h: AAA/AUTHEN/CONT (159376357): Method=LOCAL
2d13h: AAA/AUTHEN (159376357): status = GETPASS
2d13h: TTY6: Autoselect(2) sample [suppressed--line is not echoing]
2d13h: TTY6: Autoselect(2) sample [suppressed--line is not echoing]
2d13h: TTY6: Autoselect(2) sample [suppressed--line is not echoing]
2d13h: TTY6: Autoselect(2) sample [suppressed--line is not echoing]
2d13h: TTY6: Autoselect(2) sample [suppressed--line is not echoing]
2d13h: TTY6: Autoselect(2) sample [suppressed--line is not echoing]
2d13h: TTY6: Autoselect(2) sample [suppressed--line is not echoing]
2d13h: TTY6: Autoselect(2) sample [suppressed--line is not echoing]
2d13h: AAA/AUTHEN/CONT (159376357): continue_login (user='x')
2d13h: AAA/AUTHEN (159376357): status = GETPASS
2d13h: AAA/AUTHEN/CONT (159376357): Method=LOCAL
2d13h: AAA/AUTHEN (159376357): password incorrect
2d13h: AAA/AUTHEN (159376357): status = ERROR
2d13h: AAA/AUTHEN/START (249933881): port='tty6' list='' action=LOGIN service=LOGIN
2d13h: AAA/AUTHEN/START (249933881): Restart
2d13h: AAA/AUTHEN/START (249933881): no methods left to try
2d13h: AAA/AUTHEN (249933881): status = ERROR
2d13h: AAA/AUTHEN/START (249933881): failed to authenticate
2d13h: AAA/AUTHEN: free_user (0x18ECD8) user='x' ruser='' port='tty6' rem_addr='async/' authen_type=ASCII service=LOGIN priv=1
2d13h: AAA: parse name=tty6 idb type=10 tty=6
2d13h: AAA: name=tty6 flags=0x11 type=4 shelf=0 slot=0 adapter=0 port=6 channel=0
2d13h: AAA/AUTHEN: create_user (0x18ECD8) user='' ruser='' port='tty6' rem_addr='async/' authen_type=ASCII service=LOGIN priv=1
2d13h: AAA/AUTHEN/START (113133681): port='tty6' list='' action=LOGIN service=LOGIN
2d13h: AAA/AUTHEN/START (113133681): using "default" list
2d13h: AAA/AUTHEN/START (113133681): Method=RADIUS
2d13h: AAA/AUTHEN (113133681): status = ERROR
2d13h: AAA/AUTHEN/START (113133681): Method=LOCAL
2d13h: AAA/AUTHEN (113133681): status = GETUSER
2d13h: TTY6: Autoselect(2) sample 78FE8080
2d13h: AAA/AUTHEN/CONT (113133681): continue_login (user='(undef)')
2d13h: AAA/AUTHEN (113133681): status = GETUSER
2d13h: AAA/AUTHEN/CONT (113133681): Method=LOCAL
2d13h: AAA/AUTHEN/LOCAL (113133681): no username: GETUSER
2d13h: AAA/AUTHEN (113133681): status = GETUSER
2d13h: TTY6: Autoselect(2) sample FE808078
2d13h: TTY6: Autoselect(2) sample 808078FE
2d13h: TTY6: Autoselect(2) sample 8078FE78
2d13h: TTY6: Autoselect(2) sample 78FE78E0
2d13h: TTY6: Autoselect(2) sample FE78E080
2d13h: AAA/AUTHEN/CONT (113133681): continue_login (user='')
2d13h: AAA/AUTHEN (113133681): status = GETUSER
2d13h: AAA/AUTHEN/CONT (113133681): Method=LOCAL
2d13h: AAA/AUTHEN (113133681): status = GETPASS
2d13h: TTY6: Autoselect(2) sample [suppressed--line is not echoing]
2d13h: TTY6: Autoselect(2) sample [suppressed--line is not echoing]
2d13h: AAA/AUTHEN/CONT (113133681): continue_login (user='x~x`')
2d13h: AAA/AUTHEN (113133681): status = GETPASS
2d13h: AAA/AUTHEN/CONT (113133681): Method=LOCAL
2d13h: AAA/AUTHEN (113133681): password incorrect
2d13h: AAA/AUTHEN (113133681): status = ERROR
2d13h: AAA/AUTHEN/START (1699685876): port='tty6' list='' action=LOGIN service=LOGIN
2d13h: AAA/AUTHEN/START (1699685876): Restart
2d13h: AAA/AUTHEN/START (1699685876): no methods left to try
2d13h: AAA/AUTHEN (1699685876): status = ERROR
2d13h: AAA/AUTHEN/START (1699685876): failed to authenticate
2d13h: AAA/AUTHEN: free_user (0x18ECD8) user='x~x`' ruser='' port='tty6' rem_addr='async/' authen_type=ASCII service=LOGIN priv=1
2d13h: AAA: parse name=tty6 idb type=10 tty=6
2d13h: AAA: name=tty6 flags=0x11 type=4 shelf=0 slot=0 adapter=0 port=6 channel=0
2d13h: AAA/AUTHEN: create_user (0x18ECD8) user='' ruser='' port='tty6' rem_addr='async/' authen_type=ASCII service=LOGIN priv=1
2d13h: AAA/AUTHEN/START (2594207699): port='tty6' list='' action=LOGIN service=LOGIN
2d13h: AAA/AUTHEN/START (2594207699): using "default" list
2d13h: AAA/AUTHEN/START (2594207699): Method=RADIUS
2d13h: AAA/AUTHEN (2594207699): status = ERROR
2d13h: AAA/AUTHEN/START (2594207699): Method=LOCAL
2d13h: AAA/AUTHEN (2594207699): status = GETUSER
2d13h: TTY6: Autoselect(2) sample 80F88080
2d13h: AAA/AUTHEN/CONT (2594207699): continue_login (user='(undef)')
2d13h: AAA/AUTHEN (2594207699): status = GETUSER
2d13h: AAA/AUTHEN/CONT (2594207699): Method=LOCAL
2d13h: AAA/AUTHEN/LOCAL (2594207699): no username: GETUSER
2d13h: AAA/AUTHEN (2594207699): status = GETUSER
2d13h: TTY6: Autoselect(2) sample F8808078
2d13h: TTY6: Autoselect(2) sample 808078FE
2d13h: TTY6: Autoselect(2) sample 8078FE78
2d13h: TTY6: Autoselect(2) sample 78FE7880
2d13h: AAA/AUTHEN/CONT (2594207699): continue_login (user='')
2d13h: AAA/AUTHEN (2594207699): status = GETUSER
2d13h: AAA/AUTHEN/CONT (2594207699): Method=LOCAL
2d13h: AAA/AUTHEN (2594207699): status = GETPASS
2d13h: TTY6: Autoselect(2) sample [suppressed--line is not echoing]
2d13h: TTY6: Autoselect(2) sample [suppressed--line is not echoing]
2d13h: TTY6: Autoselect(2) sample [suppressed--line is not echoing]
2d13h: TTY6: Autoselect(2) sample [suppressed--line is not echoing]
2d13h: TTY6: Autoselect(2) sample [suppressed--line is not echoing]
2d13h: TTY6: Autoselect(2) sample [suppressed--line is not echoing]
2d13h: TTY6: Autoselect(2) sample [suppressed--line is not echoing]
2d13h: TTY6: Autoselect(2) sample [suppressed--line is not echoing]
2d13h: TTY6: Autoselect(2) sample [suppressed--line is not echoing]
2d13h: TTY6: Autoselect(2) sample [suppressed--line is not echoing]
2d13h: TTY6: Autoselect(2) sample [suppressed--line is not echoing]
2d13h: AAA/AUTHEN/CONT (2594207699): continue_login (user='x~x')
2d13h: AAA/AUTHEN (2594207699): status = GETPASS
2d13h: AAA/AUTHEN/CONT (2594207699): Method=LOCAL
2d13h: AAA/AUTHEN (2594207699): password incorrect
2d13h: AAA/AUTHEN (2594207699): status = ERROR
2d13h: AAA/AUTHEN/START (1044807880): port='tty6' list='' action=LOGIN service=LOGIN
2d13h: AAA/AUTHEN/START (1044807880): Restart
2d13h: AAA/AUTHEN/START (1044807880): no methods left to try
2d13h: AAA/AUTHEN (1044807880): status = ERROR
2d13h: AAA/AUTHEN/START (1044807880): failed to authenticate
2d13h: AAA/AUTHEN: free_user (0x18ECD8) user='x~x' ruser='' port='tty6' rem_addr='async/' authen_type=ASCII service=LOGIN priv=1
2d13h: TTY6: Line reset by "Exec"
2d13h: TTY6: Modem: READY->HANGUP
2d13h: TTY6: dropping DTR, hanging up
2d13h: tty6: Modem: HANGUP->IDLE
2d13h: TTY6: restoring DTR
Cisco2511#
=========================================================
05-27-2003 08:14 PM
Please be noticed of the following output"
2d13h: AAA/AUTHEN (159376357): password incorrect " . make sure to use the correct username/password.
05-28-2003 08:34 AM
Looking on the debug, the user PC is trying to authenticate in the terminal window after dialing right? You may have entered the wrong password multiple times in that terminal window,
Now i am not sure how the aaa config look like and you want the authentication in terminal window or not, BUT first make sure that the password is correct and you can also try to use "async mode dedicated" instead of "async mode interactive" under the interface group-async. With that just use straight ppp connection. Do not need to have terminal window after dialing.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide