cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
542
Views
5
Helpful
2
Replies

Vlan trunking - 6509 / 3524xl

griffp
Level 1
Level 1

Have set up a FastEthernet dot1q trunk between a 6509 and a 3524xl.

When I enter "sh vlan" on the 3524xl I do not see all the active vlans configured on the 6509. A 2950 connected to the 6509 over a Gigabit trunk will display all active vlans when entering "sh vlan". Has anyone got any idea what I have done wrong?

Here is the config:

3524xl

interface FastEthernet0/24

duplex full

speed 100

switchport trunk encapsulation dot1q

switchport mode trunk

sh int f0/24 swi

Name: Fa0/24

Switchport: Enabled

Administrative mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: Disabled

Access Mode VLAN: 0 ((Inactive))

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: ALL

Trunking VLANs Active: 1,10

Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0

Override vlan tag priority: FALSE

Voice VLAN: none

Appliance trust: none

Self Loopback: No

6509

set port speed 6/8 100

set port duplex 6/8 full

set trunk 6/8 on dot1q 1-1005,1025-4094

set spantree portfast 6/8 disable

sh trunk 6/8

* - indicates vtp domain mismatch

# - indicates dot1q-all-tagged enabled on the port

Port Mode Encapsulation Status Native vlan

-------- ----------- ------------- ------------ -----------

6/8 on dot1q trunking 1

Port Vlans allowed on trunk

-------- ---------------------------------------------------------------------

6/8 1-1005,1025-4094

Port Vlans allowed and active in management domain

-------- ---------------------------------------------------------------------

6/8 1-12,100

Port Vlans in spanning tree forwarding state and not pruned

-------- ---------------------------------------------------------------------

6/8 1-12,100

2 Replies 2

david.bradley
Level 1
Level 1

Are you running VTP?

If you're not running VTP you will not see the VLANs on the 3524, you'd have to specifically set the VLANs up on the switch.

Hope this helps...

David,

Thanks for that. That was the one thing I had overlooked. Switch now set to VTP client. All vlans now displayed.