cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
244
Views
0
Helpful
2
Replies
harald.pedersen
Beginner

2 DHCP servers/pools on a Cisco 2621?

I have a cisco 2621 with 2 fe interfaces and wants both networks to get IP addresses from the router.

How do I configure the router so the clients get address from the right DHCP pool?

Interface 1 have 10.0.1.0 addresses and interface 2 have 172.16.0.0 addresses...

Is access-lists the solution?

Ragards Harald

2 REPLIES 2
smif101
Enthusiast

The router knows which interface it came from so it will deliver the correct IP address to the client. Just build both pools and it will be fine.

Harald, try this:

Fe0/0 -> for example IP LAN 10.0.1.254/24

Fe0/1 -> for example IP LAN 172.16.0.254/24

Configuring DHCP in Cisco 2612 for FE0/0:

ip dhcp excluded-address 10.0.1.X 10.0.1.X'

ip dhcp excluded-address 10.0.1.Y 10.0.1.Y'

!

ip dhcp pool HERALD1 network 10.0.1.0 255.255.255.0

default-router 10.0.1.254

lease 30

!

interface FastEthernet0/0

ip address 10.0.1.254 255.255.255.0

For the F0/1 is the same.

Fe0/0 -> for example IP LAN 10.0.1.254/24

Fe0/1 -> for example IP LAN 172.16.0.254/24

Configuring DHCP in Cisco 2612 for FE0/0:

ip dhcp excluded-address 172.16.0.X 172.16.0.X'

ip dhcp excluded-address 172.16.0.Y 172.16.0.Y'

!

ip dhcp pool HERALD2 network 172.16.0.0 255.255.255.0

default-router 172.16.0.254

lease 30

!

interface FastEthernet0/1

ip address 172.16.0.254 255.255.255.0