cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
424
Views
0
Helpful
2
Replies
Darkglasses
Beginner

A trio of faulty Cisco 881 - lightning struck

Hi Folks,

 

I am 3/4 through my CCNA Routing and Switching course and building my own lab. While doing so I have picked up 3 X Cisco 881 routers which where headed to the bin after the Fa4 interface developed issues following lightning strikes in the area.

 

My aim is to look at identifying hardware issues with Cisco devices and see if maintenance or an alternative configuration is possible. The look at presentation and considerations when deploying Cisco hardware. So looking for any input or direction is anyone have a few minutes. Common setup is to pickup and an IP address via ISP router at site via DHCP.

 

R1 and R2 -Cisco 881

 

Powers on normally after declining initial config wizard. I run sh ip int br to find all ports Protocol and Status show as down with Fa4 showing Administratively Down. I apply No Shut to the Fa4 interface for it to come up and then go instantly down with a working Ethernet cable connected.

*Jul 8 11:30:48.355: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet4, changed state to up
*Jul 8 11:30:53.043: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet4, changed state to down

 

I erased the NVRAM and reloaded to get the same Fa4  port configured as:
interface FastEthernet4
no ip address
duplex auto
speed auto

 

The only change I see when issuing shut/no shut on fa4 is "2 lost carrier, 0 no carrier " change with the lost carrier increment by 1This I believe is the interface not detecting any carrier signal on the cable and highlighting a port fault because the Ethernet cable has been changed/tested as working.

 

R3 = Cisco 881 where fa4 stays up when no shut was issued on the fa4 interface

 

In this case I thought I was in business as the port remained up and no lost carrier stats when sh int fa4 was issued on the interface. Therefore I applied to pickup an IP address via DHCP from my BT Smart Hub router. 

 

R3(config)#int fa4
R3(config-if)#pppoe-client dial-pool-number 1
R3(config-if)#no shut
R3(config)#int dialer 0
R3(config-if)#ip address negotiated
R3(config-if)#ip mtu 1492
R3(config-if)#encapsulation ppp
R3(config-if)#ppp authentication chap
R3(config-if)#dialer pool 1
R3(config-if)#dialer-group 1
R3(config-if)#exit
R3(config)#dialer-list 1 protocol ip permit
R3(config)#ip route 10.10.25.2 255.255.255.255 dialer 0
R3(config)# no ip route 10.10.25.2 255.255.255.255 dialer 0
R3(config)# no ip route 192.168.1.2 255.255.255.255 dialer 0
%No matching route to delete
R3(config)#ip route 192.168.1.2 255.255.255.255 dialer 0

 

Unfortunately I saw no IP and thinking the issue is not my configuration as the BT Router show no information on the port the Cisco is connected too. So I unplug the Ethernet cable from fa4 and find the port status is still up/up when sh ip int br is issued.

 

Summary

 

R1 and R2 come up to  detect the carrier signal and instantly and instantly change to down as no signal is detected. As no cable fault is present with different working Ethernet cables used then I am looking at a faulty port. Are you able to change the fa4 port? Prove faulty port with debug commands?

 

R3 looks to have shorted in a way to stay permanently up. Again am I able to change the port or prove the failure within the IOS?

 

How do I prevent this fault?

All three Cisco 881 router have been deployed in the same setup, connected directly to a BT router to run specific equipment. When the lightning strikes occurred (different sites) the BT router has continued to run without issue and damage limited to only fa4 of the Cisco router. As you can imagine I would prefer the BT router to fry instead of the Cisco as changing the BT router is a far simpler task.

 

Any advice would be greatly appreciated and thanks in advance.

 

John

2 REPLIES 2
Darkglasses
Beginner

R1 and R2 are dead I think

 

R3 is where i have been working and changed fa4 to:

interface FastEthernet4
ip address dhcp
ip nat outside
ip virtual-reassembly in
shutdown
duplex auto
speed auto

 

I am still unable to get an IP address and ran debug dhcp detail but unable to spot the problem. So I am off for some reading and hoping someone can point me in the right direction?

 

*Jul 8 15:49:10.039: DHCP: DHCP client process started: 10
*Jul 8 15:49:10.039: RAC: Starting DHCP discover on FastEthernet4
*Jul 8 15:49:10.039: DHCP: Try 1 to acquire address for FastEthernet4
*Jul 8 15:49:10.039: ARP: flush cache for interface FastEthernet4, by 8183CC98
*Jul 8 15:49:10.039: ARP: flush cache for interface FastEthernet4, by 8183C430
*Jul 8 15:49:10.039: IP ARP: sent rep src 0.0.0.0 b838.61c1.7f70,
dst 0.0.0.0 ffff.ffff.ffff FastEthernet4
*Jul 8 15:49:10.039: DHCP: allocate request
*Jul 8 15:49:10.039: DHCP: new entry. add to queue, interface FastEthernet4
*Jul 8 15:49:10.043: DHCP: Client socket is opened
*Jul 8 15:49:10.043: DHCP: SDiscover attempt # 1 for entry:
*Jul 8 15:49:10.043: Temp IP addr: 0.0.0.0 for peer on Interface: FastEthernet4
*Jul 8 15:49:10.043: Temp sub net mask: 0.0.0.0
*Jul 8 15:49:10.043: DHCP Lease server: 0.0.0.0, state: 3 Selecting
*Jul 8 15:49:10.043: DHCP transaction id: 1100
*Jul 8 15:49:10.043: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
*Jul 8 15:49:10.043: Next timer fires after: 00:00:04
*Jul 8 15:49:10.043: Retry count: 1 Client-ID: cisco-b838.61c1.7f70-Fa4
*Jul 8 15:49:10.043: Client-ID hex dump: 636973636F2D623833382E363163312E
*Jul 8 15:49:10.043: 376637302D466134
*Jul 8 15:49:10.043: Hostname: R3
*Jul 8 15:49:10.043: DHCP: SDiscover placed class-id option: 64736C666F72756D2E6F7267
*Jul 8 15:49:10.043: DHCP: SDiscover: sending 303 byte length DHCP packet
*Jul 8 15:49:10.043: DHCP: SDiscover 303 bytes
*Jul 8 15:49:10.043: B'cast on FastEthernet4 interface from 0.0.0.0
*Jul 8 15:49:10.043: ARP: flushing ARP entries for interface FastEthernet4
*Jul 8 15:49:10.043: ARP: flushing ARP entries for interface FastEthernet4
*Jul 8 15:49:12.031: %LINK-3-UPDOWN: Interface FastEthernet4, changed state to up
*Jul 8 15:49:13.031: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet4, changed state to up
*Jul 8 15:49:14.007: DHCP: SDiscover attempt # 2 for entry:
*Jul 8 15:49:14.007: Temp IP addr: 0.0.0.0 for peer on Interface: FastEthernet4
*Jul 8 15:49:14.007: Temp sub net mask: 0.0.0.0
*Jul 8 15:49:14.007: DHCP Lease server: 0.0.0.0, state: 3 Selecting
*Jul 8 15:49:14.007: DHCP transaction id: 1100
*Jul 8 15:49:14.007: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
*Jul 8 15:49:14.007: Next timer fires after: 00:00:04
*Jul 8 15:49:14.007: Retry count: 2 Client-ID: cisco-b838.61c1.7f70-Fa4
*Jul 8 15:49:14.007: Client-ID hex dump: 636973636F2D623833382E363163312E
*Jul 8 15:49:14.007: 376637302D466134
*Jul 8 15:49:14.007: Hostname: R3
*Jul 8 15:49:14.007: DHCP: SDiscover placed class-id option: 64736C666F72756D2E6F7267
*Jul 8 15:49:14.007: DHCP: SDiscover: sending 303 byte length DHCP packet
*Jul 8 15:49:14.007: DHCP: SDiscover 303 bytes
*Jul 8 15:49:14.007: B'cast on FastEthernet4 interface from 0.0.0.0
*Jul 8 15:49:18.007: DHCP: SDiscover attempt # 3 for entry:
*Jul 8 15:49:18.007: Temp IP addr: 0.0.0.0 for peer on Interface: FastEthernet4
*Jul 8 15:49:18.007: Temp sub net mask: 0.0.0.0
*Jul 8 15:49:18.007: DHCP Lease server: 0.0.0.0, state: 3 Selecting
*Jul 8 15:49:18.007: DHCP transaction id: 1100
*Jul 8 15:49:18.007: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
*Jul 8 15:49:18.007: Next timer fires after: 00:00:04
*Jul 8 15:49:18.007: Retry count: 3 Client-ID: cisco-b838.61c1.7f70-Fa4
*Jul 8 15:49:18.007: Client-ID hex dump: 636973636F2D623833382E363163312E
*Jul 8 15:49:18.007: 376637302D466134
*Jul 8 15:49:18.007: Hostname: R3
*Jul 8 15:49:18.007: DHCP: SDiscover placed class-id option: 64736C666F72756D2E6F7267
*Jul 8 15:49:18.007: DHCP: SDiscover: sending 303 byte length DHCP packet
*Jul 8 15:49:18.007: DHCP: SDiscover 303 bytes
*Jul 8 15:49:18.007: B'cast on FastEthernet4 interface from 0.0.0.0
*Jul 8 15:49:22.007: DHCP: QScan: Timed out Selecting state%Unknown DHCP problem.. No allocation possible
*Jul 8 15:49:30.523: DHCP: Waiting for 5 seconds on interface FastEthernet4
*Jul 8 15:49:35.523: DHCP: Try 2 to acquire address for FastEthernet4
*Jul 8 15:49:35.523: ARP: flush cache for interface FastEthernet4, by 8183CC98
*Jul 8 15:49:35.523: ARP: flush cache for interface FastEthernet4, by 8183C430
*Jul 8 15:49:35.523: IP ARP: sent rep src 0.0.0.0 b838.61c1.7f70,
dst 0.0.0.0 ffff.ffff.ffff FastEthernet4
*Jul 8 15:49:35.523: DHCP: allocate request
*Jul 8 15:49:35.523: DHCP: zapping entry in DHC_PURGING state for Fa4
*Jul 8 15:49:35.523: DHCP: deleting entry 89B58FD4 0.0.0.0 from list
*Jul 8 15:49:35.523: Temp IP addr: 0.0.0.0 for peer on Interface: FastEthernet4
*Jul 8 15:49:35.523: Temp sub net mask: 0.0.0.0
*Jul 8 15:49:35.523: DHCP Lease server: 0.0.0.0, state: 11 Purging
*Jul 8 15:49:35.523: DHCP transaction id: 1100
*Jul 8 15:49:35.523: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
*Jul 8 15:49:35.523: Next timer fires after: 00:00:26
*Jul 8 15:49:35.523: Retry count: 0 Client-ID: cisco-b838.61c1.7f70-Fa4
*Jul 8 15:49:35.523: Client-ID hex dump: 636973636F2D623833382E363163312E
*Jul 8 15:49:35.523: 376637302D466134
*Jul 8 15:49:35.523: Hostname: R3
*Jul 8 15:49:35.523: DHCP: new entry. add to queue, interface FastEthernet4
*Jul 8 15:49:35.523: DHCP: SDiscover attempt # 1 for entry:
*Jul 8 15:49:35.527: Temp IP addr: 0.0.0.0 for peer on Interface: FastEthernet4
*Jul 8 15:49:35.527: Temp sub net mask: 0.0.0.0
*Jul 8 15:49:35.527: DHCP Lease server: 0.0.0.0, state: 3 Selecting
*Jul 8 15:49:35.527: DHCP transaction id: 1101
*Jul 8 15:49:35.527: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
*Jul 8 15:49:35.527: Next timer fires after: 00:00:04
*Jul 8 15:49:35.527: Retry count: 1 Client-ID: cisco-b838.61c1.7f70-Fa4
*Jul 8 15:49:35.527: Client-ID hex dump: 636973636F2D623833382E363163312E
*Jul 8 15:49:35.527: 376637302D466134
*Jul 8 15:49:35.527: Hostname: R3
*Jul 8 15:49:35.527: DHCP: SDiscover placed class-id option: 64736C666F72756D2E6F7267
*Jul 8 15:49:35.527: DHCP: SDiscover: sending 303 byte length DHCP packet
*Jul 8 15:49:35.527: DHCP: SDiscover 303 bytes
*Jul 8 15:49:35.527: B'cast on FastEthernet4 interface from 0.0.0.0
*Jul 8 15:49:35.527: ARP: flushing ARP entries for interface FastEthernet4
*Jul 8 15:49:35.527: ARP: flushing ARP entries for interface FastEthernet4
*Jul 8 15:49:39.007: DHCP: SDiscover attempt # 2 for entry:
*Jul 8 15:49:39.007: Temp IP addr: 0.0.0.0 for peer on Interface: FastEthernet4
*Jul 8 15:49:39.007: Temp sub net mask: 0.0.0.0
*Jul 8 15:49:39.007: DHCP Lease server: 0.0.0.0, state: 3 Selecting
*Jul 8 15:49:39.007: DHCP transaction id: 1101
*Jul 8 15:49:39.007: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
*Jul 8 15:49:39.007: Next timer fires after: 00:00:04
*Jul 8 15:49:39.007: Retry count: 2 Client-ID: cisco-b838.61c1.7f70-Fa4
*Jul 8 15:49:39.007: Client-ID hex dump: 636973636F2D623833382E363163312E
*Jul 8 15:49:39.007: 376637302D466134
*Jul 8 15:49:39.007: Hostname: R3
*Jul 8 15:49:39.007: DHCP: SDiscover placed class-id option: 64736C666F72756D2E6F7267
*Jul 8 15:49:39.007: DHCP: SDiscover: sending 303 byte length DHCP packet
*Jul 8 15:49:39.007: DHCP: SDiscover 303 bytes
*Jul 8 15:49:39.007: B'cast on FastEthernet4 interface from 0.0.0.0

 

 

 

Darkglasses
Beginner

R1 and R2 are dead I think

 

R3 is where i have been working and changed fa4 to:

interface FastEthernet4
ip address dhcp
ip nat outside
ip virtual-reassembly in
shutdown
duplex auto
speed auto

 

I am still unable to get an IP address and ran debug dhcp detail but unable to spot the problem. So I am off for some reading and hoping someone can point me in the right direction?

 

*Jul 8 15:49:10.039: DHCP: DHCP client process started: 10
*Jul 8 15:49:10.039: RAC: Starting DHCP discover on FastEthernet4
*Jul 8 15:49:10.039: DHCP: Try 1 to acquire address for FastEthernet4
*Jul 8 15:49:10.039: ARP: flush cache for interface FastEthernet4, by 8183CC98
*Jul 8 15:49:10.039: ARP: flush cache for interface FastEthernet4, by 8183C430
*Jul 8 15:49:10.039: IP ARP: sent rep src 0.0.0.0 b838.xxxx.xxxx,
dst 0.0.0.0 ffff.ffff.ffff FastEthernet4
*Jul 8 15:49:10.039: DHCP: allocate request
*Jul 8 15:49:10.039: DHCP: new entry. add to queue, interface FastEthernet4
*Jul 8 15:49:10.043: DHCP: Client socket is opened
*Jul 8 15:49:10.043: DHCP: SDiscover attempt # 1 for entry:
*Jul 8 15:49:10.043: Temp IP addr: 0.0.0.0 for peer on Interface: FastEthernet4
*Jul 8 15:49:10.043: Temp sub net mask: 0.0.0.0
*Jul 8 15:49:10.043: DHCP Lease server: 0.0.0.0, state: 3 Selecting
*Jul 8 15:49:10.043: DHCP transaction id: 1100
*Jul 8 15:49:10.043: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
*Jul 8 15:49:10.043: Next timer fires after: 00:00:04