cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco announces new innovations in SD-WAN, ISRs, SD-WAN Services, and Catalyst 9000 Series switches


298
Views
15
Helpful
9
Replies
Beginner

BGP Path aatribute

what are the attributes in BGP to control inbound & outbound traffic

9 REPLIES
Collaborator

Re: BGP Path aatribute

From my notes :

 

There are multiple ways of influencing Inbound vs. Outbound Traffic flow in BGP. The most common ones are:

 

Inbound Traffic Flow can be influenced by manipulating the following attributes –>

  • AS-Path Prepending
  • MED

Outbound Traffic Flow can be influenced by manipulating the following attributes –>

  • Weight
  • Local Preference

1. Local Preference is used to manipulate traffic going out of your Autonomous System. This attribute is only exchanged with IBGP peers and therefore has local significance to your Autonomous System.

 

2. The Weight attribute is also used to manipulate traffic going out of your Autonomous System but this attribute is local to the router on which it is configured and is not exchanged with any IBGP or EBGP peers.

 

3. A router uses the AS_PATH attribute in case of ties between the weight and local preference attributes and the route not being locally originated. When this attribute is used to select a particular route you are basically controlling traffic going out of your Autonomous System.

 

When you are multi homed to two different providers it is sometimes required to prefer one provider's link for some incoming traffic. In such cases a normal practise is to manipulate the AS_PATH attribute thereby making one path seem more attractive than the other (shorter AS_PATH). So in such circumstances you are using AS_PATH to manipulate traffic coming into your AS.

 

4. Another attribute that is used to manipulate incoming traffic is called MED (Multi-Exit Discriminator). However, an EBGP peer receiving it will only share it with IBGP peers and will not forward it to another AS. This means that you can basically use this attribute for influencing traffic between two directly connected autonomous systems.

BB
*** Rate All Helpful Responses ***
Beginner

Re: BGP Path aatribute

Thanks Balaji...

Beginner

Re: BGP Path aatribute

Hi Balaji,

 

I have another problem ------My Bgp Is Showing 0.0.0.0 As Router-id; What Could Be The Possible Reason?

Collaborator

Re: BGP Path aatribute

Since we do know your configuration and topology its hard to say what is the reason.

 

you need to provide full configuration of the network devices. and some show output.

 

show all the devices show version and device models to suggest why it was showing 0.0.0.0

 

in first instance is the BGP formed neighbouship ?

 

 

BB
*** Rate All Helpful Responses ***
Highlighted
Beginner

Re: BGP Path aatribute

Just a Guess,

 

You maybe you are using an IBGP inside your network with router id 0.0.0.0 and that router id is advertised to BGP. check other routers in the topology. 

Beginner

Re: BGP Path aatribute

Thnaks Karim it was the problem....i have one more question can i implement BGP on two routers having different subnet?

Beginner

Re: BGP Path aatribute

@Tanmoy your question is not clear. Please draw the topology or provide more info.  

Beginner

Re: BGP Path aatribute

Karim my question is that if R1 is connected to R2 & two are on different subnets like one is in /8 & other is on /16 will they form neighborship???

Beginner

Re: BGP Path aatribute

The Answer is YES

 

BGProuter1
interface GigabitEthernet0/0/0
ip address 192.168.0.1 255.255.0.0
duplex auto
speed auto

router bgp 1
bgp log-neighbor-changes
no synchronization
neighbor 192.168.0.2 remote-as 2


BGProuter2
interface GigabitEthernet0/0/0
ip address 192.168.0.2 255.255.255.0
duplex auto
speed auto


router bgp 2
bgp log-neighbor-changes
no synchronization
neighbor 192.168.0.1 remote-as 1



BGProuter1#sho ip bgp summary
BGP router identifier 192.168.0.1, local AS number 1
BGP table version is 1, main routing table version 6
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
192.168.0.2 4 2 7 7 1 0 0 00:05:29 4

BGProuter2 #sho ip bgp summary
BGP router identifier 192.168.0.2, local AS number 2
BGP table version is 1, main routing table version 6
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
192.168.0.1 4 1 6 6 1 0 0 00:04:18 4

CreatePlease to create content
Ask the Expert- DMVPN on Cisco routers