cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1381
Views
0
Helpful
1
Replies
Highlighted

CDP Neighbor over multiple vlans

Hi I was hoping someone could help with some confusion with multiple vlans and CDP.

I have 3 vlans setup on a 3750 switch, each with an individual IP in their respective subnets, and the corresponding IP setup on each vlan on the router.

Vlan 4 - Voice Vlan

Vlan 400 - Data Vlan

Vlan 401 - WIFI Vlan

All phones are registered in voice vlan4, all users pcs work in vlan400, all CISCO APs are configured in vlan401.  CISCO APs are in LWAP mode and talk to a controller located offsite (data centre)

On the 3750 if I setup the ports to the APs as regular access ports, everything works fine, staff can connect and operate in their respective areas with no problems.

But on the switch, if you run "show cdp neighbor" no results will be displayed for the APs unless you add the command "switchport voice vlan 4", only then they will display in the cdp neighbor output.

I know that CDP will operate in the lowest VLAN ID (in this case vlan4) but I thought that information such as CDP would transmit over the other vlans (400 or 401) if vlan4 was not configured on that port?

Is there a way to have CDP information displayed from devices in vlan 401, without having to have vlan 4 also added to that port?  Can you force CDP to work in other vlans not just the lowest vlan ?

 

Sample trunk port config to the router:

-----------------------------------------------------

interface GigabitEthernet1/1

description Router 1

switchport trunk allowed vlan 4,400,401

switchport mode trunk

 

Sample access port config to the AP with just vlan 400: (no cdp information is displayed)

-----------------------------------------------------------------------------------------------------------------------------

 interface GigabitEthernet3/0/48

description Cisco AP

switchport access vlan 400

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

 

 Sample access port config to the AP with vlan 4 added: (cdp information is displayed)

-------------------------------------------------------------------------------------------------------------------------

interface GigabitEthernet3/0/48

description Cisco AP

switchport access vlan 400

switchport mode access

switchport voice vlan 4

spanning-tree portfast

spanning-tree bpduguard enable

1 REPLY 1
Highlighted
Advisor

I don't think CDP even uses VLANs.  It doesn't care about what VLANs are configured, filtered, etc.  It operates at as a link layer protocol.

This smells more like a software upgrade.  I would make sure your 3750 is running a gold star release of code.