cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
171
Views
0
Helpful
3
Replies

Cisco 1921 configuration

Hi everyone, i have a Cisco 1921 Router as the gateway in my network to traffic my wifi network connected to a 2400 series router and a cisco switch, For some reason it will no longer connect to the default gateway and i can't ping it so i have no internet access when it is connected to my network here's the config of the router. What can the issue be and what can i do to fix it??

!
hostname Router-1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$Baae$VyAgSJhYiib7JZ7TkpI1t/
enable password 7 0308521A0715741A
!
no aaa new-model
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
!
license udi pid CISCO1921/K9 sn FTX1545811C
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 192.168.103.1 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
no mop enabled
!
interface GigabitEthernet0/1
ip address 50.232.137.37 255.255.255.252
duplex auto
speed auto
no mop enabled
!
interface Serial0/0/0
ip address 10.253.253.1 255.255.255.0
ip nat inside
ip nat enable
ip virtual-reassembly
encapsulation ppp
no clock rate 2000000
!
router rip
redistribute connected
network 10.0.0.0
network 192.168.100.0
network 192.168.101.0
!
ip default-gateway 192.168.15.1
no ip classless
no ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 100 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 192.168.15.1
ip route 50.232.137.96 255.255.255.224 50.232.137.38
!
access-list 100 remark NAT all test nets
access-list 100 permit ip 192.168.100.0 0.0.0.255 any
access-list 100 permit ip 192.168.101.0 0.0.0.255 any
access-list 100 permit ip 10.253.253.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!
!
!
control-plane
!
!
line con 0
password 7 05080F1C2243
logging synchronous
login
line aux 0
line vty 0 4
password 7 01030717481C091D25
login
transport input all
!
scheduler allocate 20000 1000
end

Everyone's tags (1)
3 REPLIES 3
VIP Collaborator

Re: Cisco 1921 configuration

Hello, 

There a couple things that stand out:

 

1- Your default route should point to a viable next hop associated with a router interface. Currently you have "ip route 0.0.0.0 0.0.0.0 192.168.15.1" and I don't see any interface associated with 192.168.15.1. (The same for your default-gateway, but the 0.0.0.0 is more important.

 

2- Not sure with what or where you are advertising, but you have 192.168.100.0 and 192.168.101.0 in RIP. But unless they are actual interfaces on the router they will not be advertised. 

 

 

 

Re: Cisco 1921 configuration

I will take a look at those, the 192.168.100 and 192.168.101 in rip are because the first one is the next router that is connected to the router mentioned and then the 2nd address is the switch i mentioned which is connected to the the 2400 router which then connects to my end point which i connect my pc and such to. Also the ip router the address 192.168.15.1 is my internet provider i'm not sure which interface i am connected to on that network because it is a lan to lan connection i have set up. but Thank you I will address those issues and see if the problem is fixed.

Highlighted
Hall of Fame Master

Re: Cisco 1921 configuration

There are several things in this config that I find puzzling, but not clear if they relate to the issue described in the initial post about not connecting to its default gateway.

- router rip is configured with 3 network statements. But only one of them matches an interface on the router. Unless there are interfaces in 192.168.100.0 and 192.168.101.0 then theses network statements do not achieve anything and should be removed.

- as configured RIP is running over the serial interface and not any other interfaces. It would be helpful to know what routes it is learning and placing into the routing table.

- Gig0/0 seems to be an outside interface based on its translation of networks 192.168.100.0 and 192.168.101.0. But it has a private IP address while Gig0/1 has a public IP and seems more logical as the outside interface. What does Gig0/0 connect to? (and what does Gig0/1 connect to) In the current config there is not any routing protocol running on Gig0/0 and no static routes using that interface. So I do not see what would send any traffic out that interface, and therefore the address translation would not be working.

- the router has configured both an ip default-gateway and an ip route 0.0.0.0. As long as ip routing is enabled then the ip default-gateway command is ignored. So while it does not cause any problem neither does it take any action. The configured ip route 0.0.0.0 determines what is the active gateway. Right now the ip route 0.0.0.0 points to 192.168.15.1 as the next hop. But based on the config we do not know where that address is. If it is learned via RIP on the serial interface then the default route is ok. Otherwise this might be the main problem.

- I am surprised to find no ip classless in the config. It may not be causing a problem but ip classless has been the default for so long and I am wondering why it was disabled.

- there is a static route for subnet 50.232.137.96 which uses Gig0/1. There is no indication of what this is or how it is used.  

 

Perhaps the output of the commands show ip interface brief and of show ip route might shed some light on this issue?

 

HTH

 

Rick

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards