Showing results for 
Search instead for 
Did you mean: 

Cisco Community Designated VIP Class of 2020

Not applicable

Cisco 2811 Compact Flash

Before I get a lot of replies about this, I have done a lot searching. I understand that Cisco only officially supports their CF cards. I understand that. I have two 2811 routers. One with and one without the Cisco CF cards. These are used in a lab environment, not in production. I purchased a 32Gb card from my local part store, reformatted it to FAT16, and was able to get it to work for a long time. Recently, I have tried to tftp the required files for CME and VoIP and it started to give me errors. I formatted the card, using the running, configured router, retftp'd the IOS file and it will not boot. I hot swapped the card (64mb) to the router, loaded the os, reformatted the 32Gb (yes fat16 only can use 2ishGb), and was able to tftp, show flash and dir flash: just fine. But the router will not load properly with that card install. I am just trying to figure out what I could of changed to make this work again. Yes, I know the easy answer is to buy an official Cisco CF, but I just want to figure out how i could make this work as is.

Corp-R1#dir flash:
Directory of flash:/

No files in directory

30005882880 bytes total (30005878784 bytes free)
Corp-R1#format flash:?
flash: flash:0:

Corp-R1#format flash: ?

Corp-R1#format flash:
Format operation may take a while. Continue? [confirm]
Format operation will destroy all data in "flash:". Continue? [confirm]
Format: All system sectors written. OK...

Format: Total sectors in formatted partition: 58720193
Format: Total bytes in formatted partition: 30064738816
Format: Operation completed successfully.

Format of flash: complete
Corp-R1#show flash
No files on device

30006005760 bytes available (4096 bytes used)

Corp-R1#copy tftp flash
Address or name of remote host []?
Source filename []? c2800nm-adventerprisek9-mz.151-4.M10.bin
Destination filename [c2800nm-adventerprisek9-mz.151-4.M10.bin]?
Accessing tftp://
Loading c2800nm-adventerprisek9-mz.151-4.M10.bin from (via FastEthernet0/1): !!!!!!!!!!!!!!!!!!!!!!!!! (shorted)
[OK - 67926080 bytes]

67926080 bytes copied in 384.124 secs (176834 bytes/sec)

Corp-R1#show flash
-#- --length-- -----date/time------ path
1 67926080 May 26 2017 22:23:50 c2800nm-adventerprisek9-mz.151-4.M10.bin

29938077696 bytes available (67932160 bytes used)


Everyone's tags (3)
Hall of Fame Community Legend

32 Gb?  I wouldn't use that

32 Gb?  I wouldn't use that size.  16 Gb is probably the largest I'll use.  

Next, ISR G1 routers (except the 870) all have USB slots.  If you upgrade the ROMmon, you can configure the router to boot from a supported USB stick (maximum size 16 Gb).  

Not applicable

I got it to work using a 2Gb

I got it to work using a 2Gb (or so partition). TFTPDNLD in Rommon. Now it works again. I am just trying to figure out how to make it stop messing up the parition when I tftp the voice files.

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here