cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

180
Views
0
Helpful
8
Replies
Highlighted
Beginner

Cisco 3550 help

Hello I need some clarification with L3 switching.

Toplogy |swA3500|---|swB3500|---|swC3500|

swA gig0/2 192.168.0.1/24

swB gig0/1 192.168.0.2/24

swB gig0/2 192.168.1.1/24

swC gig0/1 192.168.1.2/24

I would like to use eigrp so I use no switchport on the interfaces assign the ip. But after enabling routing I get neighbor In wrong subnet error. Any clue?

my objective is to get all the vlans to be able to communicate between switches.I used default route that worked but I want to use a dynamic routing for my own learning purposes.

thanks

8 REPLIES 8
Highlighted
Advocate

Re: Cisco 3550 help

In your scenario, you have a layer 3 division between your switches.

Switch A will know about all the VLAN subnets configured on it as well as the network link between the switches.

Switch B on the other hand will know about the subnets configured on it plus the link subnet. For reachability between all the subnets you need to run either a dynamic routing protocol (EIGRP,OSPF) or statically point routes for the subnets pointing to the correct layer3

HTH

NArayan

Highlighted
Contributor

Re: Cisco 3550 help

Hello,

make sure your configurations looks like this:

swA3500

!

ip routing

!

ip subnet-zero

!

interface GigabitEthernet0/2

no switchport

ip address 192.168.0.1 255.255.255.0

!

router eigrp 1

network 192.168.0.1 0.0.0.0

no auto-summary

swB3500

!

ip routing

!

ip subnet-zero

!

interface GigabitEthernet0/1

no switchport

ip address 192.168.0.2 255.255.255.0

!

interface GigabitEthernet0/2

no switchport

ip address 192.168.1.1 255.255.255.0

!

router eigrp 1

network 192.168.0.2 0.0.0.0

network 192.168.1.1 0.0.0.0

no auto-summary

swC3500

!

ip routing

!

interface GigabitEthernet0/1

no switchport

ip address 192.168.1.2 255.255.255.0

!

router eigrp 1

network 192.168.1.2 0.0.0.0

no auto-summary

Make sure that you use the 'ip subnet-zero' command on your switches A and B (since you are using network 192.168.0.0/24)...

Regards,

GNT

Highlighted
Beginner

Re: Cisco 3550 help

Thanks for help I'll give it a try, i'll let you know what happens

Highlighted
Beginner

Re: Cisco 3550 help

Hello

Tried what you told me but nothing, I get the same error

swC"ip eigrp neighbor 192.168.0.2 not on common subnet for gig0/1

swB ip eigrp neighbor 192.168.1.2 not on common subnet for gig0/1

Odd not sure what the problem could be, maybe redundancy is causing some sort of problem (though I shutdown all the redundant ports),

Or maybe a gbic problem (if I'm correct if you use all gbic ports it becomes half duplex)

(I tried fast Ethernet ports and got rid of the problem) so it something with gbic

Highlighted
Frequent Contributor

Re: Cisco 3550 help

can you juz post the configuration based on that will decide.

Highlighted
Beginner

Re: Cisco 3550 help

Pls do following and check-

In switch a-in place of

Network 192.168.0.1 0.0.0.0

Give

Network 192.168.0.0

Similarly ?

In switch B give ?

Network 192.168.0.0

Network 192.168.1.0

in switch C give ?

Network 192.168.1.0

And revert what happened-.

Highlighted
Advisor

Re: Cisco 3550 help

Looks like your connecting links between the switches is in 2 different address ranges and that is what it is complaining about ,on one end you have 192.168.0.2 /24 address and the other is 192.168.1.0/24 address , can't do this , change one end or the other so that they are both in the same subnet range.

Highlighted
Cisco Employee

Re: Cisco 3550 help

EIGRP requires source primary ips to be on same subnet on both ends. Thus, if u define

network 192.168.0 on sw a and b

network 192.168.1 on sw b and c

i think it would work.

For more info:

http://www.cisco.com/en/US/customer/tech/tk365/technologies_configuration_example09186a0080093f09.shtml

keep me posted.

Thanks

This widget could not be displayed.