cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
194
Views
0
Helpful
6
Replies
Highlighted
Beginner

Dynamic address assignment is assigning Voice IP for workstations.

We have 4 ip pools (one voice ip pool for VOIP and 3 data ip pools) and our dhcp server is started assigning voice ip pool address to any new laptop or desktop is connected to network.

And when i check my dhcp our primary data ip pool is full and its now started flushing voice ip addresses instead giving secondary data ip pool addresses.

What will be the cause?

6 REPLIES 6
Beginner

Re: Dynamic address assignment is assigning Voice IP for workstations.

Hi,

Well it shouldn't happen if your VOIP pool have different subnet than data and I hope they are different?
I would check for incorrect setup on dhcp relay on router (or any device where dhcp relay is configured).
Beginner

Re: Dynamic address assignment is assigning Voice IP for workstations.

Thank you for your reply.

Yes we have a different pool for VOIP. Can I know the correct setup of dhcp relay on router. I am not familiar to this.

Beginner

Re: Dynamic address assignment is assigning Voice IP for workstations.

Lets say voip have vlan 500 with addressing 10.10.10.0/24 gateway for this vlan will be at 10.10.10.1
Interface or subinterface that is gateway should habe dhcp relay with ip address pointing to DHCP server so when router rebuilds a frame it should put address in GIADDR field so dhcp will know to which pool should lease an address.

Also I would double check if switchport is correctly configured with correct data and voice vlans because it looks like you can miss data vlan on link or someone set just voice vlan on link instead of voice and data vlan.
Beginner

Re: Dynamic address assignment is assigning Voice IP for workstations.

interface Vlan1
ip address 10.122.16.1 255.255.255.0 secondary
ip address 10.122.20.1 255.255.255.0 secondary
ip address 10.122.23.1 255.255.255.0 secondary
ip address 10.122.22.1 255.255.255.0 secondary
ip address 10.122.15.1 255.255.255.0
ip helper-address 10.21.70.49
ip helper-address 10.122.15.2
!
interface Vlan12
description VOIP
ip address 10.122.12.1 255.255.254.0
ip helper-address 10.122.15.2
!
ip default-gateway 10.82.241.125
ip forward-protocol nd
ip http server
ip http secure-server
ip route 0.0.0.0 0.0.0.0 10.82.241.125

This is our configuration and we use sp voice vlan 12 and sp access vlan 1 on our interfaces.

And I also tried removing the sp voice vlan 12 on one interface and connected a laptop but I got a vlan 12 IP address which left me in complete bizarre.

Beginner

Re: Dynamic address assignment is assigning Voice IP for workstations.

Can you paste the configuration of port that you connected laptop? use: show interface <interface> switchport
Also what device acting as DHCP? Windows/linux server or router/asa?
Beginner

Re: Dynamic address assignment is assigning Voice IP for workstations.

Name: Gi1/0/47
Switchport: Enabled
Administrative Mode: static access
Operational Mode: down
Administrative Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: 12 (VOIP-vlan)
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

We are using windows server

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards