cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
485
Views
0
Helpful
5
Replies

eigrp redistribute problem

henrybb
Level 1
Level 1

router_a------router_b

If I config on the router_a:

conf t

ip route 137.1.1.96 255.255.255.224 192.168.1.2

ip route 6.0.0.0 255.128.0.0 null 0

ip route 6.128.0.0 255.128.0.0 null 0

router eigrp 1

redis static route-map stat-e1

route-map stat-e1 permit 10

match ip addr 13

no access-list 13

access-list 13 permit 6.0.0.0

access-list 13 permit 6.128.0.0

access-list 13 permit 137.1.1.96

end

the static route will not redistribute into eigrp as 1,

But if I config like this(cofnig static route at last):

conf t

router eigrp 1

redis static route-map stat-e1

route-map stat-e1 permit 10

match ip addr 13

no access-list 13

access-list 13 permit 6.0.0.0

access-list 13 permit 6.128.0.0

access-list 13 permit 137.1.1.96

ip route 137.1.1.96 255.255.255.224 192.168.1.2

ip route 6.0.0.0 255.128.0.0 null 0

ip route 6.128.0.0 255.128.0.0 null 0

end

everything will ok,why? If I use prefix-list to replace access-list, there is same result.

Are there any bug? Look like IOS will process redistribute correctly only if you config

static route at last. I can't find anything using bug toolkit.

And if I show ip route on router_b

router_b#show ip route

D 6.0.0.0/9 [90/28160] via 192.168.8.253, 01:59:55, FastEthernet1/0/0

D 6.128.0.0/9 [90/28160] via 192.168.8.253, 01:59:55, FastEthernet1/0/0

D EX 137.1.1.96/27 [170/28416] via 192.168.8.253, 01:59:56, FastEthernet1/0/0

Why 6.0.0.0/9 and 6.128.0.0/9 is internal route and 137.1.1.96/27 is external route?

Is it because 6.0.0.0/9 and 6.128.0.0/9 is point to null 0?

5 Replies 5

steve.barlow
Level 7
Level 7

They should all be external. Not sure why, I did the same and it worked for me:

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#ip route 137.1.1.96 255.255.255.224 192.168.1.2

Router(config)#ip route 6.0.0.0 255.128.0.0 null 0

Router(config)#ip route 6.128.0.0 255.128.0.0 null 0

Router(config)#router eigrp 1

Router(config-router)#redis static route-map stat-e1

Router(config-router)#net 192.168.1.0

Router(config-router)#no auto

Router(config-router)#exit

Router(config)#route-map stat-e1 permit 10

Router(config-route-map)#match ip addr 13

Router(config-route-map)#exit

Router(config)#access-list 13 permit 6.0.0.0

Router(config)#access-list 13 permit 6.128.0.0

Router(config)#access-list 13 permit 137.1.1.96

Router(config)#

Router(config)#^Z

Router#sh ip

00:42:15: %SYS-5-CONFIG_I: Configured from console by console rout

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

U - per-user static route, o - ODR

Gateway of last resort is not set

137.1.0.0/27 is subnetted, 1 subnets

S 137.1.1.96 [1/0] via 192.168.1.2

6.0.0.0/9 is subnetted, 2 subnets

S 6.0.0.0 is directly connected, Null0

S 6.128.0.0 is directly connected, Null0

C 192.168.1.0/24 is directly connected, Serial0

Router#

Router2#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router2(config)#int s0

Router2(config-if)#ip add 192.168.1.101 255.255.255.0

Router2(config-if)#router eigrp 1

Router2(config-router)#net 192.168.1.0

Router2(config-router)#no auto

Router2(config-router)#^Z

Router2#sh ip ei ne

IP-EIGRP neighbors for process 1

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

0 192.168.1.100 Se0 11 00:00:04 452 2712 0 1

Router2#sh ip rout

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

U - per-user static route, o - ODR

Gateway of last resort is not set

137.1.0.0/27 is subnetted, 1 subnets

D EX 137.1.1.96 [170/2681856] via 192.168.1.100, 00:00:06, Serial0

6.0.0.0/9 is subnetted, 2 subnets

D EX 6.0.0.0 [170/2169856] via 192.168.1.100, 00:00:07, Serial0

D EX 6.128.0.0 [170/2169856] via 192.168.1.100, 00:00:07, Serial0

C 192.168.1.0/24 is directly connected, Serial0

Router2#

What does your eigrp top look like (something like below):

Router#sh ip ei top

IP-EIGRP Topology Table for process 1

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

r - Reply status

P 6.0.0.0/9, 1 successors, FD is 256

via Redistributed (256/0)

P 192.168.1.0/24, 1 successors, FD is 2169856

via Connected, Serial0

P 6.128.0.0/9, 1 successors, FD is 256

via Redistributed (256/0)

P 137.1.1.96/27, 1 successors, FD is 2169856

via Redistributed (2169856/0)

Router#sh ip rout 6.0.0.0 255.128.0.0

Routing entry for 6.0.0.0/9

Known via "static", distance 1, metric 0 (connected)

Redistributing via eigrp 1

Advertised by eigrp 1 route-map stat-e1

Routing Descriptor Blocks:

* directly connected, via Null0

Route metric is 0, traffic share count is 1

Router2#sh ip ei top

IP-EIGRP Topology Table for process 1

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

r - Reply status

P 6.0.0.0/9, 1 successors, FD is 2169856

via 192.168.1.100 (2169856/256), Serial0

P 192.168.1.0/24, 1 successors, FD is 2169856

via Connected, Serial0

P 6.128.0.0/9, 1 successors, FD is 2169856

via 192.168.1.100 (2169856/256), Serial0

P 137.1.1.96/27, 1 successors, FD is 2681856

via 192.168.1.100 (2681856/2169856), Serial0

Router2#sh ip route 6.0.0.0 255.128.0.0

Routing entry for 6.0.0.0/9

Known via "eigrp 1", distance 170, metric 2169856, type external

Redistributing via eigrp 1

Last update from 192.168.1.100 on Serial0, 00:08:50 ago

Routing Descriptor Blocks:

* 192.168.1.100, from 192.168.1.100, 00:08:50 ago, via Serial0

Route metric is 2169856, traffic share count is 1

Total delay is 20000 microseconds, minimum bandwidth is 1544 Kbit

Reliability 255/255, minimum MTU 1500 bytes

Loading 1/255, Hops 1

What IOS are you running? If possible I would clear the config, reload and re-enter the config. If you can't can you post the show output like above?

Steve

Steve,

thanks,I can't clear the config because the router is in production.But I test it on a new 2611,result is same.I don't know why,maybe your IOS is different with mine and different IOS has different behavior.

2611#sh ip eigrp to 6.0.0.0 255.128.0.0

IP-EIGRP topology entry for 6.0.0.0/9

State is Passive, Query origin flag is 1, 1 Successor(s), FD is 256

Routing Descriptor Blocks:

0.0.0.0, from Rstatic, Send flag is 0x0

Composite metric is (256/0), Route is Internal

Vector metric:

Minimum bandwidth is 10000000 Kbit

Total delay is 0 microseconds

Reliability is 0/255

Load is 0/255

Minimum MTU is 1500

Hop count is 0

2611#sh run

Building configuration...

Current configuration : 1825 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname 2611

!

router eigrp 10

redistribute static route-map stat-e10-access-list

network 6.0.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 6.0.0.0 255.128.0.0 Null0

ip route 6.128.0.0 255.128.0.0 Null0

no ip http server

!

!

access-list 183 permit ip host 6.0.0.0 host 255.128.0.0

!

route-map stat-e10-access-list permit 10

match ip address 183

!

!

end

2611#sh ver

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-IS-M), Version 12.1(5)T9, RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2001 by cisco Systems, Inc.

Compiled Sun 24-Jun-01 03:16 by cmong

Image text-base: 0x80008088, data-base: 0x8101A744

ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

2611 uptime is 16 weeks, 1 day, 18 hours, 29 minutes

System returned to ROM by power-on

System image file is "flash:c2600-is-mz.121-5.T9.bin"

cisco 2611 (MPC860) processor (revision 0x300) with 45056K/4096K bytes of memory

.

Processor board ID JAD06070DPW (310835556)

M860 processor: part number 0, mask 49

Bridging software.

X.25 software, Version 3.0.0.

2 Ethernet/IEEE 802.3 interface(s)

32K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

router_a>sh ip eigrp to 1

IP-EIGRP Topology Table for AS(1)/ID(6.1.99.200)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

r - Reply status

P 6.0.0.0/9, 1 successors, FD is 256

via Rstatic (256/0)

P 6.128.0.0/9, 1 successors, FD is 256

via Rstatic (256/0)

P 137.1.1.96/32, 1 successors, FD is 2816

via Rstatic (2816/0)

router_a>sh ip route 6.0.0.0 255.128.0.0

Routing entry for 6.0.0.0/9

Known via "static", distance 1, metric 0 (connected)

Redistributing via eigrp 1, eigrp 18

Advertised by eigrp 1 route-map stat-e7

Routing Descriptor Blocks:

* directly connected, via Null0

Route metric is 0, traffic share count is 1

router_a>sh ver

Cisco Internetwork Operating System Software

IOS (tm) MSFC2 Software (C6MSFC2-IS-M), Version 12.1(2)E, EARLY DEPLOYMENT RELEA

SE SOFTWARE (fc1)

Copyright (c) 1986-2000 by cisco Systems, Inc.

Compiled Mon 19-Jun-00 22:17 by linda

router_b>sh ip eigrp to

IP-EIGRP Topology Table for AS(1)/ID(10.1.126.37)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

r - Reply status

P 6.0.0.0/9, 4 successors, FD is 28160

via 192.168.8.253 (28160/256), FastEthernet1/0/0

P 137.1.1.96/27, 4 successors, FD is 28160

via 192.168.8.253 (28416/2816), FastEthernet1/0/0

P 6.128.0.0/9, 4 successors, FD is 28160

via 192.168.8.253 (28160/256), FastEthernet1/0/0

router_b>sh ip route 6.0.0.0 255.128.0.0

Routing entry for 6.0.0.0/9

Known via "eigrp 1", distance 90, metric 28160, type internal

Redistributing via eigrp 1

Last update from 192.168.8.253 on FastEthernet1/0/0, 20:37:59 ago

Routing Descriptor Blocks:

192.168.8.253, from 192.168.8.253, 20:37:59 ago, via FastEthernet1/0/0

Route metric is 28160, traffic share count is 1

Total delay is 100 microseconds, minimum bandwidth is 100000 Kbit

Reliability 255/255, minimum MTU 1500 bytes

Loading 2/255, Hops 1

router_b>sh ip route 137.1.1.96 255.255.255.224

Routing entry for 137.1.1.96/27

Known via "eigrp 7", distance 170, metric 28416, type external

Redistributing via eigrp 7

Last update from 10.1.96.254 on FastEthernet1/0/0, 20:44:10 ago

Routing Descriptor Blocks:

* 192.168.8.253, from 192.168.8.253, 20:44:10 ago, via FastEthernet1/0/0

Route metric is 28416, traffic share count is 1

Total delay is 110 microseconds, minimum bandwidth is 100000 Kbit

Reliability 255/255, minimum MTU 1500 bytes

Loading 2/255, Hops 1

Steve,

I upgrade my 26'IOS to 12.1(18),result is same(route which point to null 0 is still internal).

can u tell me what's your IOS version?

regards

Henry

It is a lab router so the IOS is older - 12.0(21):

router#sh ver

Cisco Internetwork Operating System Software

IOS (tm) 2500 Software (C2500-D-L), Version 12.0(21), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2001 by cisco Systems, Inc.

Compiled Mon 31-Dec-01 18:25 by nmasa

Image text-base: 0x03038AE4, data-base: 0x00001000

ROM: System Bootstrap, Version 4.14(9.1), SOFTWARE

router uptime is 54 minutes

System restarted by power-on at 09:30:52 UTC Fri Feb 14 2003

System image file is "flash:c2500-d-l.120-21.bin"

cisco 2509 (68030) processor (revision B) with 16384K/2048K bytes of memory.

Processor board ID 49356531, with hardware revision 00000000

Bridging software.

X.25 software, Version 3.0.0.

1 Ethernet/IEEE 802.3 interface(s)

2 Serial network interface(s)

32K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read ONLY)

Configuration register is 0x2142

router#

Router_a is learning 6.0.0.0/9 via eigrp 1 and eigrp 18. Can you post the full config (minus IPs/passwds)? What does the network topology look like?

How many peers does router_b have as each route has 4 successors? The external route was learned via eigrp 7 (update from 10.1.96.254) and has a metric of 28416 and the internal routes learned from eigrp 1 (peer 192.168.8.253) with a metric of 28160.

Steve

Steve,

I download 12.0(21) to my 2600,route is internal,too.I think it is too detail.I don't want waste your time to invesgiate this problem.Thanks!

2600#sh ver

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-IS-M), Version 12.0(21), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2001 by cisco Systems, Inc.

Compiled Mon 31-Dec-01 20:22 by nmasa

Image text-base: 0x80008088, data-base: 0x808FA3E4

ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

ROM: C2600 Software (C2600-IS-M), Version 12.1(18), RELEASE SOFTWARE (fc1)

r26hqct02 uptime is 8 minutes

System restarted by reload

System image file is "flash:c2600-is-mz.120-21.bin"

cisco 2611 (MPC860) processor (revision 0x300) with 39936K/9216K bytes of memory

.

Processor board ID JAD06070DPW (310835556)

M860 processor: part number 0, mask 49

Bridging software.

X.25 software, Version 3.0.0.

2 Ethernet/IEEE 802.3 interface(s)

32K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

2600#sh ip eigrp to 6.0.0.0 255.128.0.0

IP-EIGRP topology entry for 6.0.0.0/9

State is Passive, Query origin flag is 1, 1 Successor(s), FD is 256

Routing Descriptor Blocks:

0.0.0.0, from Redistributed, Send flag is 0x0

Composite metric is (256/0), Route is Internal

Vector metric:

Minimum bandwidth is 10000000 Kbit

Total delay is 0 microseconds

Reliability is 0/255

Load is 0/255

Minimum MTU is 1500

Hop count is 0

2600#sh run

router eigrp 10

redistribute static route-map stat-e10-access-list

network 6.0.0.0

network 9.0.0.0

no auto-summary

!

ip classless

ip route 5.0.0.0 255.0.0.0 Null0

ip route 6.0.0.0 255.0.0.0 Null0

ip route 6.0.0.0 255.128.0.0 Null0

ip route 6.0.128.0 255.255.128.0 Null0

ip route 6.128.0.0 255.128.0.0 Null0

ip route 7.0.0.0 255.0.0.0 10.0.24.253

ip route 7.0.0.0 255.128.0.0 Null0

ip route 8.0.0.0 255.0.0.0 Null0

ip route 9.0.0.0 255.0.0.0 Null0

!

access-list 183 permit ip host 6.0.0.0 host 255.128.0.0

access-list 183 permit ip host 6.128.0.0 host 255.128.0.0

access-list 183 permit ip host 7.0.0.0 host 255.0.0.0

access-list 183 permit ip host 8.0.0.0 host 255.0.0.0

access-list 183 permit ip host 5.0.0.0 host 255.0.0.0

route-map stat-e10-access-list permit 10

match ip address 183

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: