cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1516
Views
0
Helpful
6
Replies

EtherChannel Trunk with Redundency on 2 3750e Stacks

Erick.Valle
Level 1
Level 1

Hello everyone, I new to the etherchannel / Trunking senerio's but I need to know how to configure the following with either of the folling options:  I am also interested in using Spanning-tree in order to prevent loops. But the focus is to create redundency between the 2 stack on different switches with 2Gib of bandwidth available at all times.

=====================================================

active     Enable LACP unconditionally
auto       Enable PAgP only if a PAgP device is detected
desirable  Enable PAgP unconditionally on Enable Etherchannel only
passive    Enable LACP only if a LACP device is detected

I would really appreciate your advise on this configuration. Thank you in advance!

Stack_Redundency.jpg

6 Replies 6

lgijssel
Level 9
Level 9

There is no added value in using two channels here, it merely complicates matters.

Simplest solution:

Configure one channel between the stacks with an uplink on every stack member.

Use "channel mode on" to activate the links unconditionally (always on).

regards,

Leo

You are absoutly correct lgijssel, I will take that approch and see how it goes.  Please keep in mind that I will also be trunking through this etherchannel, Do you see and issues in regards to loops? I beleive I should be using spanning tree correct? or will I not need this function as well?  Just trying to get a good design.

This is the configuration that I have so far, opinions are welcomed!

interface Port-channel1
description 3Gib EtherChannel to Stack1 (1.20)
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1
duplex full
end

Switch_Stack2#sh run int g1/0/28
!
interface GigabitEthernet1/0/28
description EtherChannel Port to Stack.1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1
channel-group 1 mode on
end

Switch_Stack2#sh run int g2/0/28
Building configuration...

Current configuration : 179 bytes
!
interface GigabitEthernet2/0/28
description EtherChannel Port to Stack.1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1
channel-group 1 mode on
end

Switch_Stack2#sh run int g3/0/28
Building configuration...

Current configuration : 182 bytes
!
interface GigabitEthernet3/0/28
description EtherChannel Port to Stack.1  
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1
channel-group 1 mode on
end

Hello Erick,

First my suggestion is to use all Ports as for an etherchannel too.

Additionally I prefere this config (example config added/changes are bold)

Interface GigabitEthernet1/0/28
description EtherChannel Port to Stack.1

switchport mode trunk

switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1 (Use unsused VLAN's as native and use not VLAN1 for normal traffic "security reasons" but good that you allow                                                   only the necessay ones )

switch trunk native vlan 2 (for e.g. must be the same ob both sites)

channel-group 1 mode active (In active Mode you will see configuration problems with on you will not see it)

interface Port-channel1
description 3Gib EtherChannel to Stack1 (1.20)

switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1 (see my first statement)
duplex full (not necessary)

regards,
Sebastian

Hey Sebastioan, Thank for the input , really appreciate it.  You are correct, I actually ended up doing as you mentioned below before I read your post in regards to the:

switchport mode trunk

In regards to the Vlan 1, it's not actually Vlan , I just put that for examples, but it's actually something else.

As far as the "active" parameter in the port-channel, I am interested in seeing the error if any, I am assuming that they will show up in the logs? If so I will shedule the change to modify this as soon as I can.

Thanks for the input once again.

Erick

Hi Erick,

you can check the channel with:

sh etherchannel summary

and

sh etherchannel detail

regards,
Sebastian

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: