cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1026
Views
0
Helpful
2
Replies
Highlighted
Beginner

excessive hsrp updates catalyst 6509e

Hey all, I am seeing excessive HSRP updates on one of our 6509's. The switch is running HSRP between another 6509e & currently also trunking several vlans over a 10Gbps circuit to another site which also has 2 similar 6509s. I can provide more indepth details upon request.

Is there anyone out there who can shed some light on what may be causing  the updates & some typical troubleshooting methods.

The updates are only showing up on one 6509; here is a tibbit from the logs:

Nov 13 10:41:39.949: %HSRP-5-STATECHANGE: Vlan20 Grp 20 state Standby -> Active

Nov 13 10:41:39.989: %HSRP-5-STATECHANGE: Vlan20 Grp 20 state Active -> Speak

Nov 13 10:41:43.389: %HSRP-5-STATECHANGE: Vlan20 Grp 20 state Speak -> Standby

Nov 13 10:41:51.301: %HSRP-5-STATECHANGE: Vlan300 Grp 255 state Standby -> Active

Nov 13 10:41:51.305: %HSRP-5-STATECHANGE: Vlan10 Grp 11 state Standby -> Active

Nov 13 10:41:51.313: %HSRP-5-STATECHANGE: Vlan20 Grp 20 state Standby -> Active

Nov 13 10:41:51.321: %HSRP-5-STATECHANGE: Vlan10 Grp 12 state Standby -> Active

Nov 13 10:41:51.429: %HSRP-5-STATECHANGE: Vlan300 Grp 255 state Active -> Speak

Nov 13 10:41:51.457: %HSRP-5-STATECHANGE: Vlan60 Grp 60 state Standby -> Active

Nov 13 10:41:52.409: %HSRP-5-STATECHANGE: Vlan10 Grp 11 state Active -> Speak

Nov 13 10:41:52.425: %HSRP-5-STATECHANGE: Vlan10 Grp 12 state Active -> Speak

Nov 13 10:41:52.433: %HSRP-5-STATECHANGE: Vlan20 Grp 20 state Active -> Speak

Nov 13 10:41:52.441: %HSRP-5-STATECHANGE: Vlan60 Grp 60 state Active -> Speak

Nov 13 10:41:54.625: %HSRP-5-STATECHANGE: Vlan300 Grp 255 state Speak -> Standby

Nov 13 10:41:55.645: %HSRP-5-STATECHANGE: Vlan20 Grp 20 state Speak -> Standby

Nov 13 10:41:55.817: %HSRP-5-STATECHANGE: Vlan60 Grp 60 state Speak -> Standby

Nov 13 10:41:55.953: %HSRP-5-STATECHANGE: Vlan10 Grp 11 state Speak -> Standby

Nov 13 10:41:55.953: %HSRP-5-STATECHANGE: Vlan10 Grp 12 state Speak -> Standby

Nov 13 10:42:42.362: %HSRP-5-STATECHANGE: Vlan60 Grp 60 state Standby -> Active

Nov 13 10:42:42.574: %HSRP-5-STATECHANGE: Vlan20 Grp 20 state Standby -> Active

Nov 13 10:42:42.590: %HSRP-5-STATECHANGE: Vlan300 Grp 255 state Standby -> Active

Nov 13 10:42:42.650: %HSRP-5-STATECHANGE: Vlan10 Grp 11 state Standby -> Active

Nov 13 10:42:43.362: %HSRP-5-STATECHANGE: Vlan10 Grp 12 state Standby -> Active

Nov 13 10:42:46.054: %HSRP-5-STATECHANGE: Vlan60 Grp 60 state Active -> Speak

Nov 13 10:42:46.054: %HSRP-5-STATECHANGE: Vlan10 Grp 11 state Active -> Speak

Nov 13 10:42:46.066: %HSRP-5-STATECHANGE: Vlan300 Grp 255 state Active -> Speak

Nov 13 10:42:46.070: %HSRP-5-STATECHANGE: Vlan20 Grp 20 state Active -> Speak

Nov 13 10:42:46.078: %HSRP-5-STATECHANGE: Vlan10 Grp 12 state Active -> Speak

Nov 13 10:42:49.178: %HSRP-5-STATECHANGE: Vlan20 Grp 20 state Speak -> Standby

Nov 13 10:42:49.270: %HSRP-5-STATECHANGE: Vlan300 Grp 255 state Speak -> Standby

Nov 13 10:42:49.542: %HSRP-5-STATECHANGE: Vlan60 Grp 60 state Speak -> Standby

Nov 13 10:42:49.542: %HSRP-5-STATECHANGE: Vlan10 Grp 12 state Speak -> Standby

Nov 13 10:42:49.710: %HSRP-5-STATECHANGE: Vlan10 Grp 11 state Speak -> Standby

Everyone's tags (4)
2 REPLIES 2
Participant

Re: excessive hsrp updates catalyst 6509e

Hi,

Can you confirm whether the state of show standby brief will give you other end vlan number as "unknown"?
Can you share some more config details to help you further...


Sent from Cisco Technical Support iPad App

Beginner

Re: excessive hsrp updates catalyst 6509e

Hello,

Here are some details. I will be happy to provide more upon request.

IR03#sh standby br

                     P indicates configured to preempt.

                     |

Interface   Grp  Pri P State   Active          Standby         Virtual IP

Vl10        11   120 P Active  local          xxx.xxx.xxx.xxx  xxx.xxx.xxx.1

Vl10        12   120 P Active  local          xxx.xxx.xxx.xxx  xxx.xxx.xxx.254

Vl20        20   150 P Active  local          xxx.xxx.xxx.xxx  xxx.xxx.xxx.1

Vl30        30   100   Init    unknown         unknown         192.168.8.220

Vl50        51   110 P Init    unknown         unknown         172.16.16.234

Vl60        60   120 P Active  local          xxx.xxx.xxx.3 xxx.xxx.xxx.1

Vl300       255  110 P Active  local          xxx.xxx.xxx.2 xxx.xxx.xxx.12

IR03#

IR04#sh standby br

                     P indicates configured to preempt.

                     |

Interface   Grp  Pri P State   Active          Standby         Virtual IP

Vl10        11   100 P Standby xxx.xxx.xxx.xxx   local          xxx.xxx.xxx.1

Vl10        12   100 P Standby xxx.xxx.xxx.xxx   local          xxx.xxx.xxx.254

Vl20        20   100 P Standby xxx.xxx.xxx.xxx   local           xxx.xxx.xxx.1

Vl30        30   100   Init    unknown         unknown         192.168.8.220

Vl50        51   100   Init    unknown         unknown         172.16.16.234

Vl60        60   100 P Standby xxx.xxx.xxx.2       local           xxx.xxx.xxx.1

Vl300       255  100 P Standby xxx.xxx.xxx.1     local           xxx.xxx.xxx.12

IR04#

SD1#sh standby br

                     P indicates configured to preempt.

                     |

Interface   Grp  Pri P State   Active          Standby         Virtual IP

Vl10        1    100 P Standby  xxx.xxx.xxx.253 local   xxx.xxx.xxx.1

Vl10        10   100 P Standby xxx.xxx.xxx.253 local   xxx.xxx.xxx.238

Vl20        2    100 P Standby xxx.xxx.xxx.3     local   xxx.xxx.xxx.1

Vl30        3    100   Active  local           unknown         192.168.8.254

Vl50        5    100   Active  local           unknown         172.16.16.1

Vl70        1    100 P Standby 10.10.12.3      local           10.10.12.1

Vl100       100  110 P Active  local          xxx.xxx.xxx.3 xxx.xxx.xxx.1

Vl101       101  100   Standby 172.16.4.3      local           172.16.4.1

Vl102       102  100   Standby 172.16.5.3      local           172.16.5.1

SD1#

SD2#sh standby br

                     P indicates configured to preempt.

                     |

Interface   Grp  Pri P State   Active          Standby         Virtual IP

Vl10        1     150 P  Active  local       xxx.xxx.xxx.252   xxx.xxx.xxx.1

Vl10        10   110 P  Active  local        xxx.xxx.xxx.252  xxx.xxx.xxx.238

Vl20        2     150 P Active  local        xxx.xxx.xxx.2      xxx.xxx.xxx.1

Vl30        3     100   Init    unknown         unknown         192.168.8.254

Vl50        5     100   Init    unknown         unknown         172.16.16.1

Vl70        1     100 P Active  local           10.10.12.2      10.10.12.1

Vl100      100  100   Standby xxx.xxx.xxx.2 local         xxx.xxx.xxx.1

Vl101      101  100   Active  local           172.16.4.2      172.16.4.1

Vl102      102  100   Active  local           172.16.5.2      172.16.5.1

SD2#

COLO-DISTRO01#sh standby brief

COLO-DISTRO01#

COLO-DISTRO02#sh standby brief

COLO-DISTRO02#

IR03 & IR04 are in the same location & linked together via a fiber trunk:

IR03#sh run int te4/2

Building configuration...

Current configuration : 139 bytes

!

interface TenGigabitEthernet4/2

description trunk to IR04

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

end

IR03#

IR04#sh run int te4/2

Building configuration...

Current configuration : 136 bytes

!

interface TenGigabitEthernet4/2

description IR03 trunk

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

end

IR04#


SD1 & SD2 are linked together via several ethernet trunks (there's 4 in total - here are two)

SD1#sh run int gi3/34

Building configuration...

Current configuration : 177 bytes

!

interface GigabitEthernet3/34

description SD2-Xlink

switchport

switchport trunk allowed vlan 10,20,30,50,70,80

switchport mode trunk

channel-group 20 mode desirable

end

SD1#

SD1#sh run int gi1/8

Building configuration...

Current configuration : 176 bytes

!

interface GigabitEthernet1/8

description SD2-Xlink

switchport

switchport trunk allowed vlan 10,20,30,50,70,80

switchport mode trunk

channel-group 20 mode desirable

end

SD1#

SD2#sh run int gi3/34

Building configuration...

Current configuration : 177 bytes

!

interface GigabitEthernet3/34

description SD1-Xlink

switchport

switchport trunk allowed vlan 10,20,30,50,70,80

switchport mode trunk

channel-group 20 mode desirable

end

SD2#

SD2#sh run int gi1/8

Building configuration...

Current configuration : 176 bytes

!

interface GigabitEthernet1/8

description SD1-Xlink

switchport

switchport trunk allowed vlan 10,20,30,50,70,80

switchport mode trunk

channel-group 20 mode desirable

end

SD2#

IR03 & SD2 are in separate locations & connected via a 10gig fiber cross connect

SD2#sh run int te2/2

Building configuration...

Current configuration : 152 bytes

!

interface TenGigabitEthernet2/2

description xconnect to oc2 ir03 te4/3

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

end

SD2#

IR03#sh run int te4/3

Building configuration...

Current configuration : 148 bytes

!

interface TenGigabitEthernet4/3

description xconnect to sd02 te2/2

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

end

IR03#

Vlan10, Vlan20 & Vlan300 are public facing Vlans. All the other Vlans you see are private or of no concern.

Vlan 10 has 2 standby groups. The network advertisements are distributed between the two locations.

Vlan 20 has 2 standby groups. The network advertisements are distributed between the two locations.

Vlan 300 is only segmented off IR03/IR04. Vlan 300 goes to a separate pair of of 3750's. OSPF is running between the IR03/IR04 & the two 3750s.

Logs on the 3750s: (ignore the date/time because I just set an ntp peer)

*Dec  8 20:53:13.733: %OSPF-5-ADJCHG: Process 100, Nbr xxx.xxx.xxx.xxx on Vlan300 from FULL to DOWN, Neighbor Down: Dead timer expired

*Dec  8 20:53:17.005: %OSPF-5-ADJCHG: Process 100, Nbr xxx.xxx.xxx.xxx on Vlan300 from LOADING to FULL, Loading Done

*Dec  8 20:53:48.202: %OSPF-5-ADJCHG: Process 100, Nbr xxx.xxx.xxx.xxx on Vlan300 from LOADING to FULL, Loading Done

*Dec  9 09:17:47.297: %OSPF-5-ADJCHG: Process 100, Nbr xxx.xxx.xxx.xxx on Vlan300 from FULL to DOWN, Neighbor Down: Dead timer expired

*Dec  9 09:20:22.294: %OSPF-5-ADJCHG: Process 100, Nbr xxx.xxx.xxx.xxx on Vlan300 from LOADING to FULL, Loading Done

*Dec 12 18:35:55.268: %OSPF-5-ADJCHG: Process 100, Nbr xxx.xxx.xxx.xxx on Vlan300 from FULL to DOWN, Neighbor Down: Dead timer expired

*Dec 12 18:36:34.921: %OSPF-5-ADJCHG: Process 100, Nbr xxx.xxx.xxx.xxx on Vlan300 from LOADING to FULL, Loading Done

*Dec 20 05:23:58.366: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/48, changed state to down

*Dec 20 05:23:59.381: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/48, changed state to down

*Dec 20 05:24:31.534: %OSPF-5-ADJCHG: Process 100, Nbr xxx.xxx.xxx.xxx

on Vlan300 from 2WAY to DOWN, Neighbor Down: Dead timer expired

*Dec 20 05:24:32.751: %OSPF-5-ADJCHG: Process 100, Nbr xxx.xxx.xxx.xxx

on Vlan300 from FULL to DOWN, Neighbor Down: Dead timer expired

*Dec 20 05:27:28.761: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/48, changed state to up

*Dec 20 05:27:30.791: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/48, changed state to up

*Dec 20 05:27:35.740: %OSPF-5-ADJCHG: Process 100, Nbr xxx.xxx.xxx.xxx on Vlan300 from LOADING to FULL, Loading Done

*Dec 20 05:27:41.192: %OSPF-5-ADJCHG: Process 100, Nbr xxx.xxx.xxx.xxx

on Vlan300 from LOADING to FULL, Loading Done

COLO-DISTRO01#sh clock

21:15:03.526 PST Thu Nov 15 2012

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards