Showing results for 
Search instead for 
Did you mean: 

Gi0/0 Interface does not work with modem.

Hi All, we have a Cisco 3825 router which does not work well with a DSL modem(ISP provided). I have configured the Gi0/0 port of the router to plug into this DSL modem but it does not ping to the ISP gateway. If we do a shut/no shut on the interface then it work fine for about 30 secs. Sometimes even for 1 hr. Then the packets drop and we cannot pass any traffic through this interface.

Now, if the ISP connection is terminated on a computer it works fine. It works fine without dropping any packet.

I have tried various options like using a straight/cross cable. I have tried to configure the interface negotiation for 100/full, 100/half, auto/auto and almost all the options.

I have also tried to interconnect the devices using a L2 device like a HUB. Nothing works.

Any recomendation on this? Has anyone seen this kind of a behavior?


Nikhil Kulkarni.

paolo bevilacqua
Hall of Fame Master

You either have a configuration mistake (most likely), or buggy IOS.

It's not a configuration mistake for sure. I will try to upgrade the IOS just to check.

For sure? Post config.

Here is the router config for the interface:


rtr-vpn-kor-seo#sh run in gi0/0

Building configuration...

Current configuration : 194 bytes


interface GigabitEthernet0/0

description *** DMVPN ***

ip address a.b.c.d

ip access-group dmvpn-acl in

load-interval 30

duplex auto

speed auto

media-type rj45




rtr-vpn-kor-seo#sh int gi0/0

GigabitEthernet0/0 is up, line protocol is up

  Hardware is BCM1125 Internal MAC, address is 001a.2ff0.d6a0 (bia 001a.2ff0.d6a


  Description: *** DMVPN ***

  Internet address is a.b.c.d/24

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, media type is RJ45

  output flow-control is XON, input flow-control is XON

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:00, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  30 second input rate 3000 bits/sec, 9 packets/sec

  30 second output rate 0 bits/sec, 0 packets/sec

     2319804 packets input, 143504593 bytes, 0 no buffer

     Received 2282106 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 412948 multicast, 0 pause input

     0 input packets with dribble condition detected

     82646 packets output, 9132275 bytes, 0 underruns

     3 output errors, 0 collisions, 4 interface resets

     17813 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     3 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out



and I have also tried a IOS upgrade...did not work.

Post routing configuration.

and I have also tried a IOS upgrade...did not work.

What IOS are you currently running?