cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
525
Views
4
Helpful
6
Replies

How to connect two Cisco 1700s over a T1

admin_2
Level 3
Level 3

We have a new dedicated full T1 line to another office location. That location has an internet line. We'd like to connect our two Cisco 1700s together over this T1 line so both offices have an internet connection. However, I'm having major difficulty trying to do this. The router configs are:

Office Site (without the internet connection, just the T1 line to the other location):

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname office

!

boot-start-marker

boot-end-marker

!

enable secret xxxx

enable password xxxx

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

no ip routing

no ip cef

!

!

!

no ftp-server write-enable

!

!

!

!

interface FastEthernet0

description Office Network

ip address 192.168.1.1 255.255.255.0

no ip route-cache

speed auto

!

interface Serial0

description T1 connection to other office site

ip address 10.0.0.1 255.255.255.0

encapsulation ppp

no ip route-cache

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.0.0.254

no ip http server

!

!

line con 0

line aux 0

line vty 0 4

password xxxxxxxxx

login

!

!

end

The other site, with the internet connection looks like:

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname colo

!

boot-start-marker

boot-end-marker

!

enable secret xxxx

enable password xxxxxxxxxx

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

no ip routing

no ip cef

!

!

!

no ftp-server write-enable

!

!

!

!

interface FastEthernet0

description To Internet

ip address 192.168.0.254 255.255.255.0

no ip route-cache

speed auto

!

interface Serial0

description T1 Line from Office Location

ip address 10.0.0.254 255.255.255.0

encapsulation ppp

no ip route-cache

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.0.1

no ip http server

!

!

line con 0

line aux 0

line vty 0 4

password xxxxxxxxxx

login

!

!

end

===================================

The two routers cannot ping each other. Any ideas why?

6 Replies 6

thisisshanky
Level 11
Level 11

Do you use external CSU/DSU or the internal one (WIC-1DSU-T1? Do you see any alarm lights on the T1 CSU/DSUs, smartjacks ? You should set one end of the T1 line to clock source internal. (while the other end is set to the defaults -> clock source line)..

This setting can be changed on either the external CSU/DSU, or if you use a internal CSU/DSU (WIC) - this parameter can be changed using an IOS command.

Where is the internet T1 terminating at the second site ? Is it on a separate router ?

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus

You need to enable ip routing on both of the routers. You have the command "no ip routing" entered on both of them.

I agree that turning on ip routing is important. But I would like to understand better the comment about the routers could not ping each other. I understand why the routers would not be able to ping the other routers Ethernet. But if the router can not ping the serial interface address, then it is not an ip routing issue, because you should be able to ping devices on a connected subnet.

Can we verify which addresses you were pinging when it did not work?

And can we get the results of show int on both of the routers?

HTH

Rick

The ends of the T1 are smart jacks. What is the command for changing the clock source ? I'm looking, but not finding it.

For internal CSUs:

conf t

int s0

service-module t1 clock source ?

What does sh int s0 show on both routers?

-HTH

hi

What about the cabling from the smart jack to the router?

Have you checked/replaced them

thanks