cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
456
Views
0
Helpful
0
Replies
Highlighted
Beginner

How to replay traffic to 2x10Gb/s Port-channels?

We are currently trying to improve our network traffic testing setup, to achieve playback of our samples across the network at 20GB/s

We have recently installed a NAS which can run tcpreplay, along with an Intel x520 fibre card with 2 10Gb/s SFP ports, and RAIDed SSDs to ensure the throughput is sufficient. These 2 ports are aggregated and setup correctily with a Cisco WS-C6504-E switch. From here, other fibre lines go to a different part of the building, where there are a number of 3750-x switches. We have 2 separate areas which each have 2 of the 3750-x switches stacked, each having a C3KX-NM-10G installed. On switch 1 in the stack, the 2 10Gb ports are connected back to the 6504 switch. On switch 2, the 2 10Gb ports are linked to another Intel X520 card inside our test machine. We have port aggregation set up and working on all of the switches, the NAS and the testing machines. There is no problem with this setup. In theory, we can have 20Gb/s between the machines.

Our issue, however, comes to our replaying of network traffic. We had remote-span working without at issue, and we were able to play traffic to both test machines without altering our traffic samples. However we were limited to 10Gb/s. RSPAN does not support port channels as the destination interface, only the source, on the 3750x. Am I correct in assuming there is no way around this, in terms of using RSPAN?

We then tried creating a separate vlan for the machines in this test network. We ran tcprewrite to change the destination macs to broadcast. The switches were unable to cope with this level of broadcast traffic and so throughput was worse than with RSPAN.

I was wondering if anyone here can offer advice on whether our desired setup can be achieved with our current setup? Is there any kind of configuration that would prevent the CPU usage going to 100% while allowing broadcasting on the vlan? Is there an alternative setup that might be worth a try?

Thanks in advance for any help.

Everyone's tags (5)
CreatePlease to create content
Content for Community-Ad