cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1783
Views
0
Helpful
4
Replies
Beginner

inter-vlan routing slow performance (3750)

I have a 3750 configured to do inter-vlan routing. There are 4 vlans.

when do a sftp file transfer from hostA on vlan3 to a hostB on vlan2 I only get about 1000kB/sec to 2000kB/sec.

the hosts are connected on downstream 2950 switches on the appropriate vlans.

I am not trunking the vlans, I am using separate ports to connect each vlan back to the 3750

I have some access lists on the vlan interfaces but I see no improvement in transfer rates even when I remove them.

melayer3# sho access-lists hardware counters

L2 ACL INPUT Statistics

Drop: All frame count: 3

Drop: All bytes count: 192

Bridge Only: All frame count: 25498515

Bridge Only: All bytes count: 1670417855

Forwarding To CPU: All frame count: 548870

Forwarding To CPU: All bytes count: 212525804

L3 ACL INPUT Statistics

Drop: All frame count: 5694

Drop: All bytes count: 451707

Bridge Only: All frame count: 7369443

Bridge Only: All bytes count: 526702768

Forwarding To CPU: All frame count: 0

Forwarding To CPU: All bytes count: 0

Forwarded: All frame count: 5197812473

Forwarded: All bytes count: 17902304001

Drop And Log: All frame count: 0

Drop And Log: All bytes count: 0

Bridge Only And Log: All frame count: 8392

Bridge Only And Log: All bytes count: 1627354

Forwarded And Log: All frame count: 0

Forwarded And Log: All bytes count: 0

L2 ACL OUTPUT Statistics

Drop: All frame count: 0

Drop: All bytes count: 0

Bridge Only: All frame count: 124482163

Bridge Only: All bytes count: 8106003071

Forwarding To CPU: All frame count: 0

Forwarding To CPU: All bytes count: 0

L3 ACL OUTPUT Statistics

Drop: All frame count: 30087

Drop: All bytes count: 2632523

Bridge Only: All frame count: 0

Bridge Only: All bytes count: 0

Forwarding To CPU: All frame count: 0

Forwarding To CPU: All bytes count: 0

Forwarded: All frame count: 6005434614

Forwarded: All bytes count: 10641904392

Drop And Log: All frame count: 30208

Drop And Log: All bytes count: 5266764

Bridge Only And Log: All frame count: 0

Bridge Only And Log: All bytes count: 0

Forwarded And Log: All frame count: 0

Forwarded And Log: All bytes count: 0

parts of my config are:

interface Vlan1

no ip address

shutdown

!

interface Vlan2

ip address 134.117.177.1 255.255.255.0 secondary

ip address 134.117.176.1 255.255.255.0

ip access-group 111 in

no ip redirects

no ip unreachables

!

interface Vlan3

ip address 134.117.178.1 255.255.255.0

ip access-group 121 in

ip access-group 122 out

ip helper-address 134.117.176.14

no ip redirects

no ip unreachables

!

interface Vlan4

ip address 134.117.179.1 255.255.255.0

ip access-group 131 in

ip access-group 132 out

ip helper-address 134.117.176.14

no ip redirects

no ip unreachables

!

interface Vlan10

ip address 10.1.10.1 255.255.255.0

!

vtp mode transparent

udld aggressive

ip subnet-zero

ip routing

!

spanning-tree mode rapid-pvst

spanning-tree loopguard default

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

All hosts are connected at 100mbit or 1gigbit.

What is causing the slow performance?

4 REPLIES 4
Beginner

Re: inter-vlan routing slow performance (3750)

This is a known issue. Please add the commands:

mls qos queue-set output 1 threshold 2 40 400 100 400

mls qos queue-set output 1 buffers 15 45 20 20

Good luck.

Highlighted
Beginner

Re: inter-vlan routing slow performance (3750)

that did not help

Beginner

Re: inter-vlan routing slow performance (3750)

One more thing, add the global command 'sdm prefer routing' and reload the cat3750. If it works, you owe me a diet soft drink!

Beginner

Re: inter-vlan routing slow performance (3750)

that did not help either

melayer3#sho sdm prefer

The current template is "desktop routing" template.

The selected template optimizes the resources in

the switch to support this level of features for

8 routed interfaces and 1024 VLANs.

number of unicast mac addresses: 3K

number of IPv4 IGMP groups + multicast routes: 1K

number of IPv4 unicast routes: 11K

number of directly-connected IPv4 hosts: 3K

number of indirect IPv4 routes: 8K

number of IPv4 policy based routing aces: 512

number of IPv4/MAC qos aces: 512

number of IPv4/MAC security aces: 1K

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards