cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
357
Views
5
Helpful
3
Replies

Multiple ISP, different Providers. Outbound load balance without BGP

gjohnson1963
Level 1
Level 1

I have to Internet connections with diffirent IPS providers, one is connected to Serial the other connected to FastEthernet 0/0. I am trying to load balance all out going traffic only without BGP is this possible?

All traffic is going out the serial interface only.

Check Config, any suggestions.

!

version 12.3

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Cisco_3640

!

boot-start-marker

boot-end-marker

!

enable secret 5 xxxxxx

enable password xxxxx

!

no aaa new-model

ip subnet-zero

!

!

!

ip audit notify log

ip audit po max-events 100

no ftp-server write-enable

!

!

interface FastEthernet0/0

description connected to ISP A

ip address 69.X.X..X 255.255.255.248

ip route-cache flow

duplex auto

speed auto

no mop enabled

!

interface Serial0/0

description connected to Sprint

ip address 144.X.X.X 255.255.255.252

ip route-cache flow

fair-queue

service-module t1 timeslots 1-24

service-module t1 remote-alarm-enable

!

interface FastEthernet0/1

description connected to Pix Firewall

ip address 65.X.XX 255.255.255.128

no ip route-cache

duplex auto

speed auto

no mop enabled

!

router rip

version 2

network 65.0.0.0

no auto-summary

!

no ip http server

no ip http secure-server

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

ip route 0.0.0.0 0.0.0.0 Serial0/0

!

!

!

line con 0

line aux 0

line vty 0 4

password xxxxx

login

!

!

!

end

3 Replies 3

Richard Burts
Hall of Fame
Hall of Fame

Given the configuration that you posted I am surprised that you say that all traffic is going over the serial interface. Normally the solution that I suggest if someone wants to balance outgoing traffic in the easiest way, is that I suggest two default routes. This is what you have.

It makes me wonder if there is some issue with the Fast Ethernet interface. It would be helpful if you would post the output of show ip interface brief and the output of show ip route from this router.

I do have another suggestion to make. The static route using the FastEthernet interface is less than optimal. I would suggest that you change that route to be of the form ip route 0.0.0.0 0.0.0.0 instead of having ip route 0.0.0.0 0.0.0.0 FastEthernet0/0. The issue is that if you point the default route at interface FastEthernet 0/0 then the router will ARP for every destination for which it is trying to forward. And it will depend on the provider router to answer (based on proxy ARP). And the fact that this route is not carrying traffic suggests that perhaps the provider router is not responding to your many ARP requests. If you want to verify this turning on debug ip arp for a minute or two might be very instructive. If I am correct you are likely to see that you are sending many ARP requests over the FastEthernet 0/0 interface and are getting no responses.

If you change the default route to point to the next hop address (on the FastEthernet interface) then the only ARP response that you will need is the providers address. This is a potential issue when the outbound interface is a LAN interface but is not an issue when the outbound interface is a point to point serial.

HTH

Rick

HTH

Rick

Thanks

Changing the IP route from fastEthernet 0/0 to the next hop address on the Ethernet port worked.

Thanks again

George

George

I am glad that you got it working.

The implications are subtle that a static route to an interface that is point to point is fine but a static route to an interface that is LAN carries more overhead and certain risks (as you found out) and a lot of people do not understand it. I am pleased that we have an opportunity to clarify this point in this forum.

Best of luck.

Rick

HTH

Rick