cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Popup Hotspot Using ISR 1000 with WiFi/LTE for Teleworkers and Micro Branchesr
329
Views
0
Helpful
2
Replies
Highlighted
Beginner

Port channel is not working on the Server

Hi All,

 

We've got an on premises server installed on our core switch (Stacked).

When I tested it on a different rack switch (single), the slave was joining to the bond0 (Excuse my knowledge with the server configuration as I don't really know much about this and didn't configure it).

 

This test area port channel is configured to LACP mode as below.

 

interface Port-channel19
description * SERVER SUKDEB TESTING *
switchport access vlan 1112
switchport mode access
spanning-tree portfast

 

interface GigabitEthernet1/0/21
description * SERVER SUKDEB TESTING *
switchport access vlan 1112
switchport mode access
channel-group 19 mode active
spanning-tree portfast
!
interface GigabitEthernet1/0/22
description * SERVER SUKDEB TESTING *
switchport access vlan 1112
switchport mode access
channel-group 19 mode active
spanning-tree portfast

 

From the etherchannel summary, the port channel 19 is up and running.

19 Po19(SU) LACP Gi1/0/21(P) Gi1/0/22(P)

 

The server configuration guy said LAG is working on his end.

 

On the core switch, the port channel is set to "ON" mode as it's just server at the end and not connected to anything else.

Also the port channel was not going live with "Active".

Here's the configuration on the core switch.

 

interface Port-channel20
description * SERVER MAIN COMMS *
switchport trunk allowed vlan 1008,1112
switchport mode trunk
!

interface GigabitEthernet2/0/10
description *SERVER MAIN COMMS*
switchport trunk allowed vlan 1008,1112
switchport mode trunk
channel-group 20 mode on

!
interface GigabitEthernet3/0/10
description *SERVER MAIN COMMS*
switchport trunk allowed vlan 1008,1112
switchport mode trunk
channel-group 20 mode on

 

Etherchannel summary shows it's up and running.
20 Po20(SU) - Gi2/0/10(P) Gi3/0/10(P)

 

This is my side of the story.

And here's the server side of story.

 

The configuration is just the same as our local server, should work just fine as local one with core switch if switch side configuration is identical. I went there and checked that both links are blinking green and instead of 4, Edwards suggested to use two links on interface eno3 and eno4.

 

To take both to NEP right now we need to:-
1. we need to configure 8 total ports from switch to support LACP protocol.
2. Two different static IP for those two RAC servers, one has got 10.31.8.200, OS inside it has 10.31.8.210 please see the following, it says both links up means connected, green blinking but link failure coute is 1, has to be 0.

 

And no slaves are joining the master bond0 as the ports are not supporting LACP.

 

1.png

 

bond0 status in kernel filesystem:-

image-20191016-040002.png

 

Do you guys have any opinion why the server is not working with the port channel?

Does it need to be LACP? If so, is there a way to change this to 

Everyone's tags (6)
2 REPLIES 2
Highlighted
VIP Advisor

Re: Port channel is not working on the Server

Hi there,

A port that is in mode on cannot form a port-channel with a device (your server) which is running (active) LACP.

 

For your setup to work the switch either needs to use mode passive or mode active which will facilitate the LCAP negotiation and bring the port-channel up.

 

https://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus9000/sw/6-x/interfaces/configuration/guide/b_Cisco_Nexus_9000_Series_NX-OS_Interfaces_Configuration_Guide/b_Cisco_Nexus_9000_Series_NX-OS_Interfaces_Configuration_Guide_chapter_0110.html#...

 

cheers,

Seb.

Highlighted
Beginner

Re: Port channel is not working on the Server

Hi Seb,

 

Thanks for your response.

I have updated the port channel to Active but still slave not joining from the server.

Here's the current configuration.

 

!
interface Port-channel20
description * SERVER MAIN COMMS *
switchport access vlan 1008
switchport mode access

 

interface GigabitEthernet1/0/10
description *SERVER MAIN COMMS*
switchport access vlan 1008
switchport mode access
lacp rate fast
channel-group 20 mode active
!
interface GigabitEthernet1/0/11
description *SERVER MAIN COMMS*
switchport access vlan 1008
switchport mode access
lacp rate fast
channel-group 20 mode active

 

I have changed the lacp rate fast as server is set to LACP fast.

 

20 Po20(SU) LACP Gi1/0/10(P) Gi1/0/11(P)

 

Channel 20 is up but still server side is not joining the LAG.

Any ideas?