cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
225
Views
0
Helpful
1
Replies
Highlighted
Beginner

priority traffic rdp on switch 3750

Hello, 

I need to priority the traffic on my switch 3750. I did an service policy and an access group to do this:

 

class-map match-all rdp
match access-group 101
!
policy-map rdp
class rdp
set ip dscp af41

 

access-list 101 permit tcp any any eq 3389
access-list 101 permit tcp any eq 3389 any

 

this is the interface:

interface GigabitEthernet2/0/20
description Link to AP ALM00
switchport trunk encapsulation dot1q
switchport mode trunk
switchport port-security maximum 2
priority-queue out
mls qos trust cos
spanning-tree portfast trunk
service-policy input rdp - > I can't apply the output

 

is it ok?

Everyone's tags (3)
1 REPLY 1
VIP Expert

Re: priority traffic rdp on switch 3750

"is it ok?"

Possibly/probably not.

On the 3750, to use its advanced QoS feature you need to globally enable QoS. Once that's done the 3750 provides four egress queues with default traffic mappings. You need to determine whether those defaults are suitable to your needs or amend so so that they are (auto QoS might be an option to use too).

I recall (?) you can only use a service-policy for ingress.

Since you're marking DSCP, you probably want to trust ToS rather than CoS.

If I remember correctly, by default, AF41 will go into the 2nd queue. Also by default, the four hardware queues obtain equal bandwidth (except when you enable PQ, then the 1st queue is PQ). For RDP, you might want to provide it a larger bandwidth guarantee (not that it should need more bandwidth, but to help insure it's dequeued sooner [I also wouldn't use PQ for it]).
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards