cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
842
Views
16
Helpful
11
Replies

PROBLEMS WITH 3 CISCO ROUTERS IN FRAME RELAY

CAPACITYES
Level 1
Level 1

Hello.

I am trying to set up a test lab for frame relay. I have one router Cisco 2620 and 2 routers 1760.

It's like this:

PC1--->1760---F.Relay-->2620<---F.Relay---1760---PC2

The 1760 are configured like a DTE, and the 2600 like switch.

I've configured the 3 routers but I couldn't make pings from PC1 to PC2!! Only from PC1 to the 1760's. Neither from router 2620 to any of the 1720's.

The configuration is the next:

###router 2600##

frame-relay switching

¡

interface serial 0/0

no ip address

encapsulation frame-relay

clockrate 1800000

frame-relay intf-type dce

frame-relay route 17 interface serial 0/1 18

no shutdown

!

interface serial 0/1

no ip address

encapsulation frame-relay

clockrate 1800000

frame-relay intf-type dce

frame-relay route 18 interface serial 0/1 17

no shutdown

######route 2 - 1760 left####

interface fastethernet 0/0

ip address 200.1.1.1 255.255.255.0

no shutdown

!

interface serial 1/0

ip address 163.4.8.1 255.255.255.0

encapsulation frame-relay

no shutdown

!

router eigrp 12

network 163.4.0.0

network 200.1.1.0

######route 3 - 1760 right####

interface fastethernet 0/0

ip address 200.2.2.1 255.255.255.0

no shutdown

!

interface serial 1/0

ip address 163.4.8.1 255.255.255.0

encapsulation frame-relay

no shutdown

!

router eigrp 12

network 163.4.0.0

network 200.2.2.0

I don't know what's the problem, this configuration seems to be ok.

Thanks in advance

1 Accepted Solution

Accepted Solutions

thisisshanky
Level 11
Level 11

There are a few things we can check first.

From 1760-1 to 1760-2 can you ping each other ? If not check a sh frame-relay map and see if you do see a mapping for the remote end. If not we need to fix this problem. Usually FR networks, have inverse arp on by default, so the mapping should be automatic. If not try adding a static frame-relay map for the remote end on either 1760 routers.

If the above ping test works, check to see if EIGRP neighbor relationship is proper (show ip eigrp nei)

If neighbor relationship is working alright, check the routing table to see if 200.x.x.x network is seen in either router's tables.

If the above also holds true, check the default gateway on the PCs, to see if it is configured correctly.

IF all the above are true, check your windows firewall settings, to see if ping packets are being dropped by a firewall like in Win XP.

HTH

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus

View solution in original post

11 Replies 11

thisisshanky
Level 11
Level 11

There are a few things we can check first.

From 1760-1 to 1760-2 can you ping each other ? If not check a sh frame-relay map and see if you do see a mapping for the remote end. If not we need to fix this problem. Usually FR networks, have inverse arp on by default, so the mapping should be automatic. If not try adding a static frame-relay map for the remote end on either 1760 routers.

If the above ping test works, check to see if EIGRP neighbor relationship is proper (show ip eigrp nei)

If neighbor relationship is working alright, check the routing table to see if 200.x.x.x network is seen in either router's tables.

If the above also holds true, check the default gateway on the PCs, to see if it is configured correctly.

IF all the above are true, check your windows firewall settings, to see if ping packets are being dropped by a firewall like in Win XP.

HTH

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus

I noticed later that both the serial interface IPs are configured the same. 163.4.8.1 - that is the problem.

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus

Sorry I've make a mistake, the serial for the router 1760 -right, is 163.4.8.2.

The true code for the router 1760 will be:

[before is ok]

!

interface serial 1/0

ip address 163.4.8.2 255.255.255.0

encapsulation frame-relay

[after is ok]

Thanks thisisshanky!

About the first reply you make, I've to tell you that I couldn't make pings between routers :

Router 1760-left to 2620->PING FAIL!

Router 1760-right to 2620->PING FAIL!

Router 1760 to 1760->PING FAIL!

PC1 to Router 1760-left ->PING OK!

PC2 to Router 1760-rigth ->PING OK!

I can only make pings fromn PC 1 or PC2 to the 1760's routers, so that's is the only thing is correct (Gateway and firewall are not the problems)

Many times, when Serials are connected, I saw the status of the line and Serial goes up and down (protocol and active column) without any reason: sometimes is up, others down...they must be always up or this is normal?

Could I make pings or similar from PC1 and PC2 to their owns Serials to know if the serials are ok?

I learn this configuration in the "McGraw-Hill Cisco TCP-IP Routing Professional Reference" so I can't believe what doesn't work.

I'm thinking about using IGRP routing...but I'm not sure...

Thanks in advance

Try adding the LMI statements on the switch and the routers.

**2600**

2600(config)interface serial 0

2600(config-if)frame-relay lmi-type cisco

Do the same for the other seiral interface. Then add the same command under the serial interfaces of the routers.

If this does not work, can you post the output of the following two commands.

show frame-relay map

show frame-relay pvc

HTH

Scott

I think I have found the problem.

Looks like a mix up on the config of the frame switch.

Your frame-route statements are incorrect.

The first frame-route statment is fine.

*frame-relay route 17 interface serial 0/1 18*

However for the 0/1 interface you have

*frame-relay route 18 interface serial 0/1 17*

With the above command, you have two DLCI's assigned to the 0/1 interface. Try changing this command. You will have to issue a *no frame-relay route 18 interface serial 0/1 17* command then do the following.

*frame-relay route 18 interface serial 0/0 17*

Please rate if this helps!! and keep us posted.

Scott

anthony.yu
Level 1
Level 1

Have you even tried the frame-relay map command - the static mapping on both 1700s routers. For example,

####1760 left######

interface serial 1/0

ip address 163.4.8.1 255.255.255.0

encapsulation frame-relay

fram map ip 163.4.8.2 17 br ( Asssumeing the dlci 17 on the left 1760!)

no shutdown

##route 3 - 1760 right##

interface serial 1/0

ip address 163.4.8.2 255.255.255.0

encapsulation frame-relay

fram map ip 163.4.8.1 18 br (Assuming the dlci 18 on the router 1760!)

no shutdown

Then, show frame-re map, see the mapping is static, active or not.

Note : If IOS is 12.0 or later, lmi-ty is auto sense.

This configuration should work. Let me know your result.

Thanks,

Anthony

Thanks Everybody for the responses, until next monday I can't make any changes in the routers configuration, so on monday I will try and tell you if it's ok or not.

Thank you very much!

The problem doesn't go out, now this is the configuration I've maked:

###router 2600##

frame-relay switching

¡

interface serial 0/0

no ip address

encapsulation frame-relay

clockrate 1800000

frame-relay intf-type dce

frame-relay route 17 interface serial 0/1 18

no shutdown

!

interface serial 0/1

no ip address

encapsulation frame-relay

clockrate 1800000

frame-relay intf-type dce

frame-relay route 18 interface serial 0/0 17

no shutdown

######route 2 - 1760 left####

interface fastethernet 0/0

ip address 200.1.1.1 255.255.255.0

no shutdown

!

interface serial 1/0

ip address 163.4.8.1 255.255.255.0

encapsulation frame-relay

fram-relay map ip 163.4.8.2 17 broadcast

no shutdown

!

router eigrp 12

network 163.4.0.0

network 200.1.1.0

######route 3 - 1760 right####

interface fastethernet 0/0

ip address 200.2.2.1 255.255.255.0

no shutdown

!

interface serial 1/0

ip address 163.4.8.2 255.255.255.0

encapsulation frame-relay

fram-relay map ip 163.4.8.1 18 broadcast

no shutdown

!

router eigrp 12

network 163.4.0.0

network 200.2.2.0

and this are the results in the routers:

####1700 left###3

Router#show frame-relay map

Serial1/0 (up): ip 163.4.8.2 dlci 17(0x11,0x410), static,broadcast,CISCO, status deleted

Router#show frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

Active Inactive Deleted Static

Local 0 0 1 0 <-DELETED

Switched 0 0 0 0

Unused 0 0 0 0

DLCI = 17, DLCI USAGE = LOCAL, PVC STATUS = DELETED, INTERFACE = Serial1/0

####1700 rigtht###

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

Active Inactive Deleted Static

Local 0 1 0 0<-INACTIVE

Switched 0 0 0 0

Unused 0 0 0 0

DLCI = 18, DLCI USAGE = LOCAL, PVC STATUS = INACTIVE, INTERFACE = Serial1/0

Serial1/0 (up): ip 163.4.8.1 dlci 18(0x12,0x420), static,broadcast,CISCO, status deleted

###Router 2600###

Active Inactive Deleted Static

Local 0 0 0 0

Switched 0 1 0 0<-INACTIVE

Unused 0 0 0 0

DLCI = 17, DLCI USAGE = SWITCHED, PVC STATUS = INACTIVE, INTERFACE = Serial0/0

PVC Statistics for interface Serial0/1 (Frame Relay DCE)

Active Inactive Deleted Static

Local 0 0 0 0

Switched 0 1 0 0<-INACTIVE

Unused 0 0 0 0

DLCI = 18, DLCI USAGE = SWITCHED, PVC STATUS = INACTIVE, INTERFACE = Serial0/1

The version is the 12.2, so the Lmi-type is auto sense.

I changed the serial V.35, but the problem doesn't go out.

Well, if anybody knows where's the problem... please post it.

Thanks in advance

Whats your interface status on the Serial interfaces of the 1760's as well as 2600s ? Lower your clock rates to say 56000 and see if that helps!

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus

Yesterday I put the clock to 56000 and any other commands and it was perfect!!! Now the Laboratory Lan works really good!!

This post makes me pass one subject, thank you very much,Thank you!

From Spain, best wishes for everybody of this Forum and for thisisshanky!