cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
135
Views
0
Helpful
3
Replies
Highlighted
Beginner

routing issue..cannot talk to network one hop away

I have a 2514 that has two ethernet ports and one serial. The serial link is on a T1 link and the two ethernet ports are plugged into a switch with 2 vlans....of course there are separate networks on them. OK, the problem is I cannot get my to lans that are on the ethernet ports on my router to talk. Here is the router config.

interface Ethernet0

ip address 12.183.xxx.1 255.255.255.0

no cdp enable

!

interface Ethernet1

ip address 12.45.xx.xxx 255.255.255.240

no cdp enable

!

interface Serial0

ip address 12.127.xxx.xx 255.255.255.252

encapsulation ppp

no cdp enable

!

interface Serial1

no ip address

shutdown

no cdp enable

!

ip default-gateway 12.127.xxx.xxx

ip kerberos source-interface any

ip classless

ip route 0.0.0.0 0.0.0.0 12.127.xxx.xx

no ip http server

!

no cdp run

!

!

line con 0

transport input none

line aux 0

line vty 0

password 7

login

length 25

line vty 1 4

password 7

login

!

ntp clock-period 17179847

ntp server 192.5.41.40

ntp server 192.36.133.66

ntp server 128.9.176.30

ntp server 192.6.38.127 prefer

end

Like, I said though, these two subnets plug into the same router, but are on different vlans. I dont think it is a switching issue, but I fealt that this should be known.

Any help will be appreciated.

btw...I can access both of these networks from the Internet, but not from each other.

3 REPLIES 3
Highlighted
Advisor

Check your default gateway on the PC's on each vlan from which you are testing connectivity.

Highlighted
VIP Mentor

Hello,

I guess you have made sure that the default gateways of the clients on both subnets correspond to the IP addresses of the Ethernet interfaces and that the subnet masks match ?

Can you try and enable the global command ´ip classless´ ?

Regards,

GP

Highlighted
Beginner

Hi,

If you have a routing issue then running a traceroute (tracert on Windows systems) from both of your networks would reveal the path taken by your IP packets and this can give you some clues about what is really happening.

Regards,