cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

269
Views
10
Helpful
14
Replies
Beginner

Serial1/0 is up, line protocol is up (looped)

Hi All,

 

I would like to request assistance. In my organisation i have 2 serial links out of which only one is fully working and i can ping the PTP IP's in that serial link (has no Looped Error). The issue only replies with the second serial link where shows Serial1/0 is up, line protocol is up (looped) when i issue "show interface serial 1/0" and not able to ping the PTP IP's.

 

I have the same exact configuration on both the links but still get (looped) error on the second link only.. I have been reading few discussion online and some point to check with the service providers and they have checked it twice and found no issues with the link.

 

I have never worked serial links and find difficult in troubleshooting steps and running below. I have attached show interface serial result for both working and not working interface.

 

ROM: System Bootstrap, Version 12.4(12.2r)T, RELEASE SOFTWARE (fc1)
BOOTLDR: Cisco IOS Software, 7200 Software (C7200P-KBOOT-M), Version 15.2(4)M5, RELEASE SOFTWARE (fc2)

3 ACCEPTED SOLUTIONS

Accepted Solutions
Collaborator

Re: Serial1/0 is up, line protocol is up (looped)

Assuming it is just a pair of coax cables from the provider equipment to each router, then disconnect them from one router and check to see if that router shows the loop dropping as well as the far end. My guess is that the loop drops on the side where you disconnect the cables and the other end still sees a loop. Then do the same on the other side and if the results are the same, then call the provider, explain what you did and insist they come on prem to test end to end and prove to you there is no loop in the circuit. 

One of two things will then happen:

1- They will miraculously find the loop and fix the issue.

2- They will find it when they come out.

Hope this helps.

View solution in original post

VIP Advisor

Re: Serial1/0 is up, line protocol is up (looped)

line protocol is up (looped)  - Means it is clear, somewhere the Link is given hard loop, worth checking with the provider. ( NTU side)

BB
*** Rate All Helpful Responses ***

View solution in original post

Collaborator

Re: Serial1/0 is up, line protocol is up (looped)

The testing with shutting the interfaces should suffice. Knowing that the ends of the circuit are in different countries only increases the chances that there is an erroneous loop somewhere in the circuit. It could just as easily be a logical loop,  like in a piece of equipment like a DACS, MUX, etc. versus a physical cable loop at a patch point. 

Please let us know how you make out. 

 

View solution in original post

14 REPLIES 14
Highlighted
Beginner

Re: Serial1/0 is up, line protocol is up (looped)

Attached working txt file

VIP Collaborator

Re: Serial1/0 is up, line protocol is up (looped)

Hello,

Could you provide more information about your network and topology? If possible a simple draw can help us.

provide output from:
show spanning-tree
show interface status
show ip int brief
show int s0/0 (id of each interface)
Jaderson Pessoa
*** Rate All Helpful Responses ***
Beginner

Re: Serial1/0 is up, line protocol is up (looped)

Thank You Jaderson for your response. Please find attached requested results. Only "show interface status" router did not accept.

 

Router1#show interface status
^
% Invalid input detected at '^' marker.

 

For topology its nothing much and just a normal /30 PTP interface and no other configs are there. I had moved the interface to a test VRF so that i could troubleshoot and establish normal  PTP ping  between link without any service effects. Below i have also provided serial configurations on both sides.

 

Router1#show run inter ser 1/0
Building configuration...

Current configuration : 275 bytes
!
interface Serial1/0
ip vrf forwarding DS-TEST
ip address 192.168.1.1 255.255.255.252
ip mtu 1600
ip ospf network point-to-point
ip ospf cost 100
load-interval 30
mpls mtu 1600
mpls ip
dsu bandwidth 44210
framing c-bit
cablelength 10
serial restart-delay 0

 

Router2#show run inter ser 1/0
Building configuration...

Current configuration : 272 bytes
!
interface Serial1/0
mtu 1600
ip vrf forwarding DS-TEST
ip address 192.168.1.2 255.255.255.252
ip flow ingress
ip flow egress
ip ospf network point-to-point
ip ospf cost 100
mpls ip
dsu bandwidth 44210
framing c-bit
cablelength 10
serial restart-delay 0

 

I am able to ping the local serial physical IP but not across the interface.

Router1#ping vrf DS-TEST 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

 

Router2#ping vrf DS-TEST 192.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

 

Thanks 

 

Beginner

Re: Serial1/0 is up, line protocol is up (looped)

Also forgot to mention the a local service provider is providing a link from Country A to Country B via satellite
Collaborator

Re: Serial1/0 is up, line protocol is up (looped)

Assuming it is just a pair of coax cables from the provider equipment to each router, then disconnect them from one router and check to see if that router shows the loop dropping as well as the far end. My guess is that the loop drops on the side where you disconnect the cables and the other end still sees a loop. Then do the same on the other side and if the results are the same, then call the provider, explain what you did and insist they come on prem to test end to end and prove to you there is no loop in the circuit. 

One of two things will then happen:

1- They will miraculously find the loop and fix the issue.

2- They will find it when they come out.

Hope this helps.

View solution in original post

Beginner

Re: Serial1/0 is up, line protocol is up (looped)

Hello Chrishussey,

 

Instead of disconnecting from router can i shut down the serial interface instead as both are located in different countries and would be bit challenging to physically disconnect from hardware. If yes i have done shutdown on one side and noticed the other side still showing looped(waiting 5 min before i check if still looped) and vice versa . Below result for reference

 

One way
Router1(config-if)#do show inter ser 1/0
Serial1/0 is administratively down, line protocol is down

 

Router2#show inter ser 1/0
Serial1/0 is up, line protocol is up (looped)

 

From the other side

Router2(config-if)#do show inter ser 1/0
Serial1/0 is administratively down, line protocol is down

 

Router1#show inter ser 1/0
Serial1/0 is up, line protocol is up (looped)

 

I have also attached the picture of cable connected serial interface.

 

Also noticed when i shut down Router 1 serial interface Router2 stays up and Looped and then i flap router2 serial interface it stays down for few seconds then comes up (protocol up and looped).Would this definitely confirm that the service provider needs to check the link? 

 

Router2#show inter ser 1/0
Serial1/0 is up, line protocol is up (looped) 

VIP Advisor

Re: Serial1/0 is up, line protocol is up (looped)

line protocol is up (looped)  - Means it is clear, somewhere the Link is given hard loop, worth checking with the provider. ( NTU side)

BB
*** Rate All Helpful Responses ***

View solution in original post

Beginner

Re: Serial1/0 is up, line protocol is up (looped)

Thanks I have again contacted the service provider. Hopefully they come up with something
Beginner

Re: Serial1/0 is up, line protocol is up (looped)

Hello,

 

I checked provider confirms no issues their end.Now m checking my end hopefully find an fault.

Collaborator

Re: Serial1/0 is up, line protocol is up (looped)

The testing with shutting the interfaces should suffice. Knowing that the ends of the circuit are in different countries only increases the chances that there is an erroneous loop somewhere in the circuit. It could just as easily be a logical loop,  like in a piece of equipment like a DACS, MUX, etc. versus a physical cable loop at a patch point. 

Please let us know how you make out. 

 

View solution in original post

Beginner

Re: Serial1/0 is up, line protocol is up (looped)

Hello,

 

The provider has checked their end again and confirms there are no loops and have requested for me to check the cross connect from meet me room till my hardware at B location as they suspect issue is only at B location. 

 

What is intend to do is totally disconnect meet me room connection in B location so that there are no connection at all till my hardware and A location should clear loop if issue is with B location. Please let me know if this test would actually clear out B  any possible issues with B location

 

Thanks 

Collaborator

Re: Serial1/0 is up, line protocol is up (looped)

If it is strictly cable from the provider equipment to your router at the B location and by disconnecting the cables from the provider equipment makes the loop go away at the A side then yes, the problem is at the B side. Not sure of your configuration, but then you need to investigate the cabling at the B side. Is it a short run from the provider equipment to the router with just a pair of coax cables, or is it a longer run with patch panels or connection points where a hard loop could possibly be?

Also, by removing the cables from the provider equipment at the B side, if by chance the A side still sees a loop, then it is with the provider.   

Beginner

Re: Serial1/0 is up, line protocol is up (looped)

Looped was identified in my rack. The Loop error in serial interface is basically a physical loop and needs to be checked at each hop

Collaborator

Re: Serial1/0 is up, line protocol is up (looped)

Thanks for the update and glad you got it figured out.

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here