cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
430
Views
0
Helpful
13
Replies
swendorf1
Beginner

Slow when others download?

Hello,

We have a very simple network setup. Cisco 2611 with a serial T1. We use only one of the ethernet ports for our internal network.Only have about 15 total machines from a switch that is connected to the ethernet interface of the 2611. OUR PROBLEM: When a single user within our site downloads a file it dramatically slows down all other users in the office and users accessing our Citrix Server from the outside. When I traceroute or ping or serial interface as a download is in progress, the latency is very high (around 400ms). As soon as the download stops, the piing and traceroute times drop back to about 7ms. We used to use a different carrier months ago and never seemed to have this problem. I have checked the cpu and ram usage within the 2611 while a download is on progress they appear to be normal. I have contaceted qwest (our carrier) and they claim there iis no packet loss and all links to us are functioning normally. SO I am just a little stuck here. I''m not sure if this is normal because with our last carrier we did not have this problem running the same speed. I confirmed with our last carrier that they were not running any type of prioritization software also. Can anybody throw some ideas my way that I could chjeck on. I would really appreciate it.

13 REPLIES 13

Hi,

Have you checked the T1 utilization when the download is occuring? Is it running 100% busy?

Dave

Hi,

Yes, Qwest tells me that we our utilization is very high. But why were we fine with the other carrier?

Do you have access to the router that the Qwest T1 is attached to? If so, then get into that router and display the Serial interface of that connection. You can then see the 5 minute traffic averages on that interface to be certain if you are using 100% of the pipe during the download. 100% utilized would be 1544kb per sec one way. You need to see that statistic to ensure you are actually getting full T1 throughput.

Dave

Richard Burts
Hall of Fame Guru

Were there changes in the router configuration when you switched carriers (I would assume there were) and if so what changed?

It might be beneficial if you posted the configuration of the router.

HTH

Rick

HTH

Rick

I just talked to the qwest Tech. He told me that they have verified the usage at THIER router and it is okay...Here is a copy of my config

! Last configuration change at 11:58:48 mst Thu Jul 29 2004

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname CISCO2600

!

boot system flash c2600-is-mz

enable secret xxx

enable password xxx

!

!

!

!

!

clock timezone mst -6

ip subnet-zero

ip name-server 205.171.3.65

!

!

!

!

!

!

interface Loopback0

no ip address

no ip directed-broadcast

!

interface Ethernet0/0

ip address 10.1.1.254 255.255.255.0

ip access-group 100 in

no ip directed-broadcast

ip nat inside

full-duplex

!

interface Serial0/0

description qwest ds1it-8885442 acct65800901 8778866515

ip address 208.x.x.x.x.255.252

no ip directed-broadcast

ip nat outside

no ip mroute-cache

!

interface Ethernet0/1

ip address 192.168.1.100 255.255.255.0

no ip directed-broadcast

ip nat inside

full-duplex

!

router rip

version 2

redistribute static

network 10.0.0.0

default-metric 1

no auto-summary

!

ip nat pool netpool 208.x.x.x.46.86.154 netmask 255.255.255.252

ip nat inside source list 2 pool netpool overload

ip nat inside source static 10.1.1.7 208.46.86.158

ip classless

ip route 0.0.0.0 0.0.0.0 208.46.78.53

no ip http server

ip http access-class 1

!

logging history size 100

logging history emergencies

logging trap debugging

logging facility syslog

logging source-interface Loopback0

logging 10.1.1.3

access-list 2 permit 10.1.1.0 0.0.0.255

access-list 2 permit 192.168.1.0 0.0.0.255

access-list 100 deny tcp host 10.1.1.7 any eq www

access-list 100 deny tcp host 10.1.1.8 any eq www

access-list 100 permit tcp any any

access-list 100 permit ip any any

banner motd how

!

line con 0

transport input none

speed 115200

line aux 0

line vty 0 4

password xxx

login

!

ntp clock-period 17208690

ntp peer 192.43.244.18

no scheduler allocate

end

Can you send me the output of the show int s0/0 command when the download is occuring?

Dave

David,

I sent what you needed to your email address. Thank you for your help.

Thanks for the output. Check the response time to the device in quesiton while the download is occuring and compare it to the response time to the other side of the T1.

The response time is good inside the LAN to the device. Less than 1ms. The response time to the device from outside the router is really high, 500ms. It seems the slow down occurs when you travel a path that runs through a couple of Qwest Routers to our Routers serial port.