cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1757
Views
0
Helpful
10
Replies

Spanning Tree and HSRP issues

matthewolah
Level 1
Level 1

Hello everyone,

 

I am currently having an issue with this lab I am working on in packet tracer. I have around 14 hours into this and cannot seem to find out why I am having issues.

This is a Lab with HSRP for 4 Vlans, 10,20,30, and 40. Overall, I have L3 distribution switches that can see 2 of the hsrp standby's, one being local and the other being the secondary. I will post some screenshots. I have a reason to believe its because of spanning tree. The network is running ospf and has all proper network statements. As of right now I'm just trying to figure out the distribution L3 switches.

 

entire network.png

distribution A standby brief.png

 

Dist B Standby.png

 

distribution c standby brief.png

 

distribution D standby breif.png

 

Distribution A Config: 

DistA(config-if)#do show run
Building configuration...

Current configuration : 2668 bytes
!
version 16.3.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname DistA
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
no ip cef
ip routing
!
no ipv6 cef
!

!
!
spanning-tree mode pvst
spanning-tree vlan 10 priority 24576
spanning-tree vlan 20 priority 28672
spanning-tree vlan 40 priority 36864
!
!
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/3
no switchport
ip address 192.168.254.2 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet1/0/4
no switchport
ip address 192.168.254.18 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
!
interface Vlan10
mac-address 0060.479a.bd01
ip address 172.31.10.1 255.255.255.0
ip helper-address 192.168.254.1
standby 10 ip 172.31.10.254
standby 10 preempt
!
interface Vlan20
mac-address 0060.479a.bd02
ip address 172.31.20.1 255.255.255.0
ip helper-address 192.168.254.1
standby 20 ip 172.31.20.254
standby 20 priority 90
!
interface Vlan30
mac-address 0060.479a.bd03
ip address 172.31.30.1 255.255.255.0
standby 30 ip 172.31.30.254
standby 30 priority 80
!
interface Vlan40
mac-address 0060.479a.bd04
ip address 172.31.40.1 255.255.255.0
standby 40 ip 172.31.40.254
standby 40 priority 70
!
router ospf 1
router-id 1.1.2.1
log-adjacency-changes
network 192.168.254.0 0.0.0.255 area 1
network 192.168.1.0 0.0.0.255 area 1
network 172.31.0.0 0.0.255.255 area 1
!
ip classless
!
ip flow-export version 9
!
!
line con 0
password cisco
login
!
line aux 0
password cisco
login
!
line vty 0 4
password cisco
login
!
!
end


Distribution B config: 

DistB(config)#do show run
Building configuration...

Current configuration : 2663 bytes
!
version 16.3.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname DistB
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
!
!
no ip cef
ip routing
!
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree vlan 20 priority 20480
spanning-tree vlan 10 priority 28672
spanning-tree vlan 30 priority 36864
!
!
!
!
!
!
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/3
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/4
no switchport
ip address 192.168.254.6 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet1/0/5
no switchport
ip address 192.168.254.22 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface Vlan1
ip address 192.168.1.2 255.255.255.0
!
interface Vlan10
mac-address 0000.0c91.a901
ip address 172.31.10.2 255.255.255.0
standby 10 ip 172.31.10.254
standby 10 priority 90
!
interface Vlan20
mac-address 0000.0c91.a902
ip address 172.31.20.2 255.255.255.0
standby 20 ip 172.31.20.254
standby 20 preempt
!
interface Vlan30
mac-address 0000.0c91.a903
ip address 172.31.30.2 255.255.255.0
standby 30 ip 172.31.30.254
standby 30 priority 70
!
interface Vlan40
mac-address 0000.0c91.a904
ip address 172.31.40.2 255.255.255.0
standby 40 ip 172.31.40.254
standby 40 priority 80
!
router ospf 2
router-id 1.1.2.2
log-adjacency-changes
network 192.168.254.0 0.0.0.255 area 1
network 192.168.1.0 0.0.0.255 area 1
network 172.31.0.0 0.0.255.255 area 1
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
password cisco
login
!
line aux 0
password cisco
login
!
line vty 0 4
password cisco
login
!
!
!
!
end

 

Distribution C config: 

DistC#show run
Building configuration...

Current configuration : 2664 bytes
!
version 16.3.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname DistC
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
!
!
no ip cef
ip routing
!
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree vlan 30 priority 24576
spanning-tree vlan 40 priority 28672
spanning-tree vlan 20 priority 36864
!
!
!
!
!
!
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/3
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/4
no switchport
ip address 192.168.254.10 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet1/0/5
no switchport
ip address 192.168.254.26 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface Vlan1
ip address 192.168.1.3 255.255.255.0
!
interface Vlan10
mac-address 000b.be70.4c01
ip address 172.31.10.3 255.255.255.0
standby 10 ip 172.31.10.254
standby 10 priority 80
!
interface Vlan20
mac-address 000b.be70.4c02
ip address 172.31.20.3 255.255.255.0
standby 20 ip 172.31.20.254
standby 20 priority 70
!
interface Vlan30
mac-address 000b.be70.4c03
ip address 172.31.30.3 255.255.255.0
standby 30 ip 172.31.30.254
standby 30 preempt
!
interface Vlan40
mac-address 000b.be70.4c04
ip address 172.31.40.3 255.255.255.0
standby 40 ip 172.31.40.254
standby 40 priority 90
!
router ospf 3
router-id 1.1.2.3
log-adjacency-changes
network 192.168.254.0 0.0.0.255 area 1
network 192.168.1.0 0.0.0.255 area 1
network 172.31.0.0 0.0.255.255 area 1
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
password cisco
login
!
line aux 0
password cisco
login
!
line vty 0 4
password cisco
login
!
!
!
!
end

 

 

Distribution D Config:

DistD#show run
Building configuration...

Current configuration : 2603 bytes
!
version 16.3.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname DistD
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
!
!
no ip cef
ip routing
!
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree vlan 40 priority 20480
spanning-tree vlan 30 priority 28672
spanning-tree vlan 10 priority 36864
!
!
!
!
!
!
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/3
no switchport
ip address 192.168.254.30 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet1/0/4
no switchport
ip address 192.168.254.14 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface Vlan1
ip address 192.168.1.4 255.255.255.0
!
interface Vlan10
mac-address 00e0.f93d.1801
ip address 172.31.10.4 255.255.255.0
standby 10 ip 172.31.10.254
standby 10 priority 70
!
interface Vlan20
mac-address 00e0.f93d.1802
ip address 172.31.20.4 255.255.255.0
standby 20 ip 172.31.20.254
standby 20 priority 80
!
interface Vlan30
mac-address 00e0.f93d.1803
ip address 172.31.30.4 255.255.255.0
standby 30 ip 172.31.30.254
standby 30 priority 90
!
interface Vlan40
mac-address 00e0.f93d.1804
ip address 172.31.40.4 255.255.255.0
standby 40 ip 172.31.40.254
standby 40 preempt
!
router ospf 4
router-id 1.1.2.4
log-adjacency-changes
network 192.168.254.0 0.0.0.255 area 1
network 192.168.1.0 0.0.0.255 area 1
network 172.31.0.0 0.0.255.255 area 1
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
password cisco
login
!
line aux 0
password cisco
login
!
line vty 0 4
password cisco
login
!
!
!
!
end

 

 

I appreciate any help that anyone has to offer. 

Thank you,

Matt

10 Replies 10

balaji.bandi
Hall of Fame
Hall of Fame

Long post before i go deep to look each config - in short what is the issue ? HSRP ? or OSPF peering ? ( where is your OSPF area 0 ?)

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Ospf area 0 is on the core L3 switches. I will be at work for most of the day and away from my machine. I will Post as much information as possible. 

Core A Config: 

CoreA(config)#do show run
Building configuration...

Current configuration : 2719 bytes
!
version 16.3.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname CoreA
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
ip dhcp excluded-address 172.31.10.254
ip dhcp excluded-address 172.31.20.254
ip dhcp excluded-address 172.31.30.254
ip dhcp excluded-address 172.31.40.254
ip dhcp excluded-address 172.31.10.1 172.31.10.10
ip dhcp excluded-address 172.31.20.1 172.31.20.10
ip dhcp excluded-address 172.31.30.1 172.31.30.10
ip dhcp excluded-address 172.31.40.1 172.31.40.10
!
ip dhcp pool LAN-10
network 172.31.10.0 255.255.255.0
default-router 172.31.10.254
ip dhcp pool LAN-20
network 172.31.20.0 255.255.255.0
default-router 172.31.20.254
ip dhcp pool LAN-30
network 172.31.30.0 255.255.255.0
default-router 172.31.30.254
ip dhcp pool LAN-40
network 172.31.40.0 255.255.255.0
default-router 172.31.40.254
!
!
!
no ip cef
ip routing
!
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet1/0/1
no switchport
ip address 192.168.254.1 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet1/0/2
no switchport
ip address 192.168.254.5 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet1/0/3
no switchport
ip address 192.168.254.9 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet1/0/4
no switchport
ip address 192.168.254.13 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet1/0/5
no switchport
ip address 192.168.255.1 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface Vlan1
ip address 1.1.1.1 255.255.0.0
!
router ospf 10
router-id 1.1.1.1
log-adjacency-changes
network 192.168.255.0 0.0.0.3 area 0
network 192.168.254.0 0.0.0.255 area 1
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
password cisco
login
!
line aux 0
password cisco
login
!
line vty 0 4
password cisco
login
!
!
!
!
end


CoreB Config:

 

CoreB#show run
Building configuration...

Current configuration : 2722 bytes
!
version 16.3.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname CoreB
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
ip dhcp excluded-address 172.31.10.254
ip dhcp excluded-address 172.31.20.254
ip dhcp excluded-address 172.31.30.254
ip dhcp excluded-address 172.31.40.254
ip dhcp excluded-address 172.31.40.1 172.31.40.10
ip dhcp excluded-address 172.31.30.1 172.21.30.10
ip dhcp excluded-address 172.31.20.1 172.21.20.10
ip dhcp excluded-address 172.31.10.1 172.21.10.10
!
ip dhcp pool LAN-10
network 172.31.10.0 255.255.255.0
default-router 172.31.10.254
ip dhcp pool LAN-20
network 172.31.20.0 255.255.255.0
default-router 172.31.20.254
ip dhcp pool LAN-30
network 172.31.30.0 255.255.255.0
default-router 172.31.30.254
ip dhcp pool LAN-40
network 172.31.40.0 255.255.255.0
default-router 172.31.40.254
!
!
!
no ip cef
ip routing
!
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet1/0/1
no switchport
ip address 192.168.254.17 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet1/0/2
no switchport
ip address 192.168.254.21 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet1/0/3
no switchport
ip address 192.168.254.25 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet1/0/4
no switchport
ip address 192.168.254.29 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet1/0/5
no switchport
ip address 192.168.255.2 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface Vlan1
ip address 1.1.1.2 255.255.0.0
!
router ospf 20
router-id 1.1.1.2
log-adjacency-changes
network 192.168.255.0 0.0.0.3 area 0
network 192.168.254.0 0.0.0.255 area 1
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
password cisco
login
!
line aux 0
password cisco
login
!
line vty 0 4
password cisco
login
!
!
!
!
end

 

It is very possible that I have missed something very easy because my brain is very tired. 

 

Attached is the Packet tracer if that helps. 

Hello
It looks like you have a L3 core /distribution (2 core ,4 distribution) with multiple HSRP groups on all of the distribution switches which are not only directly connecting to the two core switches but also each other, The 4 distribution switches have various hsrp group priority's but all have the same stp priorities?-  Very convoluted.

I would suggest you have just the two core switches perform all the L3, (inc HSRP) and become the stp roots, and have the distribution switches' perform just at  L2.

 

As for stp you could tweak the trunks between the core and the distribution and access layer to so stp runs over these links to a preference you wish and you could to split the stp then make core 1 stp root for say vlan 10, 20 and core 2 stp root for vlan 30,40, same for HSRP

Core 1
spanning-tree vlan 10,20 priority 0

spanning-tree vlan 30,40 priority 4096
int vlan 10
standby 10 priority  115
int vlan 20
standby 20 priority  115

Core 2
spanning-tree vlan 10,20 priority 4096
spanning-tree vlan 30,40 priority 0
int vlan 30
standby 30 priority  115
int vlan 40
standby 40 priority  115

 

Trunk links
int/x
spanning-tree vlan x cost xx
< this will affect downstream port selection, higher value less preferred 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Also, I am not having any ospf issues, everything is pingable from interface to interface on L3 switches. HSRP is the issue where it cannot see 2 of the standby switches and marks them as unknown. This applies to all distribution switches: The l3 switch can only see its primary(itself being active) and secondary vlan(The standby).

the issue AS I think there are more than one Peer in HSRP and this is because the VLAN is spanning though the total all topology. 
to solve this issue 
make the connect between Dis and Core as L3 not L2.

I dont think that is the issue since those links are already in L3. All links from dist to core are layer 3 with ip's attached to the interface and ospf routes them. the links from dist to access are all trunk links. I have made a separate packet tracer and started with a smaller scale network with the same principles. Everything was working fine until I added the 4th distribution in with vlan 40 and the link the core 2. I am now getting ospf flapping vlan networks on distribution. The more I add it seems to get worse.

 

Screenshot 2021-04-23 215638.png

What make me sure it vlan issue is listen state in hsrp where if more than one l3 in hsrp group then any additional more than two will be listen.

How you config it as l3 link?

Im sorry, I dont know exactly what you mean. How I configured this is, I set core and distribution links as normal IPs on interfaces, and then set vlans on the distribution switches and put an entry in ospf for both of those networks: the vlan as a summary 192.168.0.0 0.0.255.255 and the links between core and distribution as 10.0.0.0 255.255.255.0 which covers the /30 links between core and distribution. Im sorry am I missing something? I'm still learning all of this stuff and am still rather a beginner in networking. I know how ospf works for the most part and how to configure it on its own, but when you include hsrp and spanning tree I get confused. I know I'm missing something rather dumb in this topology but I'm just not getting it. 

Hi Friend 
make trunk from each Access SW to each all Dis SW.

and config the STP to make this Dis SW is Root for VLAN that it will be the HSRP active.

finally config the HSRP.

Hi

You have configured all access switches as trunkports connected to distribution.

meaning all vlan will travel over them.

1. Swich A and B are both connected to distribution A and B

so for those 4 there will be one link in stp blocking, the rest will be forwarding.

2. Switch D and E are both connected to distribution C and D 

so for those 4 there will be one link in stp blocking, the rest will be forwarding.

3. Then You have switch C connected to distribution B and C

so this connects them all together.

 

So basically all 4 distribution can reach each other via the above connection tree, for all of the vlans.

In each vlan the hsrp with prio 100 will be the active one, the prio 90 will be stanby, the prio 80 and 70 will be listen.

If one of the prio 100 or prio 90 shuts down, then the prio 80 will be standby.

 

/Mikael