cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
792
Views
0
Helpful
13
Replies
zillah2004
Beginner

traceroute, tftp, copy run startup, NVRAM

Hi All

1- I have got two routers connect to each other through serial cable, why when I erase startup, and reload router, still I can see the previous configuration? Does because one router tries to tftp from other router?

If disconnect the cable, I will able to delete configuration.

2- Some times when I configure router, and "copy run to startup" , and reload router, suddenly I loose my configuration, I try second time with the same router without any problem,,,,why dose this happen, and some time does not with same router? I knew if we try bypass the NVRAM with registry setting, but this no my case, because some times it happened and some time

3- When I tried to boot the router some times I received this error message:

%Error opening tftp://255.255.255.255/network-confg (Timed out)

%Error opening tftp://255.255.255.255/network-confg (Timed out)

%Error opening tftp://255.255.255.255/cisconet.cfg (Timed out)

SETUP: new interface FastEthernet0/0 placed in "shutdown" state

SETUP: new interface Serial0/1 placed in "shutdown" state

%Error opening tftp://255.255.255.255/network-confg (Timed out)

%Error opening tftp://255.255.255.255/cisconet.cfg (Timed out)

%Error opening tftp://255.255.255.255/router-confg (Timed out)

I knew we can disable this through :

No ip domain-lookup,,,but my concern when I boot the router from scratch , how we can disable this?

4- Some times I issued command traceroute , how can I disable this command rather than waiting it to finish 30 hops?

13 REPLIES 13
Prashanth Krishnappa
Cisco Employee

Few things I would do

*Make sure your config-register is 0x2102

*Configure "no service config" command. This should take care of issue number 3

http://www.cisco.com/univercd/cc/td/doc/product/software/ios123/123cgcr/fun_r/cfr_1g06.htm#wp1053300

I do not know of any command to limit the hops for traceroute but you can break out of it using Ctrl, Shift, and 6 keys, and then pressing the X key.

Thanks prkrishn

no service config,,,yee it do the job,,,but as I said before when I am trying to boot the router I received this error message, I can not access global configuration yet,,,,how I disabled at boot time.

About registration,,,as I said: why some times it happen and some it does not???, if the issue with registration only, it should happened all the times without any exception

If it is trying to boot from the network , it will eventually quit trying and go into router config mode but this is usually about 20 minutes so boot it up and let it sit for about 25 minutes and see if it will boot to the point of letting you config the router .

thanks glen.grant

You have got my point,,,,but I want to bypass waiting time (20 or 25 minutes),,Is there any way to do that? As you said eventually I can get to privilege mode,,but this is not the case,,,my case I said I want to bypass the waiting time

Any other help , because it is annoying

You only have to bypass it once. Wait the 20 minutes, go into priveleged morde, kill the config service no service config, save the config to NVRAM copy run start, then re-boot. It should then come up right away.

Have I misunderstood the problem?

Kevin Dorrell

Luxembourg

Thanks Kevin

I was about to send you email to discuss this issue with you. You did not misunderstand my problem, I am aware of what you said, but I thought there is some thing ealse.

Another thing I am experiencing between time to time(not always), when I have two routers connecting to each other by serial cable,and when I delete one router and configure it with out deleting the second router yet.

Then I start to delete second router and reload it, still I can see configuration!!!!!!!! , unless I remove serial cable, then I repeat the earse startup and reload, and I can get rid of the previous configuration,Why?

Second: some time if still there is cable(it hasnot been removed yet)when I earse configuration for second router and reload it, the serial interfcae of second router takes ip address for instance: 192.168.0.2 or 172.16.1.3 if the ip address for first router was 192.168.0.1, 172.16.1.2 respectivly,,,,,,,,why (it takes the smae network address?

I knew that this issue may be (not sure) related to tftp process between routers , when there are connection between them!!!

Thanks

It sounds like you are fighting the autoinstall feature. Now, I don't know much about the autoinstall feature, so I shall read the document at the same time as you; ;-) Here it is:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/ffun_c/ffcprt1/fcf002.htm#wp1019463

Skimming the doc, I think it will tell you how to get round most of the problems you are experiencing. But there are 30 pages to wade through.

From what I can remember, I can well believe if its partner is 192.168.0.1 then it will take the address 192.168.0.2 automatically. But if the partner is 172.16.1.2, I would have expected it to take the address 172.16.1.1.

I will take a break now while I read the fine doc.

Kevin Dorrell

Luxembourg

Looking at the thread again, I don't think you want autoinstall at all, and it is just confusing everything. I suggest you get rid of it. Takes these steps.

1. Disconnect all external interfaces except the power cable and the console. This step is essential, otherwise we'll never get beyond the problem.

2. Check that the configuration register is 0x2102, and correct it if not.

3. erase start-upconfiguration

4. reload the router, either through command, or power cycle.

5. When it comes up, go through the startup configuration dialog, and answer the questions appropriately.

6. When it offers to save the configuration, say yes

7. I think it will reboot at this point, but I'm not sure. If so, wait for it to come up again. It should not re-enter the setup dialog.

8. Go into config mode, and no service config and no ip domain-lookup

9. Exit config mode and copy run start.

10. Now you can re-connect your external cables and re-boot. It should not autoinstall now, because it has a valid config in NVRAM.

If it has no NVRAM configuration, and it is connected to another router via a serial line, then it will try and autoinstall. To avoid this, keep a configuration in NVRAM.

Kevin Dorrell

Luxembourg

"It sounds like you are fighting the autoinstall feature"

I have never used autoinsatll, I have done it manually (You meant autoinstall for router,,,did not you?).

"This step is essential, otherwise we'll never get beyond the problem."

This is what I believed also,,,but I wanted to know why?

AFAIK, the autoinstall feature is automatic, by default. That's the point of it. It comes into play if you boot a router that has no configuration in NVRAM, and which is connected to a running router via a serial link (or other links in some circumstances).

If you want to avoid autoinstall, you must either make sure you already have a config in NVRAM, or disconnect/shutdown the other end of the serial link.

Kevin Dorrell

Luxembourg

You can limit the hops of a traceroute by not specifying the IP address in the command. That puts you in an interactive specification of traceroute, similar to the extended ping. Then you can specify the minimum TTL, maximum TTL, and number of probes at each TTL, etc. etc..

Kevin Dorrell

Luxembourg

zillah2004
Beginner
Content for Community-Ad