cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
480
Views
0
Helpful
4
Replies
Beginner

Troubleshooting Multilink Group (Serial)

Hi,

I have been asked to look at a colleague's problem and I haven't touched multilink in a while, so when I looked at the initial output form various 'show' commands I think there still might be an issue. He has indicated that everything is working fine now but I have attached the output of the show command after this had been mentioned. With one of the serial interfaces as 'Down Down' and also showing as one member link as 'active' and one as 'inactive'. Any pointers would be appreciated, as I cannot help but think that only one circuit is working.

Attached is the sh int for both serial interfaces, multilink interface and sh ppp multilink. Also attached is the config for the router.

Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
Advocate

Re: Troubleshooting Multilink Group (Serial)

I agree that you seem to have a problem.

(BTW, There is something that does not quite add up in the listings, because your show run show both serial links in shutdown.)

Nevertheless, the most useful output would be to do a debug ppp multilink and debug ppp negotiation, and then bounce the interface that is not joining the bundle correctly, and see what comes out.

Also, if you shut down 0/2/1 and try and bounce 0/2/0, does 0/2/0 then join the multilink bundle OK?

Kevin Dorrell

Luxembourg

4 REPLIES
Advocate

Re: Troubleshooting Multilink Group (Serial)

I agree that you seem to have a problem.

(BTW, There is something that does not quite add up in the listings, because your show run show both serial links in shutdown.)

Nevertheless, the most useful output would be to do a debug ppp multilink and debug ppp negotiation, and then bounce the interface that is not joining the bundle correctly, and see what comes out.

Also, if you shut down 0/2/1 and try and bounce 0/2/0, does 0/2/0 then join the multilink bundle OK?

Kevin Dorrell

Luxembourg

Beginner

Re: Troubleshooting Multilink Group (Serial)

Thats what i thought as well, however i will wait till close of play and then do the debugging of both serial interfaces, bouncing each one to confirm.

I wasn't sure if there was some other config changes as the last time i had done this was with two ISDN lines a few years ago, but it seemed strange that within the 'sh run' both serials are as 'shutdown', however he confirms that everything seems to be working fine!

Thanks for the help.

Rob Brown

Beginner

Re: Troubleshooting Multilink Group (Serial)

Hi Kevin,

Once i checked this it was confirmed that 0/2/0 was actually down and this was due to an fault on the circuit. once this was corrected both were shown as 'active' from the 'sh ppp multi' and from the 'sh run' that both 0/2/0 and 0/2/1 are no longer 'shutdown'. I don't know why with one down that it would still run with one, however show as both serial interfaces as s'shutdown' within the 'running config'.

But tested and all is working fine again.

thanks for the pointers.

Advocate

Re: Troubleshooting Multilink Group (Serial)

That's great news. (And thanks for the rating BTW). In fact, a multilink will work quite happily with only one link, which gives you great flexibility for adding and subtracting links dynamically, for example in a dialup.

When you do auto-QoS on a router, it even deliberately creates a multilink protocol on each single link. That's because one of the side-effects of multilink is the ability to fragment and rê-assemble packets - and small packets make QoS easier to manage.

Kevin Dorrell

Luxembourg

CreatePlease to create content
Ask the Expert- MPLS troubleshooting