cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
990
Views
0
Helpful
8
Replies
mikram
Enthusiast

Trunk encapsulation do1q failure

Hi,

I am trying to add command on 10/100/1000 Card, switch port trunk ^encapsulation dot1q

It does not allow me enable encapsulation on the line card.

Any idea if it is bug?

The hardware card is WS-X6148-GE-TX

The ios version is c6sup2-rp-3k203su-m12.1(26)ES

thanks

8 REPLIES 8
CSCO10662744_2
Beginner

Was that a typo or did you actually put a space between "switch" and "port"?

Should be no space in between, otherwise I can't think of anything why it wouldn't work...

And also make sure you make it a switchport rather than routed interface by doing "switchport".

Being a CCIE (Muhammad Ikram, CCIE #4469 (R&S, Security, C&S and Voice))I guess that was just a typo.

could you please give us more information about this problem?

Vlad

ankurbhasin
Engager

Hi Mikram,

AFAIK when the switch is running in Native mode all the ports are in layer 3 mode which means they are routed ports and to configure trunking you have to first convert them into layer 2 mode with "switchport" command under interface config mode.

And once you have converted these routed ports into layer 2 mode then you can configure trunking encapsulation on the interface with command "switchport trunk encapsulation dot1q"

HTH, if yes please rate the post.

Ankur

I can't remember, do you have to type switchport mode trunk first or do you type switcport trunk encapsultion dot1q first?

That could be stopping you, if it is not a typo

Thanks

senglobe0907
Beginner

Hi,

Since it is IOS ver 12.1 you have to use the following command.

switchport mode dot1q-tunnel

-Senthil.C

"I can't remember, do you have to type switchport mode trunk first or do you type switcport trunk encapsultion dot1q first?"

You need to configure encap type before you can configure mode trunk.

-not related to topic

Sentihil, does HP use Cisco equipment or ProCurve in its headquarters and offices??

i aplogize, i have given tunnel command instead trunk..

sorry guys.

senthil

Actually, the dot1q encapsulation is on by default. Strange thing is that it does not allow you to type the command.Also, there is no option for ISL. Where as on other 10/100 cards, there is option for both ISL and dot1q.

Issue resolved.

Merci