cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
382
Views
5
Helpful
3
Replies
Difan Zhao
Contributor

Can't start guestshell on Cisco 4331 on 16.9.6

I am new to the development and coding in Cisco. I am studying guestshell. I am following this post for instructions. 

https://community.cisco.com/t5/developer-general-blogs/introducing-python-and-guest-shell-on-ios-xe-16-5/ba-p/3661394

When I do "guestshell enable", I got this error: % Error: No interface configuration for guestshell

Then I found a solution on google to specify the management interface for the guestshell. 

 

app-hosting appid guestshell
 vnic management guest-interface 0
end

First of all, when I specify the interface, I got this error. What does it mean, and is there now a replacement command for this?

Dec 18 15:52:56.159 CST: %PARSER-5-HIDDEN: Warning!!! ' vnic management guest-interface 0' is a hidden command. Use of this command is not recommended/supported and will be removed in future.

Now I am able to start the powershell and I can get in the Bash. However, in the base, I don't have any internet connectivity.

#guestshell run bash
$ ping 4.2.2.1
PING 4.2.2.1 (4.2.2.1) 56(84) bytes of data.
From 192.168.30.1 icmp_seq=1 Destination Net Unreachable

My router has three interfaces Gi0/0/0-2. Only traffic sourced from G0/0/1 can reach the Internet. The Mgmt G0 interface is not connected. When I tried to specify other numbers for the interface, I got this error when I enable guestshell

% Error: The guest-interface number [eth(1)] is higher than the expected number of [eth(0)]

Please let me know how to get the powershell running properly in this setup. Thanks!

 

 

3 REPLIES 3
omz
VIP Collaborator VIP Collaborator
VIP Collaborator

They are indeed very helpful! Thanks omz. I am able follow through the steps but I see a small difference in the running-config. The config I put in was "vnic gateway1 ..." but in the running config, it becomes gateway0. In the config, gateway1 is the lowest I can choose. I would assume that vnic gateway1 is app-vnic gateway0, correct?

 

app-hosting appid guestshell
app-vnic gateway0 virtualportgroup 0 guest-interface 0
guest-ipaddress 192.168.1.2 netmask 255.255.255.0
name-server0 8.8.8.8
 

omz
VIP Collaborator VIP Collaborator
VIP Collaborator

I would assume the same ...

Content for Community-Ad

This widget could not be displayed.