Showing results for 
Search instead for 
Did you mean: 

Cisco CSR1KV / 8KV and Filter support with NETCONF


Hello everyone,
I have a question about the support of the netconf specification on two specific virtual routers :

Catalyst 8000V - Cisco IOS XE Software, Version 17.04.01a
Cloud Services Router 1000V - Cisco IOS XE Software, Version 16.09.05

In my lab setup I tried to pass a "filter" to a get-config netconf request:
(using python, ncclient, also tried with yangsuite, same result)

<native xmlns="" />

Using the exact same python script, where I just changed the ip address from one router to another,
the 8000V returns an "unknown element" while the 1000V neatly does what it's supposed to.

As far as I understand "filter" is not a "capability" but an integral part of NETCONF.
I can only conclude that not every device adheres to the full netconf specification.

My questions :
1) is my conclusion correct?
2) Is there somewhere to find which devices / iOS versions support which netconf components and which do not?





Just a fast reply, i must do more research. But the problem is NOT the devices. Its somehow ncclient.


this is what is outputs to both devices :


<rpc xmlns:nc="urn:ietf:params:xml:ns:netconf:base:1.0" message-id="urn:uuid:9b78d885-6adb-463e-93df-4533534873b3">
            <running />
            <native xmlns="" />
The 1Kv accepts this fine, the 8kv doesn't.
The problem is this little thingy:
":nc" (in the rpc tag).
will followup if i understand whats happening !


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: