Showing results for 
Search instead for 
Did you mean: 
Ali mosbah Abdo

CAS Module disconnected

Hello All,

i have NAC Manager and Servers , most of  NAC Servers its Module installed in router 2800 series.

when the power cut off from the router and come back the nac module can not re-connect to the manager automatically , until i login to the router and restart the perfigo service.

i use CAM & CAS 4.5.1 version.

i check all configuration and its correct.

so please any one have an idea why the cas module can not reconnect to the manager automatically when the power is go down and then come again,

Best Regards

Ali Abdo

Federico Ziliotto
Cisco Employee

Hi Ali Abdo,

The issue you are facing might be caused by the known bug CSCsj16366:

Apart from the mentioned workaround, an alternative is to have the CAS NME to sync with the NTP server upon boot.
As this requires some manual editing on the config files on the CAS, it's recommended to back-up the original files before proceeding.

There are two possibilities to do so, the preferred one is the first option below:

1) Edit the "/etc/init.d/perfigo" file.
We need to add the Time check and sync at the end of the "start" section, so you can find where the following section starts in order to figure out where to insert the code.
The following section is "stop" so you should look for the following:

* Please enter the following lines just above the ";;"

    # Clock/NTP setting
    YEAR=$(date +"%Y")
    if [ $YEAR -eq "2006" ]; then
     ntpdate -b
     service perfigo stop
     service perfigo start

The idea about these commands is related to the fact that when the NAC-NME module loses the clock sync, it goes back to May 2006.
The script checks if the year is set to 2006 upon the perfigo service start; if this is the case it will trigger a NTP sync and then it will stop&start the perfigo services.
If, upon the next start the time is not yet in sync, the process will start again with time sync and perfigo stop&start.
Once the time is correctly set, then there will be no more time sync done upon service start.

2) The initial version of the script was the one reported here. Although this worked in a lab environment, it didn't work properly at the customer's site.
Edit the "/etc/rc.d/rc.local" file and add following commands to the bottom of the file:

  #Set Clock using NTP
  ntpdate -b
  exit 0

Hope this helps,


If  this helps you and/or answers your question please mark the question as  "answered" and/or rate it, so other users can easily find it.

dear Fede,

thank you for your replay and help

i will test and feed back you.

best regards

ali abdo