Showing results for 
Search instead for 
Did you mean: 

Disk0: unsupported file system type!


Hi all,

I recently had some trouble with my ASA 5505 in that the running config would not be saved after a reboot. Definately looked like a hardware problem with the flash memory. I have since bought a new flash memory card and copied the contents of the old card to the new card. 1st problem I have is that I can see the image on the new card, but for some reason it wont boot into that image. I get /file not found

I then successfully tftp'd a new image to the device and it boots successfully. I then follow it with a

ciscoasa# config t

ciscoasa(config)# boot system disk0:/asa831-k8.bin

(to ensure it boots from the flash in the future) and I get

WARNING: BOOT variable added, but unable to find disk0:/asa831-k8.bin

I have since tried

ciscoasa# fsck disk0:

Unsupported file system type!

%Error checking disk0: (No such file or directory)

When ever I try to do anything with Disk0: i get the same error. (No such file or directory)

I have also tried putting the old flash card in the ASA and I now get the same response.

Any help anyone can offer would be greatly appreciated.



14 Replies 14


HI Simon,

Try this command:

First check you the file in the flash, by doing:

show flash

and if it is there, do:

boot system flash:/asa831-k8.bin

it shoudl take the command now.



Varun Rao

strangely, if I can:

ciscoasa(config)# dir

Directory of disk0:/

1130   -rw-  100         08:15:37 Jul 20 2011  upgrade_startup_errors_201107200815.log

1128   drw-  0           08:15:37 Jul 20 2011  coredumpinfo

1123   drw-  0           08:15:34 Jul 20 2011  crypto_archive

1113   drwx  0           08:15:23 Jul 20 2011  log

0 bytes total (0 bytes free)


So it sees it there. 0 bytes total (0 bytes free) --- whats that on about?

Hi Simon,

It looks like the device is not detecting the flash card that you have inserted, try checking the specification for it, is it the same as the old one???


Varun Rao

The only thing I can see is the voltage of the new card might be a problem. From what I am reading the new card has a

- Voltage: 3.3V and 5V

Does anyone know what the voltage of the Cisco flash is?

Does anyone know if there is a compatible flash card on the market I can buy (preferrably not the £350 Cisco one). Something a tad cheaper might be nice.

The only other thing I would like to say is that if it is a problem with the Flash not being detected, how come the old card now is producing exactly the same results as the new card?

I put the old Cisco flash in and it does not boot into the image.


On the old flash card, does it not give you anything for show flash and show run boot commands???


Varun Rao

on the old card

show flash

%Error show flash: (No such device)

Can anyone help with this? I have tried a new CF card and am getting the same problem.

I have tried to erase disk0: -- Disk0: is not present

So i have 3 cards now (1 of which is the Cisco CF that came with the device, and they are all acting exactly the same. unfortunately the ASA 5505 box is about 3 weeks out of the 90 day warranty period. If anyone can help it would be greatly appreciated.

Ok so I sorted this out. thanks anyway for your help.

Just out of curiousity could you please let me know how were you able to get past it.


Varun Rao

If itis not a physical problem you can try to Format SC in a Cisco Device (Asa, Switch, Router). After that could recognise it.


I had this problem too and google search brought got me here. I wondered how altussupport solved it.

Tried all the troubleshooting steps from this link:

And i get back to square one after reload .

Turns out the issue is not with the COMPACT FLASH but the RAM !. I had upgraded the ram earlier . Replacing the RAM chip fixed it.

Guessing that's  (altussupport's ) fix...?

hope this helps someone.

Having the same issue. Does anyone found out the answer for this?


I had Cisco send me a new firewall and Im sitting here with two 5520's and 3 x 512mb flash and 2 x 256mb flash. Same error between both firewalls with all the flash. 


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers