cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Ask the Expert- SD-WAN

672
Views
0
Helpful
5
Replies
Highlighted
Beginner

Upgrade NAC from 4.5 to 4.8

Hello everyone

I am about to upgrade a NAC from 4.5 to 4.8 on an implementation that I make in a bank with 1500 users. The upgrade is due because the bank is migrating from PCs to Windows 7

The implementation is in Failover (2) CAS and (2) CAM. the design is Out of Band, Virtual Gateway, and an integration with a Wireless Lan Controller.

I would like to know if when I perform the upgrade of the CAM's and CAS´s to version 4.8 I can still use the Clean Access Agent version 4.5 on the clients???. To perform the migration in several steps

There is a StubAgent for version 4.8? or already included in the Agent 4.8 ??? I Install the StubAgent on all computers in the Bank because they have no administrative rights.

What is the best way to perform the upgrade of the agents that does not impact the users ?

Thank you in advance

Eduardo Navas

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Upgrade NAC from 4.5 to 4.8

Hi Eduardo,

The agent 4.5 is compatible with CAM/CAS 4.8, even if with some restrictions:

http://www.cisco.com/en/US/docs/security/nac/appliance/support_guide/agntsprt.html#wp52084

For example, see also the following notes:

"If you are using CAM/CAS version 4.8 with an Agent version earlier than 4.8.0.32, then either use the Link Distribution requirement or upgrade the Agent to the latest version to use the File Distribution."

"Cisco NAC Agent version 4.5.x is not supported for download from a Release 4.6(1) CAM because the Agent installation file structure is different in Release 4.5(x) as compared to the Agents supported in Release 4.6(1)."

The NAC agent 4.8 does not have any further components needed such as the previous stub for example:

http://www.cisco.com/en/US/docs/security/nac/appliance/configuration_guide/48/cam/m_webagt.html#wp1473153

Regards,

Fede

--

If  this helps you and/or answers your question please mark the question as  "answered" and/or rate it, so other users can easily find it.

5 REPLIES 5
Cisco Employee

Re: Upgrade NAC from 4.5 to 4.8

Hi Eduardo,

The agent 4.5 is compatible with CAM/CAS 4.8, even if with some restrictions:

http://www.cisco.com/en/US/docs/security/nac/appliance/support_guide/agntsprt.html#wp52084

For example, see also the following notes:

"If you are using CAM/CAS version 4.8 with an Agent version earlier than 4.8.0.32, then either use the Link Distribution requirement or upgrade the Agent to the latest version to use the File Distribution."

"Cisco NAC Agent version 4.5.x is not supported for download from a Release 4.6(1) CAM because the Agent installation file structure is different in Release 4.5(x) as compared to the Agents supported in Release 4.6(1)."

The NAC agent 4.8 does not have any further components needed such as the previous stub for example:

http://www.cisco.com/en/US/docs/security/nac/appliance/configuration_guide/48/cam/m_webagt.html#wp1473153

Regards,

Fede

--

If  this helps you and/or answers your question please mark the question as  "answered" and/or rate it, so other users can easily find it.

Beginner

Re: Upgrade NAC from 4.5 to 4.8

Hi Fede,

     Pls let me know whether 4.8 release is a stable version or not?

When I upgraded my CAS , it is showing the BUILD_INFO=Experimental. Pls confirm is this ok or shall I fall back to version 4.7.2.

-JP

Cisco Employee

Re: Upgrade NAC from 4.5 to 4.8

Hi JP,

NAC 4.8 is surely considered to be stable.

The value "BUILD_INFO=Experimental" under /perfigo/build is purely cosmetic.

Regards,

Fede

--

If  this helps you and/or answers your question please mark the question as  "answered" and/or rate it, so other users can easily find it.

Beginner

Re: Upgrade NAC from 4.5 to 4.8

Thank You Fede. Thank you very much for your prompt response.

-JP

Cisco Employee

Re: Upgrade NAC from 4.5 to 4.8

Glad it helped JP.

Feel free to ping us back for any further questions on NAC in the future.

Regards,

Fede

--

If  this helps you and/or answers your question please mark the question as  "answered" and/or rate it, so other users can easily find it.