cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
438
Views
0
Helpful
0
Replies
Highlighted
Beginner

ASR 920 | IOS 16.9.5 | Etherchannel Load Balancing Issues

https://www.cisco.com/c/en/us/td/docs/routers/asr920/configuration/guide/lanswitch/16-8-1/b-lanswitch-etherchannel-xe-16-8-1-asr920.pdf

 

Hi All,

 

I have been having some issues with LACP/Port-channel Load Balancing on a 2 Gigabit etherchannel on an ASR920 4-port and ASR920 24-port.

 

Both of which are running IOS XE 16.9.5. I have tried setting up the Port-channel load balancing and leaving it default (src-mac) and gone through all the other types of load balancing and tried a couple of combinations of each on the individual routers, but mostly I have tried keeping the same on both sides of the port-channels.

 

Here are my configs for each side:

4-port (simulates the edge)

interface Port-channel3
 description LAG to Transport 920 Ports
 mtu 1998
 ip address 11.12.1.90 255.255.255.252
 no ip redirects
 no ip unreachables
 no ip proxy-arp
end

interface TenGigabitEthernet0/0/3
 description lag to transport te0/0/13
 mtu 1998
 no ip address
 lacp port-priority 32601
 channel-group 3 mode active
end

interface TenGigabitEthernet0/0/2
 description lag to transport te0/0/12
 mtu 1998
 no ip address
 lacp port-priority 32600
 channel-group 3 mode active
end

sh run | section port-channel
port-channel load-balance-hash-algo src-dst-mac

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
3       Po3(RU)         LACP     Te0/0/2(bndl) Te0/0/3(bndl)

RU - L3 port-channel UP State
SU - L2 port-channel UP state
P/bndl -  Bundled
S/susp  - Suspended


  Interface                   IHQ       IQD       OHQ       OQD      RXBS      RXPS      TXBS      TXPS      TRTL
-----------------------------------------------------------------------------------------------------------------
* GigabitEthernet0/0/0          0         0         0         0 664146000     56335         0         0         0
  GigabitEthernet0/0/1          0         0         0         0         0         0         0         0         0
* Te0/0/2                       0         0         0         0         0         0 663789000     56317         0
* Te0/0/3                       0         0         0         0         0         0         0         0         0


Here is the 24-port:

interface Port-channel3
 description LAG to Edge 920 Ports 2 & 3
 mtu 1998
 ip address 11.12.1.89 255.255.255.252
 no keepalive
end

interface TenGigabitEthernet0/0/13
 description lag to edge te0/0/3
 mtu 1998
 no ip address
 lacp port-priority 32601
 channel-group 3 mode active
end

interface TenGigabitEthernet0/0/12
 description lag to edge te0/0/2
 mtu 1998
 no ip address
 lacp port-priority 32600
 channel-group 3 mode active
end



EtherChannel Load-Balancing Method:
Global LB Method: flow-based
LB Algo type: Source MAC

 Port-Channel:                       LB Method
    Port-channel3                   :  flow-based (Source MAC)


  Interface                   IHQ       IQD       OHQ       OQD      RXBS      RXPS      TXBS      TXPS      TRTL
-----------------------------------------------------------------------------------------------------------------

* Te0/0/12                      0         0         0         0 666155000     56531         0         0         0
* Te0/0/13                      0         0         0         0     67000         5      5000         5         0
  Te0/0/14                      0         0         0         0         0         0         0         0         0
  Te0/0/15                      0         0         0         0         0         0         0         0         0
* GigabitEthernet0              0         0         0         0      1000         6         0         0         0
  BDI10                         0         0         0         0         0         0         0         0         0
* Loopback0                     0         0         0         0         0         0         0         0         0
* Port-channel3                 0         0         0         0 666222000     56536      5000         6         0



 

I am pinging across the IPs from the edge to the transport's /30 on a public that I am hosting from the edge side. I am hosting a DHCP for public's on the edge that can ping the public (these are not the real IPs in the post), but they do have readability for my testing. 

 

 

I am generating about 650Mbps of traffic accross the gi0/0/0 link that I am connected on via the edge router that I wish would split into the two active etherchannel members, but it will only go along one or the other. 

 

Any advice is welcomed!

 

0 REPLIES 0
Content for Community-Ad