cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2440
Views
0
Helpful
5
Replies

BGP AS Migration

fgonzal
Level 1
Level 1

Hi all.

I've just run into the following problem when configuring Dual Autonomous System Support for BGP.

We handle 2 AS numbers that we intend to merge. 

R1 has the following config:

router bgp 10

no bgp default ipv4-unicast

bgp log-neighbor-changes

neighbor 192.168.0.2 remote-as 10

!

address-family ipv4

  neighbor 192.168.0.2 activate

  no auto-summary

  no synchronization

exit-address-family

R2 is located in a different AS (As20) and we try to pretend it is in AS10 ( from R1 perspective).  R2 config is as follows:

router bgp 20

no bgp default ipv4-unicast

bgp log-neighbor-changes

neighbor 192.168.0.1 remote-as 10

neighbor 192.168.0.1 local-as 10 no-prepend replace-as

!

address-family ipv4

  neighbor 192.168.0.1 activate

  no auto-summary

  no synchronization

exit-address-

It seems that BGP session is properly established with this config.  However as soon as we add a network command to originate a given prefix the bgp session goes down. We see the following when running a debug ip bgp:

*Mar  1 00:08:30.643: %BGP-3-NOTIFICATION: received from neighbor 192.168.0.1 3/3 (update missing required attributes) 0 bytes

*Mar  1 00:08:30.643: BGP: 192.168.0.1 went from Established to Closing *Mar  1 00:08:30.643: %BGP-3-NOTIFICATION: received from neighbor 192.168.0.1 3/3 (update missing required attributes) 0 bytes
*Mar  1 00:08:30.643: BGP: 192.168.0.1 went from Established to Closing

Then the BGP session is established again but it goes down inmediately.....

I haven't a clue about where the problem might be.  Any suggestion?

Thanks

Flo.

5 Replies 5

rsimoni
Cisco Employee
Cisco Employee

Hi Flo,

it sounds like a buggy behavior.

Can you tell which platforms/IOS your routers are?

Can you also add some more chatty debugs (on the routers closing the session).

deb ip bgp events

deb ip bgp updates

Riccardo

Hi Riccardo

Thanks for your comments.

I've just run the ip bgp events/updates debug and this is what I can see in both sides:

R1  ( the router that receives the update)

*********************************************************************************

*Mar  1 00:06:38.803: BGP: 192.168.0.2 Update missing attributes, flags 0x7

*Mar  1 00:06:38.807: BGP: 192.168.0.2 reset due to BGP Notification sent

*Mar  1 00:06:38.807: %BGP-5-ADJCHANGE: neighbor 192.168.0.2 Down BGP Notification sent

*Mar  1 00:06:38.807: %BGP-3-NOTIFICATION: sent to neighbor 192.168.0.2 3/3 (update missing required attributes) 0 bytes

R1# FFFF FFFF FFFF FFFF FFFF FFFF FFFF FFFF 0035 0200 0000 1940 0101 0040 0204 0201 000A 4003 04C0 A800 0280 0404 0000 0000 2002 0202 02

*Mar  1 00:06:38.927: BGP: service reset requests

*Mar  1 00:06:38.927: BGP: service reset requests

R2(config)#router bgp 20

R2(config-router)#net

R2(config-router)#network 2.2.2.2 mask

R2(config-router)#network 2.2.2.2 mask 255.255.255.255

R2(config-router)#

*Mar  1 00:06:38.179: BGP(0): route 2.2.2.2/32 up

*Mar  1 00:06:38.179: BGP(0): nettable_walker 2.2.2.2/32 route sourced locally

*Mar  1 00:06:38.183: BGP(0): 192.168.0.1 send UPDATE (format) 2.2.2.2/32, next 192.168.0.2, metric 0, path Local

*Mar  1 00:06:38.251: %BGP-3-NOTIFICATION: received from neighbor 192.168.0.1 3/3 (update missing required attributes) 0 bytes

*Mar  1 00:06:38.255: BGP: 192.168.0.1 reset due to BGP Notification received

*Mar  1 00:06:38.255: %BGP-5-ADJCHANGE: neighbor 192.168.0.1 Down BGP Notification received

R2(config-router)#

*Mar  1 00:06:38.255: BGP: service reset requests

*Mar  1 00:06:38.259: BGP: service reset requests

*Mar  1 00:06:38.259: BGP: service reset requests

*Mar  1 00:06:38.259: BGP: service reset requests

R2(config-router)#

*Mar  1 00:06:39.675: BGP: Regular scanner event timer

*Mar  1 00:06:39.675: BGP: Performing BGP general scanning

*Mar  1 00:06:39.675: BGP(0): scanning IPv4 Unicast routing tables

*Mar  1 00:06:39.675: BGP(IPv4 Unicast): Performing BGP Nexthop scanning for general scan

*Mar  1 00:06:39.675: BGP(0): Future scanner version: 5, current scanner version: 4

*Mar  1 00:06:39.679: BGP(2): scanning VPNv4 Unicast routing tables

*Mar  1 00:06:39.679: BGP(VPNv4 Unicast): Performing BGP Nexthop scanning for general scan

*Mar  1 00:06:39.679: BGP(2): Future scanner version: 5, current scanner version: 4

*Mar  1 00:06:39.679: BGP(4): scanning IPv4 Multicast routing tables

*Mar  1 00:06:38.803: BGP: 192.168.0.2 Update missing attributes, flags 0x7
*Mar  1 00:06:38.807: BGP: 192.168.0.2 reset due to BGP Notification sent
*Mar  1 00:06:38.807: %BGP-5-ADJCHANGE: neighbor 192.168.0.2 Down BGP Notification sent
*Mar  1 00:06:38.807: %BGP-3-NOTIFICATION: sent to neighbor 192.168.0.2 3/3 (update missing required attributes) 0 bytes
R1# FFFF FFFF FFFF FFFF FFFF FFFF FFFF FFFF 0035 0200 0000 1940 0101 0040 0204 0201 000A 4003 04C0 A800 0280 0404 0000 0000 2002 0202 02
*Mar  1 00:06:38.927: BGP: service reset requests
*Mar  1 00:06:38.927: BGP: service reset requests

*********************************************************************************

R2 (router that is configured with the "local-as no-prepend replace-as").  As soon as I configured the network 2.2.2.2 mask 255.255.255.255 command to announce a loopback interface to the peer, everything is triggered. These are the debug messages:

***************************************************************************

R2(config)#router bgp 20
R2(config-router)#net
R2(config-router)#network 2.2.2.2 mask
R2(config-router)#network 2.2.2.2 mask 255.255.255.255
R2(config-router)#
*Mar  1 00:06:38.179: BGP(0): route 2.2.2.2/32 up
*Mar  1 00:06:38.179: BGP(0): nettable_walker 2.2.2.2/32 route sourced locally
*Mar  1 00:06:38.183: BGP(0): 192.168.0.1 send UPDATE (format) 2.2.2.2/32, next 192.168.0.2, metric 0, path Local
*Mar  1 00:06:38.251: %BGP-3-NOTIFICATION: received from neighbor 192.168.0.1 3/3 (update missing required attributes) 0 bytes
*Mar  1 00:06:38.255: BGP: 192.168.0.1 reset due to BGP Notification received
*Mar  1 00:06:38.255: %BGP-5-ADJCHANGE: neighbor 192.168.0.1 Down BGP Notification received
R2(config-router)#
*Mar  1 00:06:38.255: BGP: service reset requests
*Mar  1 00:06:38.259: BGP: service reset requests
*Mar  1 00:06:38.259: BGP: service reset requests
*Mar  1 00:06:38.259: BGP: service reset requests
R2(config-router)#
*Mar  1 00:06:39.675: BGP: Regular scanner event timer
*Mar  1 00:06:39.675: BGP: Performing BGP general scanning
*Mar  1 00:06:39.675: BGP(0): scanning IPv4 Unicast routing tables
*Mar  1 00:06:39.675: BGP(IPv4 Unicast): Performing BGP Nexthop scanning for general scan
*Mar  1 00:06:39.675: BGP(0): Future scanner version: 5, current scanner version: 4
*Mar  1 00:06:39.679: BGP(2): scanning VPNv4 Unicast routing tables
*Mar  1 00:06:39.679: BGP(VPNv4 Unicast): Performing BGP Nexthop scanning for general scan
*Mar  1 00:06:39.679: BGP(2): Future scanner version: 5, current scanner version: 4
*Mar  1 00:06:39.679: BGP(4): scanning IPv4 Multicast routing tables

***********************************************************************************

Regarding the IOS, I'm currently using  Version 12.4(25d),

Cheers!

Flo.

I think I've just found out what the problem is.  This feature is only available to eBGP and it is quite reasonable.

*****

This feature allows a router to appear to external peers as a member of another autonomous system for the purpose of autonomous system number migration.

*******

I've just configured it and it works.  I think we can use a private AS and then we can remote the private as when advertising it to the internet.

Thanks for your help.

Flo.

indeed..and it makes perfect sense.

good that you spotted it 

local-as is the best and least complex command when migration of AS is concern.

Regards,
Smitesh