cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
561
Views
5
Helpful
4
Replies
Carlos A. Silva
Participant

[BNG - XRV9000 over Bundle]

Hi, 

 

For a long time now, I've had this problem and just now came around to asking this question. I have a working dual-stack BNG running on an XRV 9000. It works.

 

It's currently working while being configured on a physical/logical interface, Gig0/0/0/0.100. When I try to use the same exact configuration, but change it to a Bundle interface, everything except the data plane works. 

 

When I'm with Gig0/0/0/0.100, I get to ping everything. When I move the exact same configuration to a Bundle interface (BE100.100), everything looks right, except pings don't work, even directly from the BNG to the client asking for DHCP.

 

I'm not posting configurations because I have a working one and didn't see the point; maybe is just a matter of me missing a specific command that makes it work on an XRV 9000 over Bundle interface. Any ideas?

 

Thanks!

c.

4 REPLIES 4
Harold Ritter
Cisco Employee

Hi @Carlos A. Silva ,

 

This should work. What version of XRv9000 are you running? What device is at the other end of the port-channel? How is the bundle configured?

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Hi, Harold!

Thanks a lot for your reply. Here’s the info:

RP/0/RP0/CPU0:BNG-1#show ver
Wed Jun 9 20:57:58.256 UTC
Cisco IOS XR Software, Version 7.0.1
Copyright (c) 2013-2019 by Cisco Systems, Inc.


Attached to the BNG is a simple L2-switch with a 802.1q trunk .

The Bundle-related configuration is:

interface Bundle-Ether100.100
! this below, is the exact same configuration I use with Gig0/0/0/0.100
ipv4 point-to-point
ipv4 unnumbered Loopback100
arp learning disable
ipv6 enable
service-policy type control subscriber NOAUTH
load-interval 30
encapsulation dot1q 100
ipsubscriber ipv4 l2-connected
initiator dhcp
!
ipsubscriber ipv6 l2-connected
initiator dhcp
!
!
interface GigabitEthernet0/0/0/0
bundle id 100 mode active


Like I said in my original post. Control plane works just fine with physical (Gig0/0/0/0) or Bundle interface. BNG registers the IP session and adds it to its table in both cases, so L2 matches and works.
Data-plane, on the other hand, works in just one of those two cases. When I configure the vBNG with a physical interface I’m able to ping from the device that I’m using to simulate an ONT to the BNG and everything beyond it, so it does what we expect. When I use the configuration above in a Bundle, that same device does not ping anything.

Hopefully you can help me out.
Thanks!
c.




Harold Ritter
Cisco Employee

Hi @Carlos A. Silva ,

 

It looks like the issue is due to the command "arp learning disable" being configured on the bundle interface. Can you remove this command and try to ping again.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

I did try that before, Harold, but here’s a capture from a minute ago:

RP/0/RP0/CPU0:BNG-1#show subscriber session all
Thu Jun 10 22:39:48.917 UTC
Codes: IN - Initialize, CN - Connecting, CD - Connected, AC - Activated,
ID - Idle, DN - Disconnecting, ED - End

Type Interface State Subscriber IP Addr / Prefix
LNS Address (Vrf)
--------------------------------------------------------------------------------
IP:DHCP BE100.100.ip2 AC 192.168.1.18 (default)
RP/0/RP0/CPU0:BNG-1#LC/0/0/CPU0:Jun 10 22:40:03.347 UTC: fib_mgr[260]: %ROUTING-FIB-4-RETRYDB_NONEMPTY : 1 FIB object(s) have been in IPv4 retry queue for at least 120 seconds

RP/0/RP0/CPU0:BNG-1#show run int be100.100
Thu Jun 10 22:40:11.292 UTC
interface Bundle-Ether100.100
ipv4 point-to-point
ipv4 unnumbered Loopback100
ipv6 enable
service-policy type control subscriber NOAUTH
load-interval 30
encapsulation dot1q 100
ipsubscriber ipv4 l2-connected
initiator dhcp
!
ipsubscriber ipv6 l2-connected
initiator dhcp
!
!

RP/0/RP0/CPU0:BNG-1#
ONT#ping 172.16.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
ONT#


One other thing I failed to mention: since data-plane seems to be broken, IPv6 session never registers. As you can see only IPv4 session is added to the table.

Now, since you mentioned arp, I hadn’t looked at this before, but the device simulating the ONT never solves arp for the BNG, so that’s what’s seems to be the problem. BNG is not answering arp requests coming from the ONT. Why it happens with BE and not phy-intf, and why ipv6 is not even registering, no idea at the moment.

ONT#show arp vrf vpn1
Protocol Address Age (min) Hardware Addr Type Interface
Internet 192.168.1.1 0 Incomplete ARPA
Internet 192.168.1.19 - 0000.0000.0100 ARPA BDI100
ONT#