cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1729
Views
5
Helpful
6
Replies
vialikasielec
Beginner

Bridge-domain and trunk configuration on ES20 card.

Hello.

I have two 7609-S boxes equipped with ESM20G cards and WS-X6748-GE-TX cards. A trunk is configured on ports of WS cards between these devices. A very important system is to be connected with two optical links to both devices via ES20 cards for redundancy. I consider configuring it using EVC framework in the following way:

service instance -> bridge-domain XXX -> interface VLAN XXX and enable HSRP on my devices.

I am not sure what is the structure of conecting system so I would like to have some kind of L2 connectivity between my devices for this connection. For other connections made using ports on WS card a dedicated VLAN is allocated for every one of them and then this VLAN is simply put in trunk between devices. Can I simply add vlan XXX to the list of VLANs allowed on the WS-card-based-trunk or do I have to utilize some completely different solution? Links to any related documentation are appreciated. Tomorrow I am going to test this configruation any way but I would like to have some backup solution in case this will not work.

Thanks in advance,

Andrew.

6 REPLIES 6
chanukavitanachy
Beginner

Hi Andrei,

Im having the same dilemna and im wondering if you were able to find a solution for this?

I need to support HSRP on a vlan interface with bridging over port channel bundled interface between routers.

im trying this but i cant seem to get this to work.

----R2----
!
interface Vlan10
ip vrf forwarding BOB
ip address 10.1.1.2 255.255.255.248
standby 1 ip 10.1.1.1
standby 1 priority 110
standby 1 preempt
end
!
interface Port-channel1
no ip address
service instance 10 ethernet
  encapsulation dot1q 10
  bridge-domain 10
!


--- R2----
!
interface Vlan10
ip vrf forwarding BOB
ip address 10.1.1.3 255.255.255.248
standby 1 ip 10.1.1.1
end
!
interface Port-channel1
no ip address
service instance 10 ethernet
  encapsulation dot1q 10
  bridge-domain 10
!

BR//

Chanuka

Hi.

I did not try to configure service instance on port-channel interface but comparing to single GE interface configuration it seems that you forgot to add "rewrite ingress tag pop 1 symmetric" command under ethernet service instance configuration. Try adding it on both devices.

HTH,

Andrei.

Hi Andrei!,

Cheers, Yea i just picked that missing line and got it working.

Why do we have to do this though? if the incoming encapsulation matches the bridge domain, why the need to pop and rewrite?

Do you think that using service instance in this case is a suitable way of addressing this issue?

BR//

Chanuka

Just keep in mind, you cannot use service instance on a port that is in port-channel mode or has an ip address.

Regards

Jude

Hi Jude,

You absolutely CAN use service instance on a port channel or interface with many ip addresses on it.  Im doing this right now.

BR//

Chanuka

Hello guys

I have the same question.

Please any one help with it

Why do need to do rewrite tag if the incoming encapsulation matches  the bridge domain?

and we don't need to change the tag?

Thanks in advance

br

Malik