cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3806
Views
5
Helpful
21
Replies
Highlighted

IOS XRv 9000 Gigabit Ethernet Interfaces missing

Good day,

 

I have installed IOS XRv 9000 from an OVA downloaded from the Cisco site.

I have tried many different versions and all of them do not have any interfaces except for Mg0 after booting. 

I am importing the OVA into ESX.

 

Any help would be appreciated.

Current version: Cisco IOS XR Software, Version 6.2.25

Kind Regards,

Hendrik

21 REPLIES 21
Highlighted

@hendrik.oosthuizen - That is not the root cause. I am running these on Xeon processors and still have the interface limit. What image are you using? Last image I tried was xrv9k-fullk9-x-6.2.25.qcow2

Highlighted

Hi,

6.3.2.

Using "-cpu host" option seems to work.

Highlighted

Hi Hendrik,
The CPU is an Intel one… I saw that for some people adding “-cpu host” work for them.
I’m still searching for me…
Highlighted

Any Fix? I'm having the same problem. If I apply -cpu host the VM crashes.  

Highlighted

Hi we had the same problem with VIRL 1.6 which was a new installation. We saw that when you connect with VM there is no IOSXrv 9000 on the node list. And if we used this node type and select IOS XRv 9000 as IOS version it fails (falls in to the admin user setup which is mentioned in the release notes as a bug). After setting up a user, there was a no ethernet interfaces on the device. Then we fetch the node list on VM maestro and than we saw the IOSXRv 9000 as a node. After using the IOSXRv 9000 as a node type there was no problem.

Highlighted
Beginner

I was having this same issue and it was related to the "EVC mode" of the ESX cluster. I changed the VMware EVC mode to Intel "Nehalem" Generation and finally was able to see the interfaces. 

 

One thing that helped me find this solution was running "show controller dpa log stdout" which showed the log message "binary requires CPU with SSE4.2 extensions" repeating. 

 

I was not seeing the "Cisco IOS-XRv 9000 Centralized Line Card" until I changed the EVC mode on the ESX cluster to Nehalem.

Highlighted

Hi,
Interesting, thanks for sharing.