cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1764
Views
5
Helpful
6
Replies
Highlighted
Beginner

MGSCP configuration on ASR9K

Hi,

Im in the process of doing a design for our SCE deployment and was looking at how I would load balance traffic across 2 SCE2k’s on 2 ASR9K’s and have come across a pretty good explanation in the ASR9K configuration guide on interface bundling using MGSCP. However when I look at the sample configurations provided they look wrong. Can someone please have a look at these and let me know if they are right or wrong.

The topology as I understand it would look like this

|----{SCE}-----|

{access vrf}--- |------------------|-----{core vrf}

                        |----{SCE}-----|

The config from the guide looks as follows

http://www.cisco.biz/en/US/docs/routers/asr9000/software/asr9k_r4.1/interfaces/configuration/guide/hc41lbun.pdf

Cisco Example with OSPF Routing see page 65

vrf core

address-family ipv4 unicast

import route-target 1:1

export route-target 1:1

!

vrf access

address-family ipv4 unicast

import route-target 1:1

export route-target 1:1

interface GigabitEthernet0/2/0/1

vrf access

ipv4 address 10.10.1.4 255.255.255.0

_

interface GigabitEthernet0/2/0/9

vrf core

ipv4 address 10.20.1.4 255.255.255.0

router ospf 100

vrf core

router-id 10.20.1.2

area 0

interface Bundle-Ether200

interface GigabitEthernet0/2/0/9

vrf access

router-id 10.10.1.2

area 0

interface Bundle-Ether100

interface GigabitEthernet0/2/0/1

With this configuration I have the following questions

1.     Why are they using the same RD for both VRF’s this will cause the routes from each vrf to be visible to the other without the need to pass through the SCE?

  1. why      are the interfaces on different L3 Subnets? This will prevent layer 3      connectivity and OSPF will not be able to form  neighbor relation ships

Should I rather be using my config as below or wont this work and why


vrf core

address-family ipv4 unicast

  import route-target 1:1

  export route-target 1:1

!

vrf access

address-family ipv4 unicast

  import route-target 1:2

  export route-target 1:2

interface GigabitEthernet0/2/0/1

vrf access

ipv4 address 10.10.1.1 255.255.255.252

_

interface GigabitEthernet0/2/0/9

vrf core

ipv4 address 10.10.1.2 255.255.255.252

router ospf 100

vrf core

  area 0

  interface GigabitEthernet0/2/0/9

vrf access

  area 0
   interface GigabitEthernet0/2/0/1

If I should stick to the config from the cisco guide please explain to me the traffic flow as Im having a hard time seeing this.

There doesn’t seem to be much information available on how to setup MGSCP and the samples that I get all look different

Thanks for your help

Pieter

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Sure here is the design doc. Not sure if you have it already.

https://supportforums.cisco.com/docs/DOC-17227

Shelley.

View solution in original post

6 REPLIES 6
Highlighted
Beginner

Hasn't anyone done this before? can anyone please post their configs to review?

thanks

Highlighted

Hi,

Cisco has tested this scenario only with the 6500 thus far.

The only tricky portion of this feature is the way etherchannels loadbalance on the wires. There are requirements that 1 card on the 6500 be a DFC based so that it can have its own (differnet) loadbalancing mechanism than the rest of the chassis. If the ASR9k can do this you can certainly have the MGSCP configured on the ASR9k.

Shelley.

Highlighted

Thanks Shelley,

Do you have a working example of this on the 6500 with two VRF's? I havent been able to find any detailed examples of the traffic flow in this setup.

Thanks

PJ

Highlighted

Sure here is the design doc. Not sure if you have it already.

https://supportforums.cisco.com/docs/DOC-17227

Shelley.

View solution in original post

Highlighted

Thanks, I didnt have this guide. This realy cleared up some things form me

Highlighted

Dear All,

 

the provided document explain MGSCP with 6500/7600 using Vlan Mapping (L2).

has anyone figured out how to put this to work using VRFs with ASR 9K ??

the documents does not provide designs , only configuration of 2 VRF Access and Core !

 

waiting forward for your answer.

 

Taoufik

Content for Community-Ad

This widget could not be displayed.